Windows 8 and 8.1 Forums


Problem with pnputil syntax

  1. #1


    Posts : 1,875
    Windows 10 Pro Prieview x64

    Problem with pnputil syntax


    Hi, I'm trying to install Intel Wifi Drivers using pnputil.exe with the command below but it appears I have the syntax wrong and it just displays the help information. It seems though that what I've entered in bold is the same as the MS example.

    Does anyone know where I'm going wrong?

    C:\>pnputil.exe -i -a C:\Users\Administrator\Downloads\Netwew00.INF
    Microsoft PnP Utility
    Usage:
    ------
    pnputil.exe [-f | -i] [ -? | -a | -d | -e ] <INF name>
    Examples:
    pnputil.exe -a a:\usbcam\USBCAM.INF -> Add package specified by USBCAM.INF
    pnputil.exe -a c:\drivers\*.inf -> Add all packages in c:\drivers\
    pnputil.exe -i -a a:\usbcam\USBCAM.INF -> Add and install driver package
    pnputil.exe -e -> Enumerate all 3rd party packages
    pnputil.exe -d oem0.inf -> Delete package oem0.inf
    pnputil.exe -f -d oem0.inf -> Force delete package oem0.inf
    pnputil.exe -? -> This usage screen

      My System SpecsSystem Spec

  2. #2


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    for what chip? they should have their own installer and you can usually just right click the inf's and choose install. also you should try a little c: vs a big C: perhaps.
      My System SpecsSystem Spec

  3. #3


    Posts : 1,875
    Windows 10 Pro Prieview x64


    It's for Intel Centrino Ultimate - N 6300 N. Unfortunately I can't right click as I don't have a GUI. I only have explorer++ not file explorer. I'm trying to get wireless to work on Hyper V Server 2012 and then run my 8.1 in a VHD inside it...

    I tried the small c but got the same result. I also tried changing the directory to downloads and all other combinations I could think of.
      My System SpecsSystem Spec

  4. #4


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    Oh yeah I've ran into that issue with installing hyper v without the gui as well I'll look more into it tomorrow and get back to you. I'm not familiar with explorer++ is it by the same people who make the great notepad++?
      My System SpecsSystem Spec

  5. #5


    Posts : 1,875
    Windows 10 Pro Prieview x64


    Thanks. Not sure if it is the same people - here is their website Explorer++ - A small and fast file manager for Windows
    I'd not use it instead of file explorer but it is far far better than nothing.

    I installed it along with some other Hyper V GUI tools from here: (installation instructions here Hyper-V 2012 Core GUI . It works pretty well and gives you a sort of task bar as well. Firefox wouldn't install so I had to use chrome standalone installer which works fine (with ethernet).

    Iwas trying to follow the instructions for installing drivers from here Installing Windows Hyper-V Server 2012 with an Asus P8Z68-V Pro Motherboard? ? www.telnetport25.com when I ran into my PnPUtil problem. I also tried downloading devcon.exe but haven't had any luck with wifi yet.

    Sorry for all the links - I want to remember them also
      My System SpecsSystem Spec

  6. #6


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    Np the links are good most of my non gui work has been in esx and esxi not hyper v all my hyper v has been on 2012 datacenter ed. With a gui so I'll take a look tomorrow since I'm gonna go to bed right now lol. Also it might help to put the model of the server/laptop your using I looked for info but it seems lenovo makes multiple x201 versions like the x201 xxxx ect.
      My System SpecsSystem Spec

  7. #7


    Posts : 1,875
    Windows 10 Pro Prieview x64


    Specs updated
      My System SpecsSystem Spec

  8. #8


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    i take it you have modified that driver for it to allow installation on windows server 2012? also it looks like explorer wont run without a gui how did you use it in the first place? it also seems that windows default drivers should be able to use that card too. have you made a vhd with a system yet, it might just understand the hardware and then you can install the drivers they have for that particular os.

    you might have an easier time if you were to set up remote access to it Configure Hyper-V Server 2012 for Remote Management and use server manger on another computer to control it that is how we always have done it since you can still use power shell if you need to but can also use more tools in the manager i think it even has a tool for installing drivers. i cant remember if a separate license is needed for server manger but i don't think so. sorry im not being much help, i do think that a vhd will just be able to use that nic once the VM has the drivers for its own os though.
    look forward to your progress.
    Last edited by rvcjew; 16 Nov 2013 at 14:58.
      My System SpecsSystem Spec

  9. #9


    Posts : 1,875
    Windows 10 Pro Prieview x64


    I haven't modified the driver as PnpUtil wouldn't work but I'm certainly going to have to.

    As for explorer++, I downloaded startup.zip from link above, unzipped it and put it on usb. Then from HyperV server copied it to root of C: using

    robocopy /s e:\startup c:\startup
    cd c:\startup
    setup

    I then download chromeinstaller.exe and installed using explorer++ by clicking on it and also downloaded devcon.exe and copied this to c:\windows\system32

    After reboot I had explorer++, corefig and a taskbar. I added an autostart entry for chrome.exe and "sconfig Starts ExplorerApp.cmd" in the registry so explorer++ and chrome start automatically.

    As you suggested I tried in virtual machine (running 8.1 host and server as guest VM) and the wireless works. I think the VM sees it as ethernet in fact. When I boot direct into Server it doesn't.

    devcon can see the card and says it is enabled but I can't use it. I think I'm missing a WLAN service.

    According to here Wireless LAN Service feature not available in Hyper-V standalone server wifi is not supported on the free server software. I got the same error as the guy on that thread trying to install it:

    "install-windowsfeature -name wireless-networking" but appeared an error message:ArgumentNotValid: The role, role service, or feature name is not valid: 'wireless-networking'. The name was not found.
    As for remotely managing it I can't unfortunately as I've only got one computer so if I boot into server that is where I am.

    What I was hoping to do (and it is only for my interest and learning - no real practical reason except I could easily move my 8.1 environment to different hardware) is to run hyper V server direct on my laptop and then run my current 8.1 in VHD inside that. Perhaps it will not work and certainly I'm not going to buy a full server license just to try it.

    I'll update this if I can get it to work however
      My System SpecsSystem Spec

  10. #10


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    yeah i get what your trying to do i hope you have lots of ram cause without it your not going to get 8.1 loading anything lol since you need about 2Gb for hyperv at least i would think before you allocate for the vhd even with just core. what your doing is what i did when learning esxi (used the core and managed it remotely) and vsphere 5. i personally don't think using the core is smart for your setup but talking about licensing is the core free to use or something? when i learned hyper v it was on server 2012 with full gui and we used another computer to manage it since i apply that knowledge to like server clusters and use server manger to control a cluster (windows licensing scheme for clusters is crazy expensive).
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Problem with pnputil syntax
Related Threads
Here is my problem When i write my DVD-R with Nero/Imgburn/Burnaware it says burnt successful but it fails to verify and even dvd is blank when i reinsert in laptop and my friends computer. I have tried to burnt at slower speeds but still same problem.:rolleyes: My dvd drive reads other DVDs...
When I try to check for a solution to a problem (Control Panel\System and Security\Action Center\Problem Reports) a warning appears telling me to connect to the Internet or to try later… 44832 The problem is that I am connected to the Internet while I receive this message and now I do not see...
I am looking for the correct DOS syntax to achieve the following: In folder "C:\ABC": 1) Delete ALLA folders, including their content. 2) Delete any files that are in the root of "C:\ABC" I have tried a combination of RMDIR and DEL but I am not managing to delete folders. I can't find...
I have 2 issues. I don't know if they are related somehow. 1. I installed PrivaZer and deleted it. It still shows up on the right click context menu. I tried to reinstall it and deleted it again. I still have that problem. I even restarted the computer. How can I get rid of the entry? 2....
So i'm trying to delete this file i have in my downloads folder, which is a normal .avi file. however, this file is really broken, it wont delete. I suspect this file makes my folder not showing thumbnails and acting slow and sometimes wont show anything at all, just a loading bar thing. i...
Hey, running Windows 8.1 64bit, Asrock Z87E-ITX mobo, Intel 4770K Problem 1: When i shot down my pc via windows Shot Down button pc doesn't go Off. I see Windows Off screen, screen goes black but pc still running. Solution? Problem 2: When my pc goes sleep or monitor goes sleep i can't...
I had no problems with Customer Preview, everything worked, but, I must say that this Release Preview is another story all together. My PC hardware configuration is unchanged since installing Windows 7 when it came on to the market. 1. Doing a clean install did not install a clean...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook