Windows 8 and 8.1 Forums


Acer > no BIOS pass test beep

  1. #1

    Acer > no BIOS pass test beep


    Hi all. Went to boot up my Acer this evening to no avail. I can see it start to cycle through searching the DVD drive and see the read/right red LED light for the hard drive go on for about 5 seconds, then nothing. No BIOS test pass beep. I know that it beeps once for passing, then continues to boot. I hear the fans going. but that's it.

    I took the side panel off and reseated all the connections including the Mem strips. At one time I left a strip out intentionally for a continuous beep, which is what it's suppose to do.

    It was running great earlier today. Shut it down with the physical power button as I always do.

    I'm searching the Inet to no avail. Any thoughts?

      My System SpecsSystem Spec

  2. #2


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    Nothing on the monitor? No BIOS POST screen?
    Here is what I normally do in a situation like this.
    Unplug anything not needed for the PC to POST, all you need is the bare minimum.
    Power supply, motherboard, CPU with heat sink, one stick of RAM, Video card (onboard if it has it), Monitor and keyboard.
    If it will now POST add parts back in one at a time until it quits again. If it won't POST start swapping parts. I'd try a spare power supply first. Then Video Card, and RAM etc.
      My System SpecsSystem Spec

  3. #3


    Quote Originally Posted by alphanumeric View Post
    Nothing on the monitor? No BIOS POST screen?
    Here is what I normally do in a situation like this.
    Unplug anything not needed for the PC to POST, all you need is the bare minimum.
    Power supply, motherboard, CPU with heat sink, one stick of RAM, Video card (onboard if it has it), Monitor and keyboard.
    If it will now POST add parts back in one at a time until it quits again. If it won't POST start swapping parts. I'd try a spare power supply first. Then Video Card, and RAM etc.
    Thank you for answering, Kerry.

    Nothing on the monitor. No BIOS screen post. Just What I stated above. I will perform your process of elimination. It'll have to wait for later on today. I have to set some kitchen cabinets today. This morning I'm using an old Dell tower with XP. Man this thing is slow!
      My System SpecsSystem Spec

  4. #4


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Also try removing all power & the BIOS battery.
      My System SpecsSystem Spec

  5. #5


    Thanks, guys. It is fixed. I think it turned out to be that the LAN card wasn't seated correctly. I unhooked all other but that, thinking it possibly couldn't be it, but I had no post until I did. Put each item in one by one and all is well, including LAN. Something wasn't seated correctly.

    While I was at it, I changed the CMOS battery.

    Thanks again.
      My System SpecsSystem Spec

  6. #6


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    betting it was the cmos not the nic but who knows glad its fixed.
      My System SpecsSystem Spec

  7. #7


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by rvcjew View Post
    betting it was the cmos not the nic but who knows glad its fixed.
    Thanks. Odds would have it it was the battery since it's an older machine and has never been changed, but it didn't post immediately after changing. It may take a few cycles? I dunno. Strange that it didn't post until after pulling the card.

    Lol! First thing I saw in my eyes after it wouldn't boot > <($ $)> and that dreadful sinking feeling!
      My System SpecsSystem Spec

  9. #9


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


      My System SpecsSystem Spec

Acer > no BIOS pass test beep
Related Threads
OK! This all started Sunday morning, 5 days now of trying everything I've read, I'm throwing in the hat to you fine folks :cry:. I have a Gateway desktop SX2110G with a D1F-AD mobo. My HD is ST5000DM002-1BD142 500GB, AMD Radeon HD 7310 Graphics, and 4GB DDR3 memory. I hit the power button and...
Hi, can someone please give me a step by step guide for Step1 - C IF YOU ARE IN DOS / FREEDOS I have burned the driver files as a data DVD but don't know how to run the disk and downgrade the bios in dos and the model I have came with no windows os thank you ...
Hi all, I'm terribly confused and I hope someone can help me figure out what I"m doing wrong. These are the steps I've taken-- OS Win 8, pre-installed by Acer. 1) Make recovery USB using the Acer recovery wizard, with the laptop in stock configuration. 2) Install msata as secondary drive 3)...
Install custom BIOS in my Acer Aspire v5-571g in Performance & Maintenance
I have an Acer Aspire v5-571g(53334g50makk) Ultra Book. With WIndows 8.1 Installed. The current bios in it is completely useless, it does not provide any options for me to alter, not even temperatures of the processor, graphic card etc... there for I want to know if I can install a different...
Id like to start of by going ahead and admitting i was an idiot for doing what i did, Give a little bit of a back story etc. I had been dual booting between Linux Mint 16 and Windows 7 x64 Ultimate in the following partition scheme on my Acer Aspire AO756 1.4Ghz Celeron Processor, 4GB ram,...
Acer To Pass on Windows RT in Windows 8 News
Acer Chooses To Pass on the Current Version Windows RT | Maximum PC
Ok so I'm building my mom's business computer and everything works, I found the PSU cord wasn't 100% plugged in fixed that I booted once bios she beeped and now I got nothing. I reset cmos and power but still nothing. I got a lemon didn't I? I'll try a new battery too but this really sucks and I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook