Windows 8 and 8.1 Forums


Win 8.1 USB Automount

  1. #1


    Posts : 1
    Win 8.1 Win 7 Ubuntu

    Win 8.1 USB Automount


    I recently updated 2 laptops to Win 8.1 and noticed a couple of things. The first is that my Seagate external USB drive sometimes will not show up even though it is properly listed in Device manager and Disk Manager. I have to manually assign a drive letter to it and then it works fine. The external drive is being connected to a USB 3 port and uses external power.
    From the command line I also noticed that Automount is shown as disabled on both laptops. I thought that was supposed to be enabled by default.
    Any thoughts?

      My System SpecsSystem Spec

  2. #2


    Click image for larger versionYes that should be enabled
    Go to Command Prompt runs as administrator
    CD\diskpart
    Automount, results will show either auto mount is enabled or disabled
    automount enable, results will show auto mount is enabled

    exit
    this should solve your problem
      My System SpecsSystem Spec

  3. #3


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    Its enabled on my 8.1 desktop. Clean install though not an upgrade install.
      My System SpecsSystem Spec

  4. #4


    Quote Originally Posted by alphanumeric View Post
    Its enabled on my 8.1 desktop. Clean install though not an upgrade install.
    ,
    Yes mine was enabled with a clean install also, the OP found his is disabled, hopefully I explained well enough for him to get it turned back on.
      My System SpecsSystem Spec

  5. #5


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    When the OP said "From the command line I also noticed that Automount is shown as disabled on both laptops. I thought that was supposed to be enabled by default.
    Any thoughts? " I figured he knew how to enable it, he's just wondering why it was disabled in the first place.
      My System SpecsSystem Spec

  6. #6


    Posts : 1,875
    Windows 10 Pro Prieview x64


    Quote Originally Posted by alphanumeric View Post
    Its enabled on my 8.1 desktop. Clean install though not an upgrade install.
    I did clean install of 8.1 and mine is disabled. I can only suppose something caused it to change for me and OP as clean install can't set it differently for you and me. I can't think what though.
      My System SpecsSystem Spec

  7. #7


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    Just checked my laptop and its enabled on that too. Clean install of 8.1 on that also. My laptop is UEFI and my desktop isn't. Antivirus maybe? I'm using Defender on both.
      My System SpecsSystem Spec

  8. #8


    Posts : 1,875
    Windows 10 Pro Prieview x64


    I've got BIOS and Defender...
      My System SpecsSystem Spec

Win 8.1 USB Automount
Eight Forums Android App Eight Forums IOS App Follow us on Facebook