Windows 8 and 8.1 Forums

USB 3.0 Not Working in Windows 8.1, but it's Different

  1. #31

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    Quote Originally Posted by rvcjew View Post
    Quote Originally Posted by topgundcp View Post
    Your BIOS is out of date version 0708 dated 12/25/2012. The new version is 1401 recently dated 08/29/2013. Please update it:

    Scroll down and click on Driver & Tools then select Windows 8.1 X64 then you'll see there are 13 BIOS versions on the list.
    some version fixed the compatibility issue with USB.
    that is nto his motherboard though its actually this CM6870 - Desktops - ASUS and there for it might not be wise to flash that to his board. that mainboard has more features then his so it might work but i would ask asus first.
    You are absolutely right, my apology. In this case his BIOS is up to date.

    Please disregard what I said about the BIOS.

      My System SpecsSystem Spec

  2. #32

    Posts : 22
    Windows 8.1

    Reply to topgundcp and to rvcjew

    I'd prefer to go slow, rather than brick the entire PC. I've sent the question below to ASUS Customer Support - I'm sure, based on previous contact with them, I'll have to refine the question until they send it up the line to the higher level/more technical may take a few days, especially since we are at the weekend and ASUS Customer Support doesn't seem to work it.......

    Attached Thumbnails Attached Thumbnails BIOS Update Question to ASUS.JPG  
      My System SpecsSystem Spec

  3. #33

    Posts : 22
    Windows 8.1

    Reply to rvcjew and topgundcp

    I'm curious about the version of the Intel Chipset on my PC - it seems I get different results depending on what I look at. If I look at the driver version in Device Manager it says I have Intel, but if I run the Intel Driver Update Utility, it says I have Finally, I've not been able to find it at all in who do I believe?

    Attached Thumbnails Attached Thumbnails Device Manager Chipset Driver Version.JPG   Intel Driver Update Utility.JPG  
      My System SpecsSystem Spec

  4. #34

    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64

    that is odd, in your own post though this is your chipset as stated by aida. and maybe you can find out what drivers its using in aida like mine. idk if it will show you in your trial.

    look what i found after digging to that sub chipset you have c216, thats for windows 7 but if find one for windows 8 i will post it.

    EDIT: you could try this as well idk how current this guide is though Windows 8 and Intel USB 3.0 Host Controllers | Plugable
      My System SpecsSystem Spec

  5. #35

    Posts : 22
    Windows 8.1

    Reply from ASUS About Windows 8.1 Drivers

    The Customer Support reply from ASUS was very specific: 1) go back to Windows 8.0 because they don't currently have drivers that support Windows 8.1, and 2) at some as-yet-to-be-determined future timeframe they may have drivers for the CM6870!

    So, if I want to continue with Windows 8.1, I'm on my own with no support from ASUS! They don't have a Windows 8.0 disk for sale that I can recover to and the disk I created turns out to be only a repair disk that can boot, but is not an image (iso or wim). I've purchased a retail copy of Windows 8.1 and will have to see if a full install is any better than where I'm currently at (the PC works, but I get strange Event Log critical errors that don't seem to affect my use of the PC). The only other option would be to send the CM6870 back to ASUS and have them do something to put it back to its original state - not interested in doing that because it would take too much time & the PC does work (IE 11 is even getting better)......I'll concentrate on solving the other problems, including the DCOM

    rvcjew and topgundcp - thanks for your help!
      My System SpecsSystem Spec

  6. #36

    Posts : 1
    Windows 10

    Sorry to revive a very old thread but this thread consistently came up in google every time I searched for a solution to this problem. Just for other people out there who may be in a similar situation. Windows 10 didn't seem to solve the USB 3.0 issue that many people were having especially with the front usb ports and card readers not working. I finally managed to solve this issue by upgrading the Intel(R) 7 Series/C216 driver to the latest version. I could not find this on Asus's website in the drivers section. I was able to find it on driverscape Asus CM6870 Drivers Download for Windows 10, 8.1, 7, Vista, XP
      My System SpecsSystem Spec

Page 4 of 4 FirstFirst ... 234
USB 3.0 Not Working in Windows 8.1, but it's Different
Related Threads
My usb gamepad stopped working suddenly and never work again in this computer I tried the gamepad in other computers and it works good, but not in this computer, I tried to reinstall windows several times, install all kind of drivers, I tried to configure it in different ways and its not working...
Hi! I am repeatedly getting the error "Internet Explorer not working" / Windows checking for solution/Last browsing closed unexpectedly , then Restore Session. I went to google to find a fix for this error .I'm being told to Press Window + W key then type in Troubleshooting in the Search box , then...
Hi, I updated my Synapse software (Razer) and suddenly my BlackWidow mechanical keyboard isn't working fully. The F keys are not working correctly the F10 mutes and F11/12 turn the volume up and down (almost like it's a laptop keyboard). The Windows key has swapped with the ALT key and also the...
hie frndz, i hv installed windows 8 pro with media center on my pc, today i installed far cry 3 game on my pc,bt whenever i start my game my monitor goes black n says out of range. can u please tell me the problem ?
Solved Windows 8 pro not working at all... in Performance & Maintenance
When I first press power, my pc comes up with Preparing Automatic Repair, with the windows logo, followed by diagnosing your pc. After that it comes up with: Automatic Repair couldn't repair your PC. Press advanced options to try other options to repair your pc, or shut down to turn off your pc....
Windows 8 not working with GTX 560 Ti in BSOD Crashes and Debugging
Hello, I just installed Windows 8 Pro through the upgrade download. I kept getting BSOD when windows 8 would boot for the first time and it kept sending me back to windows 7 pro. I kept getting some system service exception error, which i found out was the graphics (Nvidia GTX 560 Ti) so i took...
Working/Non Working software for Windows Developer Preview AKA Windows 8 Please use color code above when posting your list Paint.NET Google Earth Divx Plus Web Player (free) Logitech webcam software - model, Logitech HD Pro Webcam C910
Eight Forums Android App Eight Forums IOS App Follow us on Facebook