Windows 8 and 8.1 Forums


"Eject" Option Doesn't Work for ANY of My CD-ROM Drives??

  1. #11


    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7


    I was going to suggest using "ccleaner" to edit the context menu, but you can't edit that entry. Turns out the 'Eject" program, does work, but it makes a tray icon that is in spanish.

    I found a much more comprehensive post about using the Nircmd.exe command and integrating it into your Context Menu:

    Eject and Close CD/DVD Tray - Add to Desktop Context Menu - Windows 7 Help Forums

      My System SpecsSystem Spec

  2. #12


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    A refresh might fix it.
      My System SpecsSystem Spec

  3. #13


    Posts : 1
    Jesus


    Quote Originally Posted by brz1980 View Post
    Hello all, am running Win 8.1 Pro x64. Today I noticed that the "Eject" option from the right-click menu doesn't work for either of my 2 CD-Rom drives, nor for a "virtual" drive - I get the same error message on all 3: "An error occured while ejecting [drive]".

    Device Manager shows no errors, and I've tried uninstalling the drives and rebooting, but error persists. Can anyone help?

    Also, to be clear, it is NOT a physical problem with the drives, as I can open them without a problem through the buttons on the front.

    Finally, if for some reason I can't fix this issue, does anyone know of a way to at least just DELETE the "Eject" from the context menu?
    Guy just install DAEMON tools lite, i had the same problem after mounted more than one virtual drive and daemon drivers solved em. (Mano instala o DAEMON tools lite, eu tive o mesmo problema depois de ter instalado mais de um drive virtual de cd e os drivers o daemon resolveram.)
      My System SpecsSystem Spec

  4. #14


    Posts : 132
    Windows 8.1 Pro WMC


    Quote Originally Posted by brz1980 View Post
    Quote Originally Posted by XweAponX View Post
    Are these USB Optical drives? It may be confusing "Eject Device" with "Eject Disk" in the context menu.

    Nope, of the two physical drives one is a DVD-RW and the other is a BD-RE.
    Very strange, I just bought a new DVD-RW and a BD-RE drive because my current optical drives would not work properly - writing software would just lock up. The new drives worked the same as the old drives - not. I discovered that if I connect only one of the optical drives, everything works fine. So now I thought I have a faulty sata cable and connected them to different sata cables and ports. Both drives seem to be working right now however one of them seems to be doing something (the led flashes) every few minutes and when I right click the drive icon, the menu is very slow to open sometimes.

    I do not think I have a virus, but I will do a full scan just in case. I am starting to think this may be a Windows OS bug.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
"Eject" Option Doesn't Work for ANY of My CD-ROM Drives??
Related Threads
I hate it when I double click a file and Windows 8.1 pops up a message saying I have other apps that can handle this extension. I disabled this notification through GPEDIT.MSC, it works now when I open pics/docs/etc.... but let's say I install another app, for example, when I install Pale Moon...
I want to remove the option of “Format” from context menu for drives. Could I get some help on how to do this?
Hi, I had an issue with the general user folder name, which was shown as "Alex_000". Although this was a cosmetic issue only, I wanted to change this to "Alex". I successfully managed this by changing about 50 entries in the registry (via regedit). So fine so good.
My un–computer savvy friend just bought a Windows 8 tablet, and not knowing anything about it, he called me. I thought I knew a thing or two about Windows, too, but between the two of us we couldn't make head or tail of it. Specifically what we were trying to do today was sync his documents from...
Even though the tutorial on this forum says there should be a custom option, I don't seem to have it. 37375 Any thoughts on how can I bring it back? P.S. Does anyone know what that "winrt--{***}-" folder is?
New build with a Gigabyte-Z77X-UP5 TH mother board, Intel i7 3770K, Thermaltake TGP-750 power and Level 10 case, 32 GB G skill 1600 ram, Gigabyte GTX 660oc,Samsung 840 128BG ssd for op system, 2 WD RE4 500BG storage drives, running Windows 8 pro 64bit. Booted Bios up and checked that everything...
http://i47.tinypic.com/2ef7yp5.png Help? thanks.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook