Windows 8 and 8.1 Forums


Blue screen when enabling AHCI mode in Windows 8.1

  1. #1


    Posts : 3
    8.1 enterprise

    Blue screen when enabling AHCI mode in Windows 8.1


    Hey all,

    I tried installing the 8.1 Intel SATA/RAID driver from the ASUS website P8Z68-V motherboard model, but when enabling AHCI in BIOS I'm getting blue screens which is making me think something isn't configured properly in the OS. Does anyone know how to properly enable this in 8.1 yet? I'd definitely appreciate the extra speed out of my SSD

      My System SpecsSystem Spec

  2. #2


    I'm not 100% sure but I think you have to enable ACHI before installing windows, I don't think you can change it on a current installation.
      My System SpecsSystem Spec

  3. #3


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Before changing to AHCI in BIOS, You can try:
    1. WinX+R->regedit.exe
    2. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msahci
    3. Right click on Start->Modify and set it to value 0
    4. Reboot your PC and access BIOS then change it to AHCI


    Good Luck !!!
      My System SpecsSystem Spec

  4. #4


    Usually, when an OS is installed and the AHCI driver is installed and enabled it will crash the system. If the registry edit doesn't work then a clean install will be needed.

    Also, if running a SSD, AHCI is recommended to be enabled.
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    8.1 enterprise


    ahh I guess I was just hoping there was a way to go back and fix it afterwards like in win 7/8. theres no registry key like topgundcp described in 8.1
      My System SpecsSystem Spec

  6. #6


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    It would not hurt if You create one as follows to see if it works:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msahci]
    "Start"=dword:00000000
      My System SpecsSystem Spec

  7. #7


    Posts : 3
    8.1 enterprise


    no luck unfortunately
      My System SpecsSystem Spec

  8. #8


    Scotland
    Posts : 1
    windows 8.1 64 bit

    This is what I did to get ahci working again.


    Hello, I had this problem with windows 8.1, I remember reading this on another forum. I had ahci working with windows 8.1 but i'm not sure what I did, maybe when updating my mb bios I went back to ide mode. Then when I tried to enable ahci once more, I got the blue screen each time I booted. So I went to HKEY_LOCAL_MACHINE, SYSTEM, Current Control Set, services, storahci, Start Override, then I double clicked on the zero where it says REG_DWORD and changed the value from 3 to 0 (zero) , close down regedit, reboot, go into your bios and select ahci, save changes and then reboot. I just tried it just now and I am back using ahci mode. Hope that helps.
      My System SpecsSystem Spec

  9. #9


    Posts : 1
    Windows 8.1 64bit


    @gordon67 Yes it helps! Thanks!
      My System SpecsSystem Spec

Blue screen when enabling AHCI mode in Windows 8.1
Related Threads
I have successfully installed Windows 8 Pro x64 on an ASUS P8Z77-V Deluxe board on a SSD under UEFI/secure boot mode. Used the following settings: SATA Mode = AHCI Fastboot = enabled CSM = enabled Secureboot = Windows UEFI Everything works fine. Qcode = AO, performance is excellent etc....
Cant Change My SSD To AHCI Mode in Drivers & Hardware
hi, i have recently bought an SSD. I have heard from a youtube video that changing the Sata controller from IDE to AHCI can give me better performance but i tried to enable this and it doesn't recognize the drive. The PC will not boot in AHCI mode which meant i have to switch to IDE again. I have...
Hello! I own a Samsung R780 notebook with 08JA bios version, which has the UEFI Boot setting. The laptop comes with Windows 7 which I upgraded to Windows 8, but it was installed in BIOS mode, and I wanted to switch to UEFI. I tried to follow the instructions on the following website: Converting...
Blue Screen in Windows log off mode in BSOD Crashes and Debugging
When I log out and come back, I see that my PC restarts, I get a notification of minidump. It happens after I have logged off (Windows + L button) and maybe (in the future I'm afraid) when I'm working with PC, but has not yet done (blue screen). I do not even know why this problem, a hardware or a...
computer won't boot in AHCI mode ? in Drivers & Hardware
I installed windows 8 in ide mode in the bios. Now , if I set that to AHCI mode in the bios then the pc won't boot and repair cd cannot do make the pc bootable. How can I fix this ? Is there a performance difference between ide and ahci mode ? I use segate ST2000DM001 as boot drive and have...
Solved AHCI mode windows 8 pro in Installation & Setup
When I installed Windows 8 pro (oem x64) it wouldn't allow me to install with my sata controller set to AHCI mode so I set it to IDE and installed, now I'd like to have trim support so want to enable AHCI. Just enabling AHCI in BIOS boots too a blue :( (blue screen of unhappiness, BSoU??) screen...
enabling ahci in 32 bit in Installation & Setup
I recently upgraded XP to 8 using the cheapest method - downloading direct from Microsoft. This meant staying with 32 bit. After sucessfully setting up I realised that I had forgotten all about enabling AHCI so I Googled for instructions. Getting into the registry was straightforward enough but the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook