Windows 8 and 8.1 Forums


Computer won't use all installed RAM

  1. #1


    Posts : 2
    Windows 8

    Computer won't use all installed RAM


    Hey guys, so I tried to install more RAM, but after I put the sticks in, System information told me only 4GB of the 12 total GB were usable. My setup was two 2GB sticks in ports 1 and 2 and four 4GB sticks 3 and 4. I then switched it around and put the two 4GB sticks in ports 1 and 2, and the two 2GB sticks in 3 and 4. After this 8GB of the 12 were usable. Finally I tried putting the 4GB sticks in ports 1 and 3 and the 2GB sticks in ports 2 and 4 and vice versa.

    Any tips?


    RAM Sticks

    4GB - Newegg.ca - CORSAIR XMS3 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model CMX4GX3M2A1600C9

    8GB - Newegg.ca - Kingston HyperX Blu 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model KHX1600C9D3B1K2/8GX


    MOBO - Newegg.ca - ASUS P7P55D Deluxe LGA 1156 Intel P55 ATX Intel Motherboard

      My System SpecsSystem Spec

  2. #2


    Posts : 22,564
    64-bit Windows 10


    Hello Nick,

    It's best to use RAM sticks that are all identical to avoid having any potential compatibility issues.

    You would need to have the 4GB sticks in slots A1 and B1, and the 2GB sticks in slots A2 and B2.

    P7P55D - Motherboards - ASUS

    Click image for larger version

    Hope this helps,
    Shawn
    Last edited by Brink; 07 Oct 2013 at 18:42. Reason: typo
      My System SpecsSystem Spec

  3. #3


    Posts : 2,191
    Windows 8.1


    Ok, I always find these issues interesting so here's what I've found out so far:

    On the surface, it looks like everything should work; however, I did find one restriction on your motherboard if you are trying to run all 4 sticks at 1600:

    Click image for larger version

    The solution may be to set the RAM to run at 1333Mhz which is most likely the native speed associated with your (unknown) CPU.

    Also, there could be a conflict between the way the addressable arrays are setup but I saw no restriction regarding that in your mobo manual. I found that the 8GB (2 x 4GB pair) kingston uses a double sided 256x8 scheme for each module but I couldn't determine the configuration for the Corsair. In any event, I am not sure that would be the issue anyway.

    I also noticed that all testing of memory on the QVL list always used modules of the same memory size and same memory manufacturer. You could also try running with 3 modules to see if that makes any difference. Yes, I know that will kill the dual channel but this would just be for testing and maybe that might be the best you can do here (if it worked).

    Oh, and I'll end my analysis with the standard reminder that anytime one mixes sizes and manufacturers when running a dual channel arrangement can possibly lead to unresolvable problems. Anyway. Good luck.
      My System SpecsSystem Spec

  4. #4


    Posts : 2
    Windows 8


    Quote Originally Posted by Brink View Post
    Hello Nick,

    It's best to use RAM sticks that are all identical to avoid having any potential compatibility issues.

    You would need to have the 4GB sticks in slots A1 and B1, and the 2GB sticks in slots A2 and B2.


    This solved it! Thanks! All 12 GB is being recognized
    !
    P7P55D - Motherboards - ASUS

    Click image for larger version

    Hope this helps,
    Shawn
    This solved it! Thanks! All 12 GB is being recognized!
      My System SpecsSystem Spec

  5. #5


    Posts : 22,564
    64-bit Windows 10


    You're most welcome. Glad we could help.
      My System SpecsSystem Spec

  6. #6


    Posts : 2,191
    Windows 8.1


    Quote Originally Posted by Brink View Post
    Hello Nick,

    It's best to use RAM sticks are all identical to avoid having any potential compatibility issues.

    You would need to have the 4GB sticks in slots A1 and B1, and the 2GB sticks in slots A2 and B2.

    P7P55D - Motherboards - ASUS

    Click image for larger version

    Hope this helps,
    Shawn
    Well I skimmed right past the obvious "assuming" the OP had placed the memory in the proper slots. Good one Brink and congrats to the OP!
      My System SpecsSystem Spec

Computer won't use all installed RAM
Related Threads
Hey kinda in a pretty bad situation right now. about a week or 2 ago I downloaded the windows 8.1 update for my Samsung Series 7 chronos model NP700Z5C-S02UB I never installed the update after I downloaded it though. During the last week I notices the mute led on my keyboad wasn't lighting up...
I had Windows 8 and my computer was having problems, it would cut off my internet connection. And it kept on prompting me to upgrade to Windows 8.1 so I did a couple of nights ago. Now my computer freezes up, a website page or a video. Does anyone know what I can do about this? Its so...
2 of my machines have automatically downloaded/upgraded using the recent Win 8.1 Upgrade 1, but one machine is still running the pre upgrade 8.1. I've attempted to explicitly install the upgrade via Settings|Change PC Settings|Update & Recovery|Windows Update, but none of the expected...
Thanks to the generous help of members of this forum, I now have XP SP3 running under Hyper-V with an Internet connection and access to USB on the Windows 8.1 host (using remote access). Now the BIG question/goal: I want to clone my XP development system that resides on a different computer and...
This has happened three times in the last couple of days and I cant seem to figure out what's causing it. So if someone out there could look into it for me or guide me in the right direction that would be great. here is the specs of the system in question... Gateway SX2110G-UW318 Running...
Thought I would share this with all you good folks (hopefully good). The other day I went and purchased a new SanDisk 240 gig SSD to install in my desktop for use with the new Win 8 OS. Having a Sandisk 240 gig already in the machine I had decided to put that one in my HP dv7 laptop. To make...
BSOD on fresh installed computer in BSOD Crashes and Debugging
Hi all, Every 5-10min getting a BSOD on a fresh installed computer (Win 8 64Bit - AsRock B75 Pro3-M - 8GBDDR3 1333 GEIL Black Dragon - i3 3225 - Hitachi 500GB deskstar 7k1000c - LG GH24NS95 ) So just when i let the computer on the desktop, it will crash in 15min. When i try to do windows...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook