Windows 8 and 8.1 Forums


No USB device is getting detected

  1. #1


    Posts : 78
    Windows 8.1 64-bit

    No USB device is getting detected


    Hello everyone,
    No USB device seems to be getting detected on my machine when I plug in a flash drive or an external hdd I get the distinctive sound from my speakers that an USB device is plugged in but nothing is showing up in "My Computer". I went through the event logs and found that Windows is failing to load the USB device (check image in attachment logs.jpeg). What is causing this problem ? I am stuck right now. Recently I installed iTunes, so I though it might be causing this problem but I uninstalled it even then the problem persists. I don't want to format my machine just because of this small problem. Is this a driver conflict ? How do I find out why windows is all of a sudden failing to load the USB devices ? I have uploaded a copy of the saved logs detailing this failure(logs.zip). Thanks.
    Attached Thumbnails Attached Thumbnails logs.jpg  
    No USB device is getting detected Attached Files

      My System SpecsSystem Spec

  2. #2


    Go into device Manager and uninstall all the USB controllers! Reboot the computer and see if this helps.
      My System SpecsSystem Spec

  3. #3


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    In order to get help, you need to fill out your system specs so that we'll know what kind of PC/Laptop you have.
    In the mean time, open my computer and click on computer tab->System Properties->Device manager and look under USB controllers. If you see a yellow exclamation mark in front of the USB port where you attach your device, then there's a problem.

    Few things you can try:
    1. Update the BIOS to the latest for your MB.
    2. Update the chipset drivers for your MB (USB drivers also get installed for built in USB's)
    3. Update the firmware for the USB devices built in with your MB.
      My System SpecsSystem Spec

  4. #4


    Posts : 78
    Windows 8.1 64-bit


    Quote Originally Posted by topgundcp View Post
    In order to get help, you need to fill out your system specs so that we'll know what kind of PC/Laptop you have.
    In the mean time, open my computer and click on computer tab->System Properties->Device manager and look under USB controllers. If you see a yellow exclamation mark in front of the USB port where you attach your device, then there's a problem.

    Few things you can try:
    1. Update the BIOS to the latest for your MB.
    2. Update the chipset drivers for your MB (USB drivers also get installed for built in USB's)
    3. Update the firmware for the USB devices built in with your MB.
    Yes there is an exclamation mark just as you. Please check the image. I have to USB devices connected so there are two exclamation marks here. What does this error mean ? And how do i update the firmware for the USB devices built in with my MB ? Can you please explain that in detail i am kind of a novice ?
    Click image for larger version
      My System SpecsSystem Spec

  5. #5


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    You still have not filled out your system specs and without knowing who's the manufacturer of your mother board but by looking at the screen shot, step 3 above may not apply to your MB so all you need is to update your BIOS if it's outdated and update the Intel chipset drivers to the latest which will also update the built-in USB drivers (both USB 2.0 & USB 3.0).

    Here's the link for the latest Intel Chipset drivers version 9.​4.0.1026: https://downloadcenter.intel.com/Det...?DwnldID=20775

    For some motherboard such as MSI Z77 Mpower. In addition to the USB 2.0 ports, it has 2 Intel USB 3.0 ports and 4 USB 3.0 ports from Renesas to give a total of 6 USB 3.0 ports then you have to update both Intel Chipset drivers and the driver/firmware from Renesas.
      My System SpecsSystem Spec

  6. #6


    Posts : 1
    Windows 8, Windows 7, Windows XP


    So I work at a school that has Windows 8 on our new Lenovo laptops (Helixes, T430s, X230). Regardless of the model, the ports detect USB thumb drives for a certain amount of time. Eventually they stop working and will not start working unless you do a fresh install of Windows. We suspect that the problem is due to Kaspersky 10 Endpoint Security.
      My System SpecsSystem Spec

  7. #7


    Posts : 78
    Windows 8.1 64-bit


    Quote Originally Posted by Pylon View Post
    So I work at a school that has Windows 8 on our new Lenovo laptops (Helixes, T430s, X230). Regardless of the model, the ports detect USB thumb drives for a certain amount of time. Eventually they stop working and will not start working unless you do a fresh install of Windows. We suspect that the problem is due to Kaspersky 10 Endpoint Security.
    I solved the problem. The problem was happening due to iTunes. My advise to those using iTunes is that only install the Apple Mobile device driver and completely uninstall everything relating to iTunes. Use iFunBox(google it) to access your data from your iPad when connected to the computer.
      My System SpecsSystem Spec

No USB device is getting detected
Related Threads
I know that a similar question has been asked before but, not with the last part of the message, (Device Descriptor Request Failed). I get this, in Device Manager, and I have searched for an answer on the net. Also it is a Code 43. I went through my laptop, with an HP Technician this morning, I...
My computer keeps telling me Unknown USB Device (Device Descriptor Request Failed), so I looked up how to fix it and they told me to uninstall it then scan for hardware changes and it will reappear working properly.:thumb: Only it did not come back working properly, it came back the same. :mad: I...
BSOD then no GPU detected in device manager in BSOD Crashes and Debugging
Hi, im having problem with my MSI 620DX notebook wich have integrated intel family 3000 graphic card as well as GT555M.. problem is that BSOD randomly occurs when im browsing the web and then after restart my GT555M is not detected in device manager and then on another day it is back there until...
Hi, First, I would like to start off by saying that this is not a Windows 8 exclusive problem, I've had it in Windows 7 and upon install to Windows 8, it still occurs, which is leading me to the conclusion that this is a hardware problem. Ever since I built my machine in early 2014, it seems...
Since upgrading my HP DV6T7000-CTO from Windows 7 to Win 8 and now 8.1I have had an intermittent issue where the my wifi/bluetooth adapter is detected, until a restart, and then afterwards, is no longer detected. I have a Intel centrino wireless N 2230 which is both wifi and bluetooth. I cannot...
I am getting four megasas2 as Source with Event ID 11 errors in succession in Event Viewer on a computer running Windows 8.1 every time the computer goes to Sleep or Hibernates. On the General tab, it says: "The driver detected a controller error on \Device\RaidPort0." I have a LSI RAID Controller...
"Unknown PC or device detected" in Network & Sharing
I'm not truly the best with computers, and this is a new pop up for me. I just purchased this new dell laptop in May and have had no problems with it. However, in the last few weeks I've been getting a new pop up in the right hand corner. My house hold have a wireless router that is password...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook