Windows 8 and 8.1 Forums

For the Love Of God Make My Wireless Work!

  1. #1

    Posts : 33
    Windows 7 64x Enterprise

    For the Love Of God Make My Wireless Work!

    SO I have a great little dual boot thing set up over here. At first I couldn't get my lynksys usb adapter to work so I said "screw it" and used my laptop which ran 8 with no issues AND my wireless worked.
    Well I gave my laptop away. She's gone to a loving home
    But now I cant use the net at all on 8 on my desk top which kinda blows the purpose of having it!
    My adapter is a linksys ae 1000. I Have the drivers but 8 wont take em giving me guff over "its not digitally signed" or some junk. One member here tried to help me as we went into the registry etc and checked the binary string and it was ok i guess.
    I CANT run cable. If I do my guy will nag and nag like an old housewife.
    I gotta go to work but I'll be back around 9pm. If you guys could help me out with some options to get this working it would be VERY much appreciated. I've dug around in the guts of this install till my eyed bled.

      My System SpecsSystem Spec

  2. #2

    Depere, WI
    Posts : 15
    Windows 7 Ultimate 64bit;Snow Leopard 64bit

    Linksys ae1000 cd exe

    I have the same adapter and it worked for me. I have the CD though.
    Here's a link to the Linksys AE1000 exe I uploaded to my sky drive if you want to give it a try.

    Click image for larger version
    Last edited by lattimus; 14 Jan 2012 at 16:15.
      My System SpecsSystem Spec

  3. #3

    Hi I have the same problem, the compant say it hasn't updated the drivers...theres forward thinking for you...
      My System SpecsSystem Spec

  4. #4

    Depere, WI
    Posts : 15
    Windows 7 Ultimate 64bit;Snow Leopard 64bit
      My System SpecsSystem Spec

  5. #5

    Posts : 1
    Win 8.1, XP, Ubuntu Linux, Raspbian

    How to use the Linksys AE1000 under Windows 8!

    The AE1000 uses the RALink RT2870 chipset. Mediatek still makes RT2870-based wifi adapters, and they continue to update their drivers. Download the driver from MediaTek's support site.

    You'll need to disable Windows 8's DRIVER SIGNATURE ENFORCEMENT to install the "incorrect" driver for the AE1000. I find it easiest to go to a command prompt and enter shutdown /r /o. Your PC will reboot to a troubleshooting menu. Click on "Troubleshoot", then on "Advanced options", and then on "Startup Settings". Then click "Restart" yet again. You'll then boot to a menu with "Disable Driver Signature Enforcement" -- hit that and reboot one last time.

    Launch the MediaTek driver installer -- IS_Setup_ICS_011916_1.5.39.173.exe -- and let it install.

    With the AE1000 plugged into a USB port, launch the Device Manager. Right-click on the AE1000 (which will have a yellow alert icon on it,) and choose "Update driver software..." Tell it you want to find the driver on your PC. Browse to the the directory:
    C:\ProgramData\Mediatek Driver\RT2870 Wireless LAN Card\Driver
    Scroll down to MediaTek, and choose their USB Wireless adapter. You'll get warned that it isn't the right driver. It won't matter, because you can't be stopped! You are a superhero on a mission.

    The MediaTek taskbar tray utility will be launched at startup. You can kill that; it won't be able to find the "MediaTek" adapter. (Task Manager, Startup tab.) Now look at your network adapters! Enable that shiny, new wireless adapter! You should see a "802.11n USB Wireless LAN Card"!!! (Control Panel\Network and Internet\Network Connections)

    It's working perfectly on my Windows 8.1 PC.
      My System SpecsSystem Spec

For the Love Of God Make My Wireless Work!
Related Threads
Hi guys, Recently I have re-installed my windows.So then I also installed UxStyle with all my Windows files in original format. No patching has been done yet. After I installed UxStyle, I rebooted and then applied theme it worked very well no problem at all. But the next time I turned on my...
ralink wireless won't work in General Support
I have just upgraded from windows 7 ultimate to 8.1 but I can't seem to find any driver that works for my ralink wireless it is 802.11 n wireless LAN card. I have uninstalled it I have updated the driver but it still won't work can someone please give me some advise on how to fix this. Thanks...
I have a Lenovo Ideapad Y500 laptop running Windows 8.1. i7, 8BG ram, 2GB Nvidia card--all that stuff. It ran perfectly for nearly a year. But now, the local area network is broken. I haven't done anything different or changed anything that would affect it, as far as I know. But now that it's...
I am posting this because the information Amazon has is not correct or at least misleading and confusing. They have been alerted to the problem and may fix it in the future. (according to tech support, I just got off the phone with them) The Problem: Amazon offers two different Kindle for PC...
Read more at: For the love of God, please secure your wireless networks | ZDNet
How do you make Office 2010 work? in Software and Apps
I tried to install the trial, but it didn't seem to work. Either it didn't allow me, or it installed a little bit and stopped. Anyone else who has trouble installing office on WIndows 8? I went back to Windows 7, but I am thinking about going back again, since there's something wrong with this...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook