Windows 8 and 8.1 Forums

Logitech Setpoint

  1. #1

    Posts : 7
    Windows 7 Professional x64 / Windows 8 beta x64 + SDK

    Logitech Setpoint

    Hello all, just wondering if anyone else is having the same issue I am and maybe found a solution to it.
    I installed Logitech setpoint 6.30 and my mouse and keyboard tabs are missing, so I can't assign any values to my keyboard or mouse hotkeys. I only have the Information resources and SetPoint options. I tried looking up a similar problem in the logitech forums and it says to uninstall, reboot, delete "C:\WINDOWS\System32\drivers\wdf01000.sys" and re-install. I would try this, except "C:\WINDOWS\System32\drivers\wdf01000.sys" does not seem to exist in windows 8. I have tried installing previous versions of SetPoint but to no avail. Any ideas?

      My System SpecsSystem Spec

  2. #2

    Posts : 18
    Windows 8 Pro Pack

    Initially, I installed the Setpoint drivers and had the same problem. Also the pictures for the device were not downloaded. I had the pictures for the device saved and put them in the folders, but still had problems with the Setpoint interface. I looked on Logitech and found another way to install them after the initial failure (which did work). But I still experienced problem with the Setpoint interface.

    The best way I found to install these was to turn off UAC. I turned off UAC, but someone on the forum mentioned that UAC was not totally turned off and you had to modify "EnableLUA" in the registry to completely turn off UAC. So I changed Enable LUA to 0 (I rebooted after making these changes):

    Windows Registry Editor Version 5.00

    ; on=1, off=0

    After I did these modifications, Setpoint had no problem installing the driver and interface. I haven't turned UAC back on yet.
    Last edited by N30; 18 Sep 2011 at 06:58.
      My System SpecsSystem Spec

  3. #3

    Posts : 520
    Windows 8, x64, DP8102 - Win7 Ultimate x64, Dual Boot

    N30, Thanks! I really needed that.
      My System SpecsSystem Spec

  4. #4

    Posts : 7
    Windows 7 Professional x64 / Windows 8 beta x64 + SDK

    Awesome, works like a charm. Thanks!
      My System SpecsSystem Spec

  5. #5

    Posts : 520
    Windows 8, x64, DP8102 - Win7 Ultimate x64, Dual Boot

    One issue:
    If you disable UAC using the registry method (changing "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Cu rrentVersion\Policies\System" to 0), the Metro Apps cease to function.

    Unfortunately, SetPoint fails to function properly once the registry setting is returned to its default "1".
      My System SpecsSystem Spec

  6. #6

    United Kingdom
    Posts : 39
    Windows 8 Pro With Media Centre

    Setpoint V4.7.2 works if you install V4.0.0 first and then V4.7.2
      My System SpecsSystem Spec

  7. #7

    Posts : 520
    Windows 8, x64, DP8102 - Win7 Ultimate x64, Dual Boot

    I haven't tried the 4.x versions but I found a sort of a work around for SetPoint v.6.30.

    Once you boot into Win8, exit the tray icon then re-install.
    Works great, then, without changing the EnableLUA registry setting.
    I've tried it three times. Hasn't failed yet. Note that upon booting up I couldn't change settings (no mouse in the settings app).

    Hang on, I haven't tried it yet to see if the settings carry over after a reboot without re-installing SetPoint v.6.3.0 even though the app doesn't show the mouse or available options thereof.

    brb ...

    EDIT: Nope. Gotta exit the tray and re-install every time. Still, the settings are saved in the app just not effective until a re-install. (I am specifically talking about non-default button assignments on the mouse - an M510 in my case)
      My System SpecsSystem Spec

  8. #8

    Posts : 2
    Windows 8

    Fixed the problem:

    Installed Setpoint 4.00 64bit from the Logitech FTP site. Whereas 6.3 would install with LUA turned off - it wasn't possible to use Uberoptions, which is the only way to use a Logitech mouse. 4.00 allows you to use Uberoptions. You dont get the pretty on screen effects of Setpoint 6.3, but having a middle mouse button is worth it.
      My System SpecsSystem Spec

  9. #9

    Posts : 1
    Windows 8 Developer Preview

    Found a Work around!!
    "C:\Program Files\Logitech\SetPointP\SetPoint.exe" <- Set to Run as an administrator
    Turn off UAC in users
    Create a task in Scheduler -> Basic Task -> start a program -> point it too the above -> Run when i log onto my computer
    Go to the properties for this task after you have created it, then run as windows 7 at the bottom, check hidden and run with highest privilages

    Let me know if that works for you...
      My System SpecsSystem Spec

  10. #10

    Posts : 520
    Windows 8, x64, DP8102 - Win7 Ultimate x64, Dual Boot

    Setpoint 6.32 fixes this issue.

    Update to it.
    One should get an automatic update but, if you don't:


    Click image for larger version
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Logitech Setpoint
Related Threads
Latest Logitech SetPoint Software in Drivers & Hardware
Latest Logitech SetPoint Released Date: September 8th 2015 Software Version: 6.67.83 Updated Description: none
Trying to install Logitech "Setpoint" driver software in order to enable wheel-scrolling via trackball. During the installation, executing Setpoint6.65.62_Smart.exe, the OS throws up a command-line window with the information, "SUCCESS: The file (or folder):...
Solved Logitech K350 Lag in Drivers & Hardware
So after having been looking all over the internet for a solution, without any luck finding one, i ask for it here. So i just bought my new PC, and i got a problem with it: My Logitech K350 Wireless Keyboard randomly stops responding or sending keystrokes to the PC, its likes it lags or disconnects...
Logitech G35 & Win 8 problems in Drivers & Hardware
Hey guys So I have had my Logitech G35 headset for a really long time. There has been no problems with it, until I got my Asus G75VX with Win 8. When the headset is plugged in, and I want to adjust the volume after a few minutes, "explorer.exe" always crash and I have no sounds.. I really...
Hello, Is Logitech Setpoint necessary with Windows 8? I have a Logitech MX 518 gaming mouse. I would install it but it doesn't have a download link for Windows 8 which is worrying.
Solved Logitech g19 in Drivers & Hardware
I've bought about a month ago a logitech g19 keyboard. When i downloaded the driver (and software) from logitech support site, i had to chose Windows 7 64. When i started the installation a windows popped up, and said: this installation is not compatible with your operating system. the same result...
Solved Logitech drivers - where are they? in Drivers & Hardware
Missing driver for my G15 keyboard and my G5 Laser mouse. I have tried to install Windows 7 driver, but without getting it to Work :o
Eight Forums Android App Eight Forums IOS App Follow us on Facebook