Windows 8 and 8.1 Forums


Intel Rapid Start Technology Black Screen At Startup

  1. #1


    Kolkata, India
    Posts : 127
    Windows® 8.1 Pro 64-Bit

    Intel Rapid Start Technology Black Screen At Startup


    Hello guys, Recently I Recieved A Laptop in gift which I owned in the past which is A Dell XPS 15-L521X. It was running all good but suddenly Today morning when I pressed the power button and it boot through the Dell splash screen and after that It booted normal through the Windows 8 boot screen but after that It stucked at a Black Screen.
    I passed on 20-min but it stucked there. No Cursor, nothing except The Black Screen. I ran Dell Pre-Boot System Assesment to check any Hardware failware but no everything is just fine.
    I remember That My Dell Driver Update Utility Notified me that it installed latest Intel Rapid Start Technology Driver on my last boot but I dont know whether its causing the error but The Intel Rapid Start Technology is very essential for SSD users so why will it cause errors? Please help me I am totally Screwed up......

    Thanks For Any Help.............

      My System SpecsSystem Spec

  2. #2


    Posts : 474
    Win 8 (64) : Win 7 (64) : Vista (64) : Android JB 4.2 : iOS 6


    try to boot up on safe mode, if it goes through, one reason may be that driver. While in safe mode, do a system restore to get rid of that driver or just uninstall the driver if you don't want any of the other installed applications to be affected.
      My System SpecsSystem Spec

  3. #3


    Kolkata, India
    Posts : 127
    Windows® 8.1 Pro 64-Bit


    Sorry for late reply, Today after trying too much I could manage to boot up to Windows. In my action centre it was written "Fix one issue", I clicked on it and it showed me some "McShield.dll" error. It was written that "Action centre have removed McShield.dll because it can stop your system from booting in future".

    Please help me and my McAfee Security Centre is also not starting though its Taskbar Icon is there itself but when I clicked it it doesn't open Anything.
      My System SpecsSystem Spec

Intel Rapid Start Technology Black Screen At Startup
Related Threads
I don't know if this is a general thing, or some specific thing that should be elsewhere, so... Asus X99 Deluxe, 5820k, 1TB SSD, 3TB data HDD, 2TB backup HDD The system I just put together does NOT have any RAID disks. I've had RAID setups in the past and found that the frequency of disk...
HI, I want to install Intel Rapid Start driver and so trying to create a hibernation partition. I have followed every step correctly till setting partition ID and was successful. But, when I check the details of created partition in disk management, it is shown as "Healthy (Primary Partition)"...
My desktop machine is built on Gigabyte GA-Z87-UD3H and Gigabyte provides the latest driver for Intel Rapid Storage Technology (IRST), which I installed after installing the OS. Same goes for my Lenovo Thinkpad-T420. And for both machine, checking the controller device under the IDE ATA/ATAPI...
Solved Intel Rapid Start and GPT-mode? in Installation & Setup
Greetings. Installed Windows 8 in GPT-mode, and the manual from Intel on how to make the hibernate-partition, does not seem to work, when the SSD is not in MBR-mode. In diskpart I can create the partition, but I can't set it to ID=84 when in GPT-mode. Diskpart returns an error, saying that it is...
How to Hide or Show Intel Rapid Storage Technology Notification Area Icon in Windows The Intel Rapid Storage Technology software package provides high-performance SATA and SATA RAID capabilities for supported operating systems and requirements. The notification area (also called the system...
My laptop is an Asus Zenbook UX32A with an Intel® HM76 Express Chipset and 4GB of RAM. It has a 465GB HDD, and 22GB SSD. It supports Intel Rapid START Technology and Intel Rapid STORAGE Technology as Asus offer out of date Windows 7 x64 drivers for those technologies - I have called them about...
Hi there, I have windows 8 Enterprise x64 RTM, an asus sabertooth z77 mobo. I have installed windows 8 in AHCI sata mode and it works flawlessly but I have a solid state drive for caching. So I backed up my data, changed to RAID mode in BIOS and proceeded to reinstall. Windows 8 installer...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook