Windows 8 and 8.1 Forums

Windows not recognising External Hard drive

  1. #21

    Sloe Deth, Californicatia
    Posts : 3,908
    Windows 8 Pro with Media Center/Windows 7

    How odd - Do you have the Western Digital SES driver installed? It's necessary for those My Book drives. It usually installs automatically - If it doesn't, the driver is on the Drive Itself, or on the CD which comes with the drive.

    Click image for larger version

      My System SpecsSystem Spec

  2. #22

    Quote Originally Posted by XweAponX View Post
    How odd - Do you have the Western Digital SES driver installed? It's necessary for those My Book drives. It usually installs automatically - If it doesn't, the driver is on the Drive Itself, or on the CD which comes with the drive.

    Click image for larger version
    Thanks for taking the time to reply.

    I don't have that in my Device Manager list, it isn't a My Book, it's a WD Elements 1TB portable Hard Drive 3.0, should it still require that file? There was no disc that came with it in the box, I assumed it was 'plug and go' do you have a link to a download for the drive management device at all?
      My System SpecsSystem Spec

  3. #23

    Update: I just plugged the drive back in to have another go at it, and it recognised it again this morning (has been doing this on and off). Whilst it was working, In the drive properties under 'volume' there was a new option called 'populate', which I clicked and it is now showing up as pictured here, so it's not saying it's uninitialised anymore... does this mean it's fixed? Do I still need to try to partition it or is that what just happened?

    Don't want to transfer my 650GB back over until I know it's good to go!

    Click image for larger version
      My System SpecsSystem Spec

  4. #24

    Update: still no further options available in Partition Wizard program.
      My System SpecsSystem Spec

  5. #25

    It's still saying the drive is write protected, any ideas on fixing that also?
      My System SpecsSystem Spec

  6. #26

    Hafnarfjörđur IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    Hi there
    Try this from within Windows.
    1) Delete the partition.
    2) Re format the disk / Create simple volume.
    3) check a disk letter has been assigned --if it hasn't assign it one.
    4) copy ONE or TWO small files to it - doesn't matter what they are.
    5) exit windows explorer
    6) unmount / eject the drive via the safely remove hardware icon - the arrow on the bottom taskbar at the right.
    7) unplug the device - and leave it unplugged.
    8) power off the machine completely -- i.e SWITCH OFF - don't plug in the disk again yet.
    9) re-boot.
    10) plug in the HDD again -- if the computer sees it and you can see your data (the two files you copied in 4) above then it's all fixed.

    If you get other problems please post a screen shot of the disks.

      My System SpecsSystem Spec

  7. #27

    Hi Jimbo,

    Thanks for your reply. Is there another way to delete the partition rather than right clicking on it? When I do that it's not giving me the 'delete volume' option. See picture.

    Click image for larger version
      My System SpecsSystem Spec

  8. #28

      My System SpecsSystem Spec

  9. #29

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    Do you have another PC that you can plug in your HD to test with, maybe from a friend who owns a Desktop PC ? The reason I ask because your portable HD is getting power from the USB port and with laptop, sometimes it does not provide enough power. Another possibility is your USB cable is flaky.

    Maybe it's time to use diskpart from the elevated command prompt. It is a little tedious to use but it does give you commands that are unavailable with Disk Management. This link will show you a list of command options and parameters on how to use Diskpart.
    DiskPart - Partition a disk |

    If you have problem using Diskpart, please post back with your question.

    Good luck.
      My System SpecsSystem Spec

  10. #30

    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit

    You might want to have a go with diskpart. I've had good luck recovering stubborn drives by doing this. Disk - Clean and Clean All with Diskpart Command - Windows 7 Help Forums

    EDIT: @topgundcp, missed your post somehow and didn't see that you already suggested diskpart.
      My System SpecsSystem Spec

Page 3 of 4 FirstFirst 1234 LastLast
Windows not recognising External Hard drive
Related Threads
Hello, After experiencing some malfunctions in my hard drive I decided to buy a more reliable one before my existing hard drive completely died. I've used Windows 8.1's backup and recovery tools to create an image of my existing hard drive in the hopes that I can restore this image to my new...
I'm currently using a Dell Inspiron 3520 laptop with Windows 8 on it. I have an external hard drive from a Windows 7 desktop. It recognizes the external hdd right away and I can access it but I can't figure out how to boot Windows 7 as the primary. I've tried changing boot order in bios but I've...
Hi, thanks for all the help you have been giving me! Can i install windows 7 or 8 to an external hard drive so i can take it to another computer, select it from the boot menu and it will boot up? Thanks!
HP Envy dv7, Windows 8 Seagate 2TB drive mounted in a Thermaltake, Max 5 enclosure. The drive does not show in Windows 8. Does show when running Disk Management (diskmgmt.msc) but shows as "Unallocated" without a drive letter. If run the Seagate drive tools, it shows up as unallocated, with...
Hello everyone, A few months ago my laptop broke and it needed repairs. The HDD was replaced and i got my laptop back with one new HDD inside and one "broke" HDD in a bag. Later the "Repaired" Laptop crashed again so i bought a new one and took the HDD out of the old laptop. I bought a HDD case...
Hi I successfully managed to create a virtual hard drive on my external drive to try boot windows 8 off it. I managed to boot it up and the login screen also appears as normal. I have a successful login, But on the second time login I am faced with black screen and the cursor. I'm aware that...
I have a 2TB Western Digital My Book Essentials, it's filled with tons of old photos, movies, docs, games, and I'm scared to think of what else. The SATA to USB connector broke on it, so I took the drive apart and put it inside my computer. I opened up device manager because it wasn't showing up...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook