Windows 8 and 8.1 Forums


Using PCIE Gen 2 - cant find any device

  1. #1

    Using PCIE Gen 2 - cant find any device


    Hey guys,

    Am trying to build my first PC with a Asus P8Z68M motherboard I have managed to get it all going but when I start it up its says - Using PCIE Gen 2 - cant find any device. What does this mean? Also, why does the PC beep at me whilst booting up? Thanks

      My System SpecsSystem Spec

  2. #2


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    BIOS beep codes are error codes. One short beep is the normal everything is OK code. If you hear a series of long and short beeps that's an error message telling you there is a hardware fault. The "Using PCIE Gen 2 - cant find any device" message sounds like part of the problem. I would double check all your motherboard connections and reseat any add-in cards you have. If you take not of the sequence of the beep code you can look it up to see if the description for that code will help you figure out what's wrong.
      My System SpecsSystem Spec

  3. #3


    Also make sure you have all your PCIe cards in there right PCIe slots...and like alphamumeric stated, make sure that they are firmly seated.
      My System SpecsSystem Spec

  4. #4


    Posts : 1,121
    Windows 8.1 x64


    If it is relevant in your case, Windows 8 (or ASUS) seems to have problems with the PCIe x1 slots. Do you have anything in one of those?
      My System SpecsSystem Spec

  5. #5


    Some motherboards in the Asus P8Z68 series support PCI-E 3. Whether they run at that can be controlled by a BIOS setting. I see no indication that a P8Z68M Pro (Is that your board?) is one of them.

    It sounds like you can't get into your BIOS setup just yet, anyway.

    What beeps are you getting?
      My System SpecsSystem Spec

  6. #6


    Hi Guys, thanks for the advice. I don't currently have any cards plugged in.
      My System SpecsSystem Spec

  7. #7


    Will I need to plug in a wireless card so I can access Internet wirelessly?
      My System SpecsSystem Spec

  8. #8


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    Is the boot up beep just the one short beep?
      My System SpecsSystem Spec

  9. #9


    No, it is numerous beeps
      My System SpecsSystem Spec

  10. #10


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    You have a hardware fault then. Record the order and number of beeps and any pauses. Then post them here and we'll see if we can figure out what it means. It will be a series of long and short beeps. Example, 2 short and 3 long.
      My System SpecsSystem Spec

Using PCIE Gen 2 - cant find any device
Related Threads
Add a USB 3 PCIE controller in Drivers & Hardware
Hi, Have difficulty to show my Toshiba V63700-A 500gb external HD plugged in the USB 2s of my motherboard. Saw this below in Amazon (£9.99) but does not mention Win8 only w7, has anybody by chance used it in w8? Also my mobo has 2 free PCIE slots, will I need anything else with them or...
cant find my bluetooth device in Drivers & Hardware
i'm james, someone help me...! i cant find my bluetooth device in my (acer aspire s3 ultrabook i5 2467m 13.3) before i am using window7 it works properly but now im switch to windows8.1 and i cant find my bluetooth device even in device manager. i also used scan driver but nothing happend.. i...
Hello, I would like to test power management of my PCIe SSD, ASPM can work well. And I want to know L2 state work well, too. Anyone knows how to let PCIe device enter L2 state in Win8.1? Thanks.
Solved Unable to find bluetooth device in Network & Sharing
Hi I have never used 'Bluetooth' before. I want to transfer a file between my laptop and Android tablet. I turned Bluetooth 'on' (which I have installed the latest driver) on my W8.1 laptop. I turned Bluetooth 'on' on my Android 4.1.1 tablet. I had my laptop search for 'Bluetooth' devices, but...
Hey Guys, My VIA drivers won't install because it can't find the device. I'm trying the driver from the Biostar Website. I've tried the ones from the via website but those don't work either. I get nice clear audio but i can't configure my drivers so I can get my sub woofers working. Links...
I need to know what is the easest way of locating the device manager and bringing it up. This would be like the default method of doing this without having any custom shortcuts setup. So you should be able to go to any install and use this method :D
When I open Device Manager, I see a problem with one of the PCI Devices: 11931 I've tried automatically updating the drivers, but Windows 8 says it can't install the PCI Device. Windows 8 64bit on a Dell m301z Laptop. So I don't know which device is causing a problem or how to resolve it....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook