Windows 8 and 8.1 Forums


Weird printer problem

  1. #1


    West Sussex, UK
    Posts : 29
    Windows 8.1 Pro 64 bit w/Media Center

    Weird printer problem


    I have a Canon MP990 All-in-One which has been working perfectly from when I installed the Canon drivers on my new home build W8 64bitpc a few weeks ago. This included successfully printing pdf files via the W8 Reader App. I set up the MP990 to always show a print preview before printing.
    All of a sudden, today, whilst I am still able to print from MS Office 10 Outlook, Word, Excel, IE10 and Wordpad, with no problems at all, I can no longer print pdf files via Reader (as you may know, I understand Adobe Reader 10 does not as yet support a W8 printer device).
    Trying to print via the W8 Reader App now, I can select my printer device (MP990) and set the printing options. Then, when I press ‘Print’, I get a message to the effect, ‘Printer needs your attention, go to desktop.’ This is a valid message I’ve always had which means I have to go to the Desktop to see the Canon Print Preview screen. However, the Print Preview screen is no longer appearing (though it still does via Outlook, Word, Excel, IE10 and Wordpad ) and when I check the printer properties; the print queue is completely empty.
    Maybe it’s a rogue Windows update, though I can’t see anything recently obvious.
    I carried out a Diagnosis & Repair from My Printer – no faults at all and successfully printed a Test page. Any suggestions will be appreciated.
    Thanks,
    Pedro

      My System SpecsSystem Spec

  2. #2


    Quote Originally Posted by pedro38 View Post
    Any suggestions will be appreciated.
    Hello Pedro,

    I tried that Reader App and I really didn't like it so I went back to my old reliable PDF-XChange Viewer. IMHO, its the best free PDF Reader available & I haven't had any problems using it on Win XP, Win 7, or Win8:

    Tracker Software Products :: PDF-XChange Products Comparison Chart - Compare PDF software solutions.

    Good luck.
      My System SpecsSystem Spec

  3. #3


    Posts : 153
    Win8.1 64 bits Ent- Pro


    dude, I have an MP 140 and had in the early beginning a different problem than yours concerning scanning, I assume you installed latest driver fro Win8; check here to see if this does anything to your Canon
    Solution for MP Navigator scan failed | Daily Tweak
      My System SpecsSystem Spec

  4. #4


    West Sussex, UK
    Posts : 29
    Windows 8.1 Pro 64 bit w/Media Center


    Many thanks norepli


    I've installed PDF Exchange Viewer. It works a treat and interfaces with my Canon 990 100pct - so kudos to you.

    HBHB, my MP990 functions all work properly and I do have the latest W8 drivers. I think it is that the Reader App has gone flaky and I shan't use it anymore, but thanks anyway.

    Regards,
    Pedro
      My System SpecsSystem Spec

  5. #5


    That's great news Pedro!

    Kirk out!
      My System SpecsSystem Spec

Weird printer problem
Related Threads
Help - weird problem in General Support
I had a 2TB WD Black HD that was developing bad sectors, so I decided to replace it with a WD Velociraptor 1 TB HD. Everything seemed fine., though I didn't do a lot on the computer so I can't say for sure. Power outage the next night. Starting the next day, the computer boots up and shuts down...
Weird USB Problem in Drivers & Hardware
Heya, I've got weird USB problems, and can't seem to work out what's wrong. I'm using Windows 8 x64, all updated, which had been working without problem for about 8 months now. I noticed my internel card reader drives (9 pin USB header) kept disappearing and reappearing quickly, in both My...
Weird Problem in Network & Sharing
First off I have 5 Windows computers in my house. 3 with 8.1, and 2 with Windows 7. I have an ASUS RT-AC66U wireless router that supports A, B, G, N, & AC. My problem is with my HP 7520 All-In-One printer hooked up wirelessly. With all the pc's off and the printer on in standby mode, I can start...
I have this weird problem in General Support
Hi I have this really weird problem. I recently upgraded my laptop to Windows 8. Everything went fine and there was no problem whatsoever. But recently, all the buttons inside the Metro (or, Modern) UI have disappeared. Either it shows only the outside ring with the insides blank, or boxes(like...
Solved Weird Problem in General Support
I'm having an issue I've never seen before. It seems to happen maybe a couple times a day (haven't paid that close attention yet). I'll be sitting there and notice the hard drive activity light is on steady and won't even blink. I can work on the system normally though. However when I try to...
Weird Weird Problem! in Network & Sharing
I have the strangest problem with my internet since updating to W8. My internet works absolutely fine all day, up until later in the day (not sure what time exactly this happens) but it stops working! It says it is connected but it simple can't find a network. I am connected via LAN to an...
When I play any 3d game on my pc like Bullet Run, The, um.. I cant explain. Heres a picture.8005 Notice how the back of the mp7 has parts that are see through. Although this may seem minor, in other games like Batlefield Play4free, The sky is messed up, houses are messed up and the game looks...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook