Windows 8 and 8.1 Forums

USB not recognized, but not showing in 'Computer'

  1. #1

    Posts : 1
    Windows 8

    USB recognized, but not showing in 'Computer'

    Hi, I've been having a problem with a 4GB i-Ecko USB drive. When I plug it into my laptop it makes a noise and the device is ready notification shows but when I go into 'Computer' nothing shows up. It has worked before on many computers, I haven't done anything to it that I can think of that would cause this.

    I've plugged it into other computers 3 running Windows 7 and 1 running Vista so it is nothing to do with Windows 8.

    I've gone into 'Disk Management' and changed the drive letter and that did not work. It just shows up as Removable: (F) No Media.

    There is no errors in 'Device Manager' where it shows up. I've uninstalled and reinstalled the driver.

    In 'Devices and Printers' it shows up as a 'Mass Storage Device' I tried troubleshooting it and it says "USB Mass Storage Device is an older USB device and might not work with USB 3.0" But the Vista laptop I tried it on has a USB 2.0 so that can't be the problem. Also, I have older USB drives that work fine.

    It says Device is Working Properly under properties.

    I did just recently Upgrade to Windows 8 but it was not working before that too.

    Any help would be greatly appreciated!

    Thanks in advance!
    Last edited by Kosaka; 16 Feb 2013 at 10:08.

      My System SpecsSystem Spec

USB not recognized, but not showing in 'Computer'
Related Threads
Hello everyone, I have run into some networking problems and I think I have narrowed it down to the homegroup provider. I have 4 windows 8 pro x64 computers connected to a router. Up until now, I have been able to disable the homegroup provider service because I don't want to use the...
Hi! Please help. Here is my issue in bullet points: -Running my PC with a Radeon HD 7700 on Windows 8, main display is monitor in DVI port, secondary display is HDMI running to my LG TV for playing videos (only enabled some of the time in AMD Catalyst Control Center under "Desktop ...
I am currently running Windows 8 64 bit and when I go to "My Computer" it is only showing my C: drive. I know my other drives (internal, external and dvd) are working because I can enter the directory name (ie. H:\ or E:\) into the address bar and the content appears. Is there any way to fix this...
Please could anyone help? Since refreshing win 8 my DVD drive doesn't appear in 'computer' and doesn't boot from the win 8 disk. The green light on the drive flickers and you can hear the drive reading the disk. Thanks for any help
Hi there I have a TDK 16GB usb pen drive that shows in Device Manager when inserted but not in Computer. It does sometimes appear but very rarely. I have updated all driver via Device manager an they are fine. Hope somebody can help as I shelled out 24 for it. Thanks in advance
new computer name not showing up in Network & Sharing
I wanted to rename my computers so they would show up in Windows explorer ordered from the one closest to me to the one farthest from me. I renamed four of the eighteen computers on my home network I renamed: Portable to 001Portable (running windows 9 home premium) ...
This is my first build. Just getting Windows 8 on the SSD was a minor adventure on its own. i7 2600 ASUS P8Z68 Windows 8 on new 60gb OCZ SSD - Shows in Computer Management. New 2tb WD Green - Shows. Formatting right now. 2tb WD Green - Shows but as unformatted - working on this w/ testdisk....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook