Windows 8 and 8.1 Forums


Fantom drive not recognized, but shows up in devices

  1. #1


    Posts : 2
    Windows 8

    Fantom drive not recognized, but shows up in devices


    I recently switched over from a macbook pro (snow leopard) to an hp envy dv6 with windows 8 on it. My Fantom GreenDrive worked fine on the mac, and on another pc before. The new laptop makes a detection noise when I turn it on and plug it in, but it does not show up anywhere but in devices. I can't access my backed up files, it's pretty bad news if I can't get them back. I tried downloading the driver for the fantom drive, but no luck. Anyone know how to fix this?

      My System SpecsSystem Spec

  2. #2


    Posts : 5
    Windows 8 Pro


    Go into disk manager and assign it a drive letter.
    I had to do this with several external HDD's on my DV7
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8


    The disk manager will let me change/assign letters to everything listed except my fantom drive. Here is what it looks like:
    Click image for larger version
      My System SpecsSystem Spec

  4. #4


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Open the elevated command prompt and type: diskpart
    Once you are in diskpart, use this link as command reference to assign a letter.
    DiskPart - Partition a disk | SS64.com
      My System SpecsSystem Spec

Fantom drive not recognized, but shows up in devices
Related Threads
hello my problem is very confusing every time i plug in a usb for android device it says it's not recognized by windows however the mobile or the tablet are charging via the USB but i cannot access the memory card i tried installing intel USB driver , ADB driver but still no response i use...
I got home and turned on pc, got message that windows is finishing update and once i got to desktop, none of my usb devices worked, and even my internet disconnected. Restarting does nothing, and theres only so little i can do since keyboard and mouse are not working.
hard drive not recognized in General Support
when plugging in my seagate freeagent hard drive i get the message "USB device not recognized. I have been to device manager and it appears as "unknown USB device (device descriptor request failed)". I have tried uninstalling it and reinstalling, checked for new drivers/updates. no luck any help...
An automatic update occured, and a blank box popped up continuously(Titled: C:/swsetup/sp59654/IDTSetup.exe) I was using my USB headset during that update, then all of a sudden they stop working and only my speakers were working, and no devices were being shown under playback devices nor under...
hi there, I have an iomega portable usb drive. I can plug into any of my windows 7 machines and access the files and store data on it. when I put into my win 8 machine it shows in devices and printers and in my computer shows as removable disk but you cannot open it up. I have went into...
Solved DVD Drive No Longer Recognized in Drivers & Hardware
Hi all. I have a TSST 208DN DVD drive installed in a Win 8 Pro Toshiba C855 machine. I am no longer able to use the drive and could use your advice and assistance. The problem began with my always having to reinstall the drivers upon reboot. I found a solution, or so I thought, that advised...
I installed windows 8 pro and my dvd drive has not been recognised. I get a message Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19) I tried that FIX IT thing on Microsoft and it failed to do anything. tried...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook