Windows 8 and 8.1 Forums


Ixtreme X8540 DVD eject button won't work after Windows 8

  1. #1


    Posts : 7
    Windows 8

    Ixtreme X8540 DVD eject button won't work after Windows 8


    Hi, since installing Windows 8, the DVD eject button on my Packard Bell Ixtreme X8540 won't work. I've searched for solutions and installed the Gateway Photo Frame 4.1.3.10 software by I/O Interconnect as suggested, but this hasn't fixed the problem. Any idea what I can do to fix it? Thanks.

      My System SpecsSystem Spec

  2. #2


    Strathpine, Queensland
    Posts : 179
    Windows 8 Pro 64 Bit


    Hi Funkybass99, and welcome to Eight Forums! I hope you enjoy the forum as much as the members here!

    As for the error, in the Windows Explorer window (My Conputer, etc), is the drive showing up as DVD_Drive X: (X = Drive Letter) or something of similarity? If not, then the drive may not be compatible with Windows 8.

    Also, if you don't mind, please link your threads by adding your other thread link (https://www.eightforums.com/drivers-hardware/17586-ixtreme-x8540-surround-sound-not-working-after-windows-8-a.html) into the opening post!

    Thanks, and good luck!
      My System SpecsSystem Spec

  3. #3


    Posts : 7
    Windows 8


    Hi, will do. I attached some system info in the other thread.

    Yes it is showing up and working. I can eject it by right clicking that icon, but it's annoying that the button doesn't work and also that Packard Bell will offer no help simply on the grounds that a warranty has expired! Who's ever heard of a hardware firm limiting technical support to a year... and to have the sheer nerve to direct you to a premium number costing 50 pence a minute in the uk!
      My System SpecsSystem Spec

Ixtreme X8540 DVD eject button won't work after Windows 8
Related Threads
so i cant click the windows start button to get to tiles,nor use the charm to search. i have had this happend before on another system. ive read that it can be caused by an update but i havent downloaded nor installed an update. my anti virus is avast but i do have malware antibytes...
Hello all, am running Win 8.1 Pro x64. Today I noticed that the "Eject" option from the right-click menu doesn't work for either of my 2 CD-Rom drives, nor for a "virtual" drive - I get the same error message on all 3: "An error occured while ejecting ". Device Manager shows no errors, and I've...
I have one of the strangest issues I have come across. After upgrading to 8.1 my power button doesn't always work when trying to enter sleep mode. It's how I send my computer to sleep and wake it up. If the computer is off or asleep and I press the button it works every time, but if it is on and I...
Read more at source: Here's how the new Windows Blue Start Button may work | ZDNet
My Internet connection icon/button (either on the desktop to the right of the task bar or on the settings when you slide in from right) doesn't work... I mean when I click it it does absolutely nothing. Also, when I open the network and sharing center after clicking change adapter settings it...
I have tried for some time now to get my surround sound to work on my Packard Bell Ixtreme X8540 since upgrading to Windows 8 via Microsoft's upgrade tool. When I had Vista installed, there was an icon on the bottom task bar which would take me to a control centre for the audio which gave the...
http://i47.tinypic.com/2ef7yp5.png Help? thanks.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook