Hello all, hope someone can help:

Here's my drive config (all SATA):
Disk 0 - Intel 128gb SSD - Windows System
Disk 1 - 1TB Western Digital - Media storage
Disk 2 - 250gb WD Work / project files
Disk 3 - 250gb WD VMs for testing
Mainboard - Asus P8P67 Pro

In my system event viewer, I get these warnings:

"The IO operation at logical block address 6a1d1338 for Disk 1 was retried."

Sometimes its Disk 2 or 3, but mostly disk 1. Never disk 0
I even get this warning, which makes no sense as I don't have any Asian regional settings or keyboards installed

"The IO operation at logical block address 挀  搀㈀㠀 for Disk ㈀ was retried."

If I do a large file copy (4gb) between either disk 1 and either disk 2 or 3 it will start out solid at about 40mbs and after a few seconds it will drop to less than 1mbs. It might peak at around 40 a couple more times before hitting 0mbs at about 40% - 60% completed and it won't go any further from there. Same thing between Disk 2 & 3.
Copying FROM disk 0 to any of the other three produces the same behavior. Copying TO disk 0 (SSD) from either of the other three disks works fine.

Nothing is logged in the event viewer during these copy attempts, the errors above often happen when the system is idle. I've formatted and error checked drives 1, 2, & 3 but to no avail. I've researched this issue and it seems like its not uncommon with Windows 8, and a Windows reinstall often fixes it when the problem is on the system disk and freezes constantly. In my case Windows is fine, I don't get freezing because its not affecting Disk 0. (I do however get freezes in my VMs on disk 3). I'll only do a reinstall as a last resort.

I've tried the latest chipset drivers, and tried different physical SATA ports. I mounted the 1TB drive in another computer (windows 7) and had no issues.

There must be some hardware (BIOS) or windows configuration that is causing this, I'm pretty sure its not the drives themselves. Any other ideas to try before I reinstall? The fact that I get the error with Asian characters in it suggest more a Windows issue than a hardware issue.