Windows 8 and 8.1 Forums

Installing SATA DVD/RW with Asus Rampage 2 gene

  1. #1

    Installing SATA DVD/RW with Asus Rampage 2 gene

    My old DVD/RW was connected by IDE cable but this died a few weeks back.

    I've checked my motherboard to see if it will accept SATA drives, to which it says it does.

    I have bought a new DVD/RW and its connected via a SATA cable. I have plugged the SATA cable into the SATA port on the M'Board and connected it to the DVD/RW. I was assuming it would be 'Plug and Play' like the IDE cable but it's not showing in my computer.

    What do I need to do to get it working? I thought I'd ask you guys first encase I downloaded drivers that I don't need.

    Many Thanks

      My System SpecsSystem Spec

  2. #2

    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1

    Welcome to EightForums.

    Will the DVD Drive show in BIOS?
      My System SpecsSystem Spec

  3. #3


    Firstly I'm a twit. I signed up to a windows 8 forum when I've got windows 7 :/

    Yes, it does show up in the BIOS.

    It shows in My Computer but it just wont record a CD.
      My System SpecsSystem Spec

  4. #4

    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1

    Try this (1):

    Your CD drive or DVD drive is missing or is not recognized by Windows or other programs

    Fix problems with CD or DVD drives that can

    The CD drive or the DVD drive does not work as expected on a computer that is running Windows Vista

    Try this(2):
    1) Shut down PC.
    2) Physically disconnect the CD/DVD Drive.
    3) Reboot to Windows with NO DVD drive.
    4) Shut down PC.
    5) Physically reconnect the CD/DVD Drive.
    6) Reboot to Windows with DVD drive.
    7) Check Device status.
      My System SpecsSystem Spec

Installing SATA DVD/RW with Asus Rampage 2 gene
Related Threads
My new laptop has currently 8.1 installed to a 500gig 840 EVO SSD, I replaced the 1tb hard drive it came with and did a clean install. I'd like to utilize the M.2 sata port with a Crucial M550 500gig drive for windows, and re-install the 1tb hard drive for storage. I have an external USB 2.5"...
Hi having problems! On a new install using Asus maximus VII ranger MB. Purchased a crucial m500 M.2 sata ssd. Fitted to the MB and changed the BIOS allowing M.2 usage. Tried to install window 8.1 64 bit oem. Message no storage device deteched. Any ideas please
Has anyone had any success installing Asus Suite 3 V.10082 64-bit? I just built a new Asus Z97-Deluxe PC running windows 8.1 64-Bit and have tried multiple time installing Asus Aisuite 3, but each time I install it will install into the program files(x86) folder and runs in 32-Bit. Tried Asus...
Hi I've recently completed a PC build: ASUS Rampage IV Extreme motherboard Intel i7 4930k CPU 64GB Corsair DDR3 RAM Seagate Barracuda 3TB HDD Samsung 840EVO 500GB SSD (boot drive) GPU: NVIDIA GeForce GTX760 PSU: Corsair AX860
Hello All; I have searched high and low and have tried a 101 different drivers from NVidia and Asus websites to try and get my rig installed with windows 8. I installed windows 8 preview without a problem at all. However, now that I try to install the full version, I am unable to do so. When...
I have two separate instances of Win8 running on two separate IDE hard drives (both Win8's restored from same exact backup image). The one on the hard drive comected to the SATA port (via an adaptor) runs fine, but the one on the IDE connection (motherboard's only one), does not respond properly...
this is an ASUS X83V notebook - Setting the SATA operation to 'compatible' mode at installation, Win8 CP installed fine, no hitches. Switched BIOS to Enhanced/full mode and it fails. I recall this sort of problem from XP installs where tricks were needed to support SATA, but I do not recall...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook