I've fought with this for two days, and none of it makes sense.

I tried to upgrade my machine to Win8... System was a Intel DP35DP board, Q9550 processor, 8 gigs RAM, BFG nVidia GTX 260 graphics card and a 1 TB WD Black drive, all sitting in an Antec Performance One case with an Antec TruePower Trio 550 power supply. Oh, and two Samsung 2233SB monitors, a Logitech G5 mouse, and a Keytronics Classic-U2 keyboard. I tend to upgrade my computer various pieces at a time, but I seem to recall buying most of this in the 2008 time frame, processor I think in 2009, video card in 2010.

When I ran the Win8 compatibility program it didn't see any problems. Said some software might not work, but when I did the install I told it to overwrite everything.

The install went fine. As you go through it prompts you to enter you live.com logon information and I do and it goes off and registers the computer with this and I get a text message and all that.

Reboot... get the nice logon screen type in my password and the instant I hit enter, the Keyboard locks up.

Mouse still works though.

So I try a different keyboard. Keytronics E03600U2 brand new out of the box that I had sitting in a drawer. Same problem. Yes, I like keytronics... I buy these things for $20/ea from newegg, and they're 10 times better than anything I can buy locally. Can actually touchtype on them, unlike the mushy crap from microsoft, logitech, dell, etc.

Ok, so I try different USB ports... same problem.

At this point I said what the heck, I wanted to do some upgrades. So I go down to Microcenter and buy a DH77EB micro-ATX board, i5-3570K processor, 16 Gigs of Crucial Ballistix DDR3-1600 RAM and a 128 Gig Samsung 840 SSD drive.

Go through the entire install process. Keyboard locks up.

So then I start thinking about what could be similar. Pull out the video card and use the mboard's graphics. Do a fresh install again. Keyboard locks up.

Unplug the front USB connectors from the case, just in case. keyboard locks up.

Remove the G5 mouse and attach a Logitech MX1100 wireless mouse. keyboard locks up.

Scrounge around house, find a Zippy small keyboard from many years back with USB plug. keyboard locks up. Oh, but the hot buttons on the top work... I can adjust volume, start up email even power down the computer using the keyboard. Just can't type.

Through all of this, the mouse always works. So I check settings, I set device drivers... it's recognizing the keyboard, the driver is there and says it is working fine.

I've been assembling my own systems since 1992. I've made Win3.1 work, OS/2 Warp, Linux of various flavors. I've had every version of Windows running and never had a problem like this. I've had my share of devices not work out of the box requiring drivers, etc. Sound, network, video, etc. But I always got some bare default to work. Might have been VGA graphics, but the keyboard and mouse always worked and I could load up the other drivers.

But this isn't a driver issue. The keyboard works or I couldn't enter a password.

And I don't have anything else installed. It's a clean install, there's no funky anti-virus, anything. It's just pure Win8 install.

The other thing... all these keyboards and mice work just fine with Win8 installed on my Dell m4600 laptop.

I've given up on this for now. I have another case and drives and I'll probably try to put the old mainboard into that and see if it works. That's really the only other thing I haven't swapped, the case and power supply.

Also thinking maybe it's a problem using the live.com logon, need to try a local account. That might be the key since this blows up once I connect.

Anybody else have ideas?