Windows 8 and 8.1 Forums


computer won't boot in AHCI mode ?

  1. #1


    Posts : 153
    windows 8 pro x64

    computer won't boot in AHCI mode ?


    I installed windows 8 in ide mode in the bios. Now , if I set that to AHCI mode in the bios then the pc won't boot and repair cd cannot do make the pc bootable. How can I fix this ? Is there a performance difference between ide and ahci mode ? I use segate ST2000DM001 as boot drive and have gigabyte p43-es3g mainboard.

    If I can managet to set the pc to ahci mode , would windows 8 require activation or new license ?

    Any ideas? Thanks in advance.

      My System SpecsSystem Spec

  2. #2


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    No need to set BIOS to IDE mode to install Windows 8. Just load the Sata Controller drivers.
    SATA Driver - Load in Windows 8 Setup
      My System SpecsSystem Spec

  3. #3


    Posts : 354
    Windows Server 2012 Standard w/Hyper-V


    Did you install Windows 8 while the BIOS was set to IDE? If so, you may need to reinstall.
    Sent from my Nokia Lumia 920 using Board Express
      My System SpecsSystem Spec

  4. #4


    Posts : 153
    windows 8 pro x64


    I installed windows 8 in ide mode . I did the steps here How to Enable AHCI in Windows 8 After Installation but I cannot boot the pc.
      My System SpecsSystem Spec

  5. #5


    Posts : 446
    Win 8 64-bit
      My System SpecsSystem Spec

  6. #6


    Posts : 153
    windows 8 pro x64


    Thanks but that didn't solve my issue. My pc won't boot and stuck at this Click image for larger version

    The pc locks at this stage and I have to reset it and revert back to ide mode.
      My System SpecsSystem Spec

  7. #7


    I see that the board includes a Jmicron IDE controller. Do you have anything attached to it? If not, I suggest turning it off in the BIOS settings.

    (This is sort of a random try, but as your motherboard is based on an Intel P43 chipset, I'd expect switching to AHCI to proceed normally.)

    If all else fails, re-installing Windows with the SATA controller set to AHCI will fix it, but I understand your reluctance to go that route.
      My System SpecsSystem Spec

  8. #8


    Posts : 153
    windows 8 pro x64


    Thanks for the information. I re-installed windows in ahci mode. It seems a bit faster and quieter. I was surprised to see that hard drives work quieter in ahci mode ? . It may be a placebo effect ,too but really I get quieter and less vibrating hdds.

    Is ncq feature enabled by default in ahci mode ? How can I check it out?
      My System SpecsSystem Spec

  9. #9


    Posts : 3
    Win 8 Pro


    Quote Originally Posted by ecevit View Post
    I installed windows 8 in ide mode . I did the steps here How to Enable AHCI in Windows 8 After Installation but I cannot boot the pc.
    I followed this instruction and it WORKED! Thanks!!!!!!! τΏτ
      My System SpecsSystem Spec

  10. #10


    Posts : 153
    windows 8 pro x64


    You're welcome. It didn't work for my pc .It might be because of the fact that my hard drive was cloned from the old hard drive. Maybe cloning process didn't do something right on boot sector. Reformatting during installation in ahci mode may have been fixed the issue. I am not sure ,though.
      My System SpecsSystem Spec

computer won't boot in AHCI mode ?
Related Threads
I have successfully installed Windows 8 Pro x64 on an ASUS P8Z77-V Deluxe board on a SSD under UEFI/secure boot mode. Used the following settings: SATA Mode = AHCI Fastboot = enabled CSM = enabled Secureboot = Windows UEFI Everything works fine. Qcode = AO, performance is excellent etc....
Hey all, I tried installing the 8.1 Intel SATA/RAID driver from the ASUS website P8Z68-V motherboard model, but when enabling AHCI in BIOS I'm getting blue screens which is making me think something isn't configured properly in the OS. Does anyone know how to properly enable this in 8.1 yet? I'd...
Cant Change My SSD To AHCI Mode in Drivers & Hardware
hi, i have recently bought an SSD. I have heard from a youtube video that changing the Sata controller from IDE to AHCI can give me better performance but i tried to enable this and it doesn't recognize the drive. The PC will not boot in AHCI mode which meant i have to switch to IDE again. I have...
A couple of weeks ago, I cloned my HDD C drive to a new 250GB Samsung 840 EVO SSD. After fitting the SSD in place of the old HDD, the system rebooted fine and worked well with a very noticeable increase in the speed at which Windows loaded. However, Samsung's "Magician" software informed me...
My PC will not boot up. An error message occurs a few moments into the boot process " We're just collecting some error info and then we'll restart you." Th PC then disconnects and restarts and after a few few moments the same error message occurs. Have left if for 3 hrs and it is definitely stuck...
Solved AHCI mode windows 8 pro in Installation & Setup
When I installed Windows 8 pro (oem x64) it wouldn't allow me to install with my sata controller set to AHCI mode so I set it to IDE and installed, now I'd like to have trim support so want to enable AHCI. Just enabling AHCI in BIOS boots too a blue :( (blue screen of unhappiness, BSoU??) screen...
How to change SATA mode to AHCI? in Drivers & Hardware
When I tried to change SATA mode to AHCI in BIOS, it bluescreened while loading. I looked up the registry tweaks, but my registry seems to already be set up for AHCI.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook