Windows 8 and 8.1 Forums


Synaptics Touchpad/ Mouse disappeared

  1. #1


    Posts : 2
    windows 8

    Synaptics Touchpad/ Mouse disappeared


    Hello everyone,

    when I first upgraded to Windows 8, everything except the accelerometer was working perfectly. Now, weeks later all of a sudden my touchpad (synaptics) stopped working. I un- and reinstalled drivers, reset windows, reinstalled windows.. nothing worked. I checked in the driver settings, and it says it's working fine, but no input gets through.

    Does anybody else experience similar issues? Or does anybody got an idea how I could solve this issue? My Acer Aspire 1825ptz might have a touchscreen as well, but using the desktop without a proper mouse is still a pain.


    I uploaded my dxdiag, so you can have a look into my specs.

    Thanks a lot for any ideas,

    Cheers
    Synaptics Touchpad/ Mouse disappeared Attached Files
    Last edited by topher089; 17 Nov 2012 at 12:53.

      My System SpecsSystem Spec

  2. #2


    Try uninstalling touchpad driver in Device Manager, get the Acer Driver from here and re-install it.
    Download
    If that doesn't work, try the driver from Synaptics.
    Drivers | Synaptics
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    windows 8


    Solved. Thanks a lot I should have figured that out myself :P

    -Closed.
      My System SpecsSystem Spec

Synaptics Touchpad/ Mouse disappeared
Related Threads
Hi everyone I intended to post this one in Tablets & Touch section at first, but since this issue only occurs while using IE 11 -- I thought this may be due to some conflicts or settings change in IE 11 that is causing the issue. I am using latest WIN 8.1.1 64-bit OS. Just bought this lap 2...
So I was updating my drivers, and had wanted to update my Synaptics driver. I had removed the older version of Synaptics driver (because I was required to) and wanted to restart. My computer restarts, and I try to install the latest version of the Synaptics driver, it doesn't work. It says "install...
It seems like only the middle area of my touchpad is working, even with edgemotion disabled. Any way to make whole area usable? Didn't know where to ask this... Help appreciated :)
Hi i just did a clean intall of win 8.1 and installed all drivers etc and now my synaptich touchpad installer poops up on every boot any ideas? windows installer is set to manuel even other installers starts aswell
Am using windows 8 pro with the synaptics drivers on my sony vaio, but they are taking ages to load in whenever I reboot/startup my laptop. I was wandering if there are any tweaks I can do to make it load into my system tray quicker. I dont have many things loading at startup so I cant see what...
In Windows 7 I downloaded the latest driver from Synaptics and it gave me the option to disable the touchpad. However nothing I do has allowed me to do the same thing in Windows 8. I never get the touchpad icon in the system tray. When I go to the Mouse device in device manager it shows the...
Synaptics Touchpad Settings in Drivers & Hardware
Hello, I just got an Acer Windows 8 PC, and none of the touchpad gestures seem to be working. I have tried using several recommended third-party tools and all of them said that I didn't have the correct drivers, even after I installed all of them. I have gone to mouse --> Synaptics -->...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook