Windows 8 and 8.1 Forums


Strange Card reader problem. Maybe USB3 related.

  1. #1

    Strange Card reader problem. Maybe USB3 related.


    I have a Kingston USB3 multi card reader that was working fine with Windows 7. After upgrading to Windows 8 on Sunday i now find that the SD card slot works fine, but the CF slot wont ready my CF Card, it just sits there flashing away.
    Now the strange bit. I took the card reader and connected it up to two other PC's, both running W7 but USB2 and had no issues. The CF card and slot worked fine. The card is from my DSLR and is definitely working ok, but i only have the one CF card so cant really test the reader.

    I know there are USB3 drivers issues under W8, as in no Intel USB 3.0 Extensible Host Controller drivers, so speeds are not what they should be, and im wondering if this might be the problem.

    Any ideas most welcome. I do have a new card reader, just in case, so need to test that out this evening but if the old one works ok on other PC's i cant see that this is the problem.

    Thanks

      My System SpecsSystem Spec

  2. #2


    Seems like it is the card reader thats faulty, but still only with USB3. New one works fine.
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8 Professional


    It looks like I'm having the same issues. My CF cards are not reading on my new Kingston USB3 card reader.

    I had to use my old card reader to access my CF card.

    Have you gotten your Kingston reader to work with CF cards on Windows 8 and USB3 yet? You mentioned that it was a faulty card reader? Is your new reader the exact same model?
      My System SpecsSystem Spec

  4. #4


    I went and got a Lexar card reader and it works fine, plus it seems a bit faster than the Kingston. Ive got some hacked Intel drivers for USB3 now so ill give the Kingston another go tonight and post back.
      My System SpecsSystem Spec

  5. #5


    Does it use a NEC chipset? Asking because my motherboard uses a NEC chipset for the USB 3 jacks -- and I had to go to the NEC site, download updated firmware and drivers, and apply BOTH before I got USB 3 speeds.
      My System SpecsSystem Spec

  6. #6


    Posts : 2
    Windows 8 Professional


    It looks like the Kingston media card reader I purchased wasn't shipped with Windows 8 firmware. I didn't realize that hardware needed to be updated for Windows 8 if t was already previously working on Windows 7. Luckily, Kingston did release updated firmware for this particular card reader. So after updating the firmware, the reader worked fine and gave me full USB3 speeds.

    My only complaint is that I honestly didn't know card readers even had updatable firmware and Kingston didn't make it easy for me to discover that. I'm going to say that my above-average knowledge about computers and drivers/firmware was the only reason I knew what to look for to fix this. Any other average non-tech savvy consumer would probably struggle to find a solution.

    So a quick summary to anyone still trying to fix their card readers... Search for firmware and driver updates for your card reader and USB/motherboard.
      My System SpecsSystem Spec

  7. #7


    Thanks very much for posting about the FW. I too would never had thought about this being the issue, especially as it was only the CF slot that i had trouble with.
    Ive updated my FW and will try the card reader tonight, although as its not as good as the Lexar one ill keep it as a spare or at work.

    UPDATE: Yep, that fixed the issue, thanks again.
    Last edited by Fliplip; 15 Dec 2012 at 21:42.
      My System SpecsSystem Spec

Strange Card reader problem. Maybe USB3 related.
Related Threads
I have the very latest Windows 8.1 update. My internal multi card reader has been working fine for just under a year but just recently it has stopped recognising SD cards. When I insert a card it normally opens an explorer window but now it does nothing and does not show in file explorer. ...
Please help! Just upgraded to Win 8.1 Pro from Win 8 on a Dell Latitude E6530. Everything was working fine; post upgrade, system does not recognize any of my SD cards upon insertion. All other peripheral storage devices are fine. Has anyone run into this problem; if so, know a fix? Thanks.
Built a new system, all good EXCEPT memory card reader. No big deal, but I have had internal card readers on the last couple of PCs and find them convenient. Ordered a Rosewill RCR IC0001-r, found that id does not work with Win 8 /64. Started asking vendors about compatibility, not finding any...
mutimedia card reader problem in Drivers & Hardware
I am using Dell xps 8300 desktop,it came with windows 7 ultimate 64 bit preloaded. subsequently I have upgraed to windows 8 pro 64 bit.it has 19-in-1 card reader. I have downloaded and intalled windows 8 drivers from "dell community wiki link" by natakuc4. The Foxconn icon manager I have...
Strange boot problems (related to video card?) in BSOD Crashes and Debugging
Hello everybody, Yesterday I installed windows 8 on my 4 year old Acer Aspire 5920G laptop (still runs many recent games decently), dual booted with Vista (OEM) and W7. W8 was installed succesfully and it worked as it should, but when I let the system do a performance rating the screen went...
It also slows down my computer it appears - The driver that was installed automatically says 2006 IC USB Storage-CFC USB Device this is the hardware ID under USB MASS STORAGE DEVICE USB\VID_1019&PID_0C55&REV_0100 USB\VID_1019&PID_0C55 And under one of the Tabs:...
So, shutdown problems... We meet again. I have an "internal! Memory card reader in my computer connected to the mainboard's USB slot. The reader works correctly, but every time I shut down my computer Windows realises to start complaining about Empty drives. I press the shutdown button. ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook