Windows 8 and 8.1 Forums

Fix file system on external WD passport?

  1. #1

    Posts : 7
    Windows 8 64-bit

    Windows 8 not detecting WD passport properly...

    Hi guys,

    My external WD passport started showing up as empty and I can't access it directly in explorer. I ran a few chkdsk commands and it came back clean. When I attached it to another USB slot, it came up as being RAW instead of the default NTFS.

    Everything shows up fine in Stellar Phoenix Data Recovery (any good alternatives btw?), but I don't have space to back up to right now. Is there a way to rebuild the drive/files structure so it works normally again without copying/re-formating the drive?
    Last edited by BleepingCrazy; 11 Nov 2012 at 03:21.

      My System SpecsSystem Spec

  2. #2

    Posts : 7
    Windows 8 64-bit

    OK, I just checked it on my wifes laptop (win7) when she got home. It works fine there and I can access the files, etc without issue. So it's a windows 8 thing apparently? Here on my PC, once plugged in it says "Choose how to handle unknown content"....Access is denied.

    I tried changing the drive letter for it but that didn't work.

    Any ideas?

    UPDATE: Really weird, it was the only external drive that didn't work on Windows 8 (Failed on Vista too, but worked fine on Win7) WTF? :|

    I had to move all my "precious" stuff to various safe places and reformat it in the end. Working fine for the moment on win8, but I'm sure it's on deaths door...
    Last edited by BleepingCrazy; 11 Nov 2012 at 03:23.
      My System SpecsSystem Spec

Fix file system on external WD passport?
Related Threads
Hello all, I didn't use my external hard drive for over a month, and today I decided that i wanted a back-up of some of the stuff on my laptop. I plugged it in and immediately a message popped up, saying that this drive was protected by something called BitLocker. It required me to enter a 48...
File history cannot recognize my external HD in Performance & Maintenance
it says File history cannot recognize my external HD. Under the icon of my external HD it says "Unknown error". Its HP SimpleSave 1TB external hard drive. Please Help. Thanks. Sent from my Windows 8 device using Board Express
About a few days ago I tried copying some stuff from my old laptop to my new one with my Toshiba HDD (750GB). Some are large sizes. At least 2 files were corrupted and from then on out, I've been having issues with the external. The folder it was in could not be deleted. I tried EVERY possible...
Hi all, In the process of installing a new Win 8.1 machine, going mostly OK, but I have a WD Passport Ultra that is not working with it at all. I plug it in, it lights up and spins, but never shows up as a drive either in "This PC" or in disk management; nothing at all in device manager either. ...
Solved New WD 1TB Passport error. in Drivers & Hardware
Hi everyone, I am copying lots of files from one external hard drive, an old 3.5", to my new WD Passport 1TB with USB 3.0. The first few folders copied but when I checked in hours later, I received the error "The sephamore timeout has expired." My source HD (G: ) seemed to be fine but my...
Help. This is driving me nuts. Not sure what's happened and pretty sure I have not done anything to silly. Background : New Windows8 install all update and drivers : system running absolutely fine. Issue :Copying data from one drive to another via any hub on system...
(Or how to remove Write Protection from Pendrive). Pendrive doesn't have any write protection lock key on it.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook