Windows 8 and 8.1 Forums

Saitek Pro Gamer Command Unit not being recognized

  1. #1

    Posts : 5
    Windows 8

    Saitek Pro Gamer Command Unit not being recognized

    I use a Saitek Pro Gamer Command Unit for Games and some editing with various
    programs, the Command Unit worked on all games and programs running Windows 7.

    I have installed Windows 8 and in the properties all is fine and buttons working.
    Problem is that no games or programs are recognizing that it is there.
    The drivers are up to date. so what needs to be done or changed ??
    Also tried to see if it would type on notepad. It will not.
    Properties and profiler show that it is working.

      My System SpecsSystem Spec

  2. #2

    Posts : 61
    Windows 8 Pro

    Have you tried "add a device"? in the "Devices and Printers" in control panel? See if it is recognized?
      My System SpecsSystem Spec

  3. #3

    Posts : 1
    Windows 8 Pro (64-bit)

    Not sure why this thread was marked as "solved" as it contains no solution.

    Same problem here: Saitek Pro Gamer Command Unit. All drivers up-to-date. Saitek control panel shows unit as functional, but no keystrokes are being sent to games or to the note pad. Have "added" and "removed" the device multiple times via control panel, and Windows does appear to recognize it. Thoughts?

    Anyone ACTUALLY found a solution to this one?
      My System SpecsSystem Spec

  4. #4

    Posts : 61
    Windows 8 Pro

    Did you check your USB ports in the device manager? All drivers there? I remember I had to do a manual update on one of them. I don't have the Saitek but use other devices like that and they work fine now.
      My System SpecsSystem Spec

  5. #5

    Posts : 4
    Windows 8

    I got the same problem when I upgraded from Windows 7, where the Saitek worked beautifully.
    There are no need to "add a device" it is recognized correctly by the full name and make 'Saitek Pro Gamer Command Unit'.

    So it is connected alright and recognized by the USB, I did one attempt to fix it with the automatic tool to identify problems and Windows stated it did some changes to the system, a second attempt yielded the reply that it were not possible to identify any problem - and so this problem persist.
    (there do not appear to be any manual search/add feature which I could attempt with)

    And I have also made one update to Windows 8 to no avail. When opening the control panel for the Saitek unit itself, it is a small software that came bundled but also are updated to the latest version, I can see the buttons being pressed.
    But the Saitek unit do not communicate with any programs just as Nomina stated.

    This is really a big problem that have rendered my computer useless, I use the Saitek to add numbers, data and statistics into various fields, since the numerical keyboard are located at right - which is my mouse hand and I am right handed cannot use the left hand for the mouse, but in the 2 other modes of the Saitek I got ready made formulas to insert in various fields on how the data are supposed to be handled. So there's no realistic alternative of using the keyboard instead of the Saitek for my scientific work.

    If no solution is found I really will have to consider a rollback to win 7, sadly the OS came bundled with the computer which will mean i will have to wipe all and buy a license - no disk included for this OEM computer.

    Before that I really hope someone have some input on a solution, so I will keep an eye on this forum for a while.
    ....until then I am completely stuck and only work at 1/10 of my usual ability.

    Edit: To admin, please do not have this subject flagged as solved, I have spent several days on attempting to fix it, talked to various people, my sysop guy are stunned on why the Saitek refuse to communicate properly since it is recognized.
      My System SpecsSystem Spec

  6. #6

    Posts : 5
    Windows 8

    Sorry it was solved for me I figured with the new drivers and
    software nobody else would have a problem.
    I just went to the new Saitek page

    select Choose Product Type
    select Gamepads
    select Pro Gamer Command Unit
    select operating System
    Download Driver and software.

    You can test it also by opening note pad and typing with it.
    set it to green.
    With the new drivers and the new profiler it works great for me on Win 8 Pro. x64

      My System SpecsSystem Spec

  7. #7

    Posts : 4
    Windows 8

    Thank you, I have done that. The only result were that the profiler did not load any more.
    Without the profiler, the Saitek are useless. Going into the new files installed one can open the programmer tool, and then the Saitek suddenly will activate, where the buttons now act as a qwerty keyboard.
    But the window to open and activate the Saitek with the profile of my chose are missing, and at the moment the unit are useless.

    I did a rollback to the previous version to get the launcher up again, and it were at that point I made the previous post.

    Since then I have installed the drivers no less that twice, but the problem of no profiler menu remains. So I have mailed support.
    If they provide information that solve this matter I will add the solution to this problem as a reply to this thread.
    Last edited by TheAnt; 21 Jan 2013 at 18:58. Reason: One sentence did not make sense.
      My System SpecsSystem Spec

  8. #8

    Posts : 5
    Windows 8

    The Profiler that I have that works is MadCatz Software version driver version
      My System SpecsSystem Spec

  9. #9

    Posts : 5
    Windows 8

    OK, I installed the new driver and software, they DO NOT WORK.
    My Command unit stopped my RAT 9 was off and My STRIKE 7 worked a little.

    The software and driver I use do work.
    Here they are if you want them They are for x64. if you are on a 32bit system
    you will need MadCatz software version and driver

    Software Profiler x64

    Command unit x64

    These work on my system: Windows 8 Pro x64
    I use a lot of Saitek including The X52Pro and Rudder Pedals All work with this Profiler

    I found the 32Bit Drivers, I have not tried these.

    Software Profiler x32

    Command Unit x32

    All Win 7/8
    Last edited by Lighthorse; 21 Jan 2013 at 15:30.
      My System SpecsSystem Spec

  10. #10

    Posts : 4
    Windows 8

    Good grief!

    That's it, and you did provide a solution and thank you very much for that Lighthorse.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Saitek Pro Gamer Command Unit not being recognized
Related Threads
Solved DISM Analyze command not recognized in Performance & Maintenance
Can anybody please help me fix this? 41287
Hi, i'm curious if anybody is still using their x-fi xtremegamer soundcard on windows 8.1 OS. I really wanted to dump it and use my onboard realtek ALC892. But, the audio to my surprise was inferior. Odd that a card I acquired in 2008 still beats out a modern onboard sound solution even...
I have the latest Creative driver on here for Win 7 64bit, and I'm not getting any sound. Anybody else having this problem.
Big problem to the acer unit in General Support
windows 7 upgrade to windows 8 has many problems it is not compatible to the device.. what the heck..
Solved CD/DVD unit not recognized in Drivers & Hardware
After upgrading to Windows 8, my CD/DVD unit (a Samsung - TSST corp CDDVDW Sh-S223L) will not be recognized unless a disc is inserted before boot. Then disc can be removed and new one inserted later. Any assistance appreciated. Stephen
My gamer tag is not associated with my main Microsoft account that I use. It seems like a big pain to have to create a whole new user and switch to it in order to use the xbox live app. Does anyone know if there is anyway to log into a different Xbox live gamer tag than the user account you are...
It seems that the soundblaster cards are currently not working with Windows 8. To be expected since this is a pre beta. But I installed the drivers for my Extreme Gamer and it was crashing every few minutes. I then reinstalled Windows without installing the drivers and it was STILL crashing every...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook