Windows 8 and 8.1 Forums


USB Port not working after upgrade

  1. #1


    Posts : 3
    Win 7

    USB Port not working after upgrade


    Got as far as the initial Personalisation screen (background colour) following an upgrade from 7 to 8 Pro and no keyboard or mouse working (wireless). Tried a hardwired keyboard/mouse and even dug out an old keyboard with a PS2 connector, none worked. Looked at the xbox receiver I have plugged in and no light on that or a USB key. So it looks like at least the USB ports are not working.

    The m/b (Asus M4A88TD-M EVO/USB3) also has a PCI slot based USB3 card so tried that as well but nothing.

    Looks like a major driver issue, is there any way to provide additional drivers during the upgrade?

    Thanks, Simon

      My System SpecsSystem Spec

  2. #2


    Posts : 5,707
    Windows 8.1 Pro


    Hello there!

    If you go to Device Manager (type device manager in at the Start Screen) and click on Universal Serial Bus controllers, you should see a decent list of entries of controllers and root hubs. If you can, please take a screenshot or snippet (Start key+PrintScreen for a screenshot, a folder will be made in Pictures labeled Screenshots; or use the snipping tool for the snippet) and post it here.

    You can also try downloading and installing the USB drivers from ASUS.
    ASUSTeK Computer Inc. -Support- Drivers and Download M4A88TD-M EVO/USB3
    Hit the USB entry, and if your USB controller is built by NEC, do that one. If you don't know, you can just try both and see what sticks.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Win 7


    Hi, thanks for the reply, I'm assuming you mean the Windows 7 Device Manager details as I don't get as far as being able to access Win 8 DM becuase I have no mouse or keyboard to get past the personalisation screen.

    Here's the Win 7 DM details :


    The NEC devices are the USB 3 ports on the pci card.

    As you can see in Win 7 all USB devices are working fine using the latest drivers.

    Simon
      My System SpecsSystem Spec

USB Port not working after upgrade
Related Threads
My USB port suddenly stopped working after inserting another USB device. My unit has 4 rear USB and 2 front USB port. 2 rear USB port are used for USB mouse and USB keyboard, after inserting another USB speaker in the rear USB port, my mouse and keyboard suddenly stopped working with lights off...
Hey guys i bought hpx705w usb 3.0 drive.Its not working in front usb ports of my desktop but works fine when plugged in back usb ports.And also works fine on my laptop usb ports. What should i do ? Running windows 8
Dear community, It seems that my new MSI GT70 2OD's USB 3.0 port(s) are experiencing serious issues. Because as soon as I try to transfer any file or folder with files in them, it just disconnects the external drive, and claims that the file transfer failed! While in USB 2.0 port(s), it works...
CDMA software requires a COM port to communicate with a cell phone. I'm using HW Virtual Serial Port v3.1.2 (single port, standalone install). I have a separate modem and router. My Win8.1 PC is hardwired to the modem. Windows firewall is off. Windows Defender is off. Motorola Mobile Drivers...
Ethernet port not working in Network & Sharing
just noticed my Vaio ethernet port isn't working. it says the adaptor is working normally, but when I plug in an ethernet cable is says the cable is not plugged in. I tried it with two different cables that work elsewhere. I wonder if the laptop ethernet card is faulty? Wireless is working...
USB 3.0 port not working in Drivers & Hardware
Hi guys, I'm new to this forum, and I am having trouble with my USB 3.0 port. Whenever I plug anything (usb, mouse, portable hard drive etc) into that particular port, "Client Server Runtime Process" would use 100% of the CPU. However, when plugged into the USB 2.0, all seems to be fine. Would...
Hello everyone, I am using Windows 8 64 bit Pro. After my ps/2 mouse was giving problems I recently switched to using a wireless usb mouse. Now when that didn't suit me I wanted switch back to a ps/2 mouse. But the problem is that now when I attach the mouse to the ps/2 port,...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook