Windows 8 and 8.1 Forums


Windows 8 x64 Ivy Bridge USB Issues

  1. #1


    Posts : 6
    Windows 8 Pro x64

    Windows 8 x64 Ivy Bridge USB Issues


    I have had Windows 8 build 9200 for a couple months (through volume licensing) and ever since I have had issues with how Windows 8 treats USB 3.0 devices. It claims the device is connecting via USB 2 speeds and when transferring files this is obviously apparent as the speeds hovers around 30MB/s.

    Since I just joined this forum here are my specs.
    W110ER
    Intel Core i7 3630QM
    16GB Hyper-x 1866
    512 OCZ Agility 4
    GT 650m (optimus)

    So know this, anybody else with an Ivy Bridge CPU having issues with the Intel USB 3.0 drivers (USB eXtensible Host Driver).

      My System SpecsSystem Spec

  2. #2


    Posts : 80
    Windows 8 Pro


    Not here. System in specs. USB 3 is 100MB/s roughly. Annoying that USB 3 is only detected 97% of the time. Same thing happened in Win 7 though, so meh.
      My System SpecsSystem Spec

  3. #3


    Posts : 6
    Windows 8 Pro x64


    I just tested a Sandy Bridge CPU and the USB port in Windows 8 still reports it running in 2.0 mode. I posted a question on the Intel Forums to see if I can get a response. wishful thinking maybe
      My System SpecsSystem Spec

  4. #4


    Redmond
    Posts : 651
    Windows 8.1 x64


    I've seen this very issue with Lenovo laptops as well, and it ended up being a BIOS configuration issue (specifically the USB3.0 setting - if it's anything other than "Enabled", Windows 8 does NOT pick it up for some reason). Might want to check your motherboard's BIOS settings.
      My System SpecsSystem Spec

  5. #5


    Posts : 6
    Windows 8 Pro x64


    Quote Originally Posted by cluberti View Post
    I've seen this very issue with Lenovo laptops as well, and it ended up being a BIOS configuration issue (specifically the USB3.0 setting - if it's anything other than "Enabled", Windows 8 does NOT pick it up for some reason). Might want to check your motherboard's BIOS settings.
    Yeah, wish it was that easy. I have a W110ER with NO such setting. In fact, I didn't even touch any BIOS settings after the fresh install.
      My System SpecsSystem Spec

Windows 8 x64 Ivy Bridge USB Issues
Related Threads
Solved Bsod page fault in non paged area ivy bridge in BSOD Crashes and Debugging
this pc was built around 1 year ago 3570K @ 4.2gHZ stock volts max temps around 75c using a hyper 212 plus P8Z77-V Bios 2104 Sapphire 7950 dual x fans running stock with AMD beta 14.4 2x4GB corsair memory they are rated at 1600mhz the motherboard set it to 1333hz as default but i switched...
My mac miniport birdge is not working when I try to connect it. It says "Please wait while windows bridges the connection" and when it is finished it does not bridge. I have spent a good few hours going threw fourms and stuff trying various things but nothing seems to help. I have also noticed that...
Solved Metro requires network bridge? in Network & Sharing
In 8.1 Pro, 64-bit: In an effort to allow connectivity with a virtual machine using VMware Player, I deleted the Network Bridge. While this indeed enabled connectivity I now find that Metro apps (at least iHeart radio, Weather) requiring Internet connectivity no longer work. I have already run...
I have a Dell Inspiron 660s running Windows 8.1, and I just did a full boot of Ubuntu 13.10 onto a Dell Optiplex 330 that was previously running Windows XP. My goal is to connect to the internet by using the 660s as a bridge to the internet by connecting the two computers with an ethernet cable. ...
I'm trying to simply connect my Pc to xbox but cannot due to reasons because the network is bridged and I am unable to select the sharing tab. I see on forums to simply go to network sharing window, manage networks, right click and delete. But there is no "Manage networks option. Just adapter...
BSOD driver not less or iqual ( bridge.sys) in BSOD Crashes and Debugging
Hello, my pc .. after many restart ( cause BSOD bridge.sys) is very slow please help:(
My 1st of 3 i7-3770K Ivy Bridge systems is up and running. I am migrating from a ASUS P8P67 EVO i7-2600K (doh, I know but I have a home for the SB system). I was able to TEMPORARILY move a clone of the boot drive into the new machine and have it boot, but then things started getting hinky (is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook