Windows 8 and 8.1 Forums


None of my USB ports are working.

  1. #1


    Posts : 2
    Windows 8

    None of my USB ports are working.


    I hope this is the right place to post.

    So I upgraded this morning from windows 7 to 8 and it all seemed to be working alright. Then my usb ports stopped working. Can't use mouse, doesn't recognize external hard drive or anything else.

    For the first few minutes it was all working ok and I could use my wireless mouse etc. I'm usually on a wired internet connection but switched on the wireless to check that it all worked, right away I noticed 3 items pop up in the task bar which had the word "device" but they disappeared fairly quickly so I couldn't see what it was all about. After that, everything stopped working.

    When I go to Device Manager, I see a list of "USB Hub Root" with yellow exclamations next to them.

    Any ideas how to go about fixing the problem?

    EDIT: When I right click on "USB Hub Root" it gives me this: Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)
    Last edited by Daryn; 25 Oct 2012 at 23:11.

      My System SpecsSystem Spec

  2. #2


    Posts : 2
    Windows 8


    Figured it out. After a bit of searching on google, found someone else had a similar problem. Turns out the driver for my ps3 controller was clashing with the usb root hub ports. Just uninstalled libusb-win32 and everything is working again.
      My System SpecsSystem Spec

None of my USB ports are working.
Related Threads
Post upgrading to Windows 8.1 Pro on a Dell XPS15, 'only' 1 of the 3 USB ports has stopped working. The other 2 are working fine. I have the latest BIOS A16. I've uninstalled all USB drivers and had them auto-resintall on boot. No change, 1 USB port (the one with powershare) is still not...
Hello everyone, My pc specs are as follows: 1)Intel 4670 K 2)Asus Sabertooth Z87 3)12 GB DDR3 ram 4)Windows 8.1 Pro x64 5)Razer DeathAdder 2013 mouse 6)Logitech Usb keyboard
USB 3.0 ports not working in Drivers & Hardware
Hi there... So, my USB 3.0 ports are not working with my USB 3.0 ext-HDD. It's an ADATA Nobility NH13 I don't have any other USB 3.0 equipment to test, but the ext-HDD works perfectly on my laptop and on my TV as well, so it's definitely not the HDDs fault. When I plug in USB 2 devices, they...
And it happens only when I boot the computer up and find that neither my keyboard or mouse are working then I plug them into front (2) avaialable usb ports and they work fine.... And then If I try to uninstall universal bus controllers by device manager then my keyboard + mouse stops working...
usb 3.o ports suddenly not working in Drivers & Hardware
I dont know why but my external hard drive isnt showing up when connected.. Windows makes the connection noise when I plug it in but it dont show up in disk management, device manager or anywhere else... If I plug it into a regular usb port it works fine... And its a usb 3.0 capable drive it worked...
USB Ports not working in Drivers & Hardware
Ok so I have a windows 8 64 bit machine. I have a xerox personal scanner as well as a dell 2330d printer. My issue is that the scanner only works if i have it plugged into one of my usb ports on the front of my machine and will not work on any that are on the back of the machine. As for my...
Recently I installed a fresh, clean install of Windows 8 pro 64 bit on a sony vaio laptop vgn-z540n model, and then did a restoration of Windows settings and files from windows easy transfer (wasn't able to transfer everything though). After that, installed most of the drivers that to make the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook