Windows 8 and 8.1 Forums


Using Windows Defaulted

  1. #1


    Posts : 1,720
    Windows 8.1 Pro

    Using Windows Defaulted


    After buggering things up and performing another clean installation, for the 'ump-teenth' time in half as many days, I decided to try and run Windows with all default and recommended settings.

    I just can't do it! I don't think it can be done!

    Does anybody run Windows straight 'Out of the Box'?

      My System SpecsSystem Spec

  2. #2


    Trnava
    Posts : 683
    Win 8.1.1 Pro x64


    Almost everyone, even people who heavily tweaked XP and 7 firmly believe, that 8.1 is perfect as it is. They do not realize, that it is the same old, ehm. They even glorify memory management, that has not changed much since XP/Vista and if there is any problem, they blame everything else, but the glorious Windows.

    Quote Originally Posted by Edwin View Post
    I just can't do it! I don't think it can be done!
    Amen brother. I have honestly tried as well a few times, but I just could not handle all the sluggishness.
    Cold startup of my browser is about 2-3 secs, deleting a file does not take 5-10 secs like on default either.
      My System SpecsSystem Spec

  3. #3


    Posts : 1,720
    Windows 8.1 Pro


    Don't get me wrong, I'm pretty much convinced its MS' strongest, most versatile OS to date, but not straight out of the box!
    I think, after the install, I navigated around for about 20 minutes but then had to start streamlining stuff!
    Haven't installed my favorite browser yet but getting very close cuz this IE is driving me nuts! (fast though!)
      My System SpecsSystem Spec

Related Threads
I have been running Win8's Explorer (file) using Classic Shell to retain the Win7 classic look and feel of Win7. For unbenowst reasons today the Explorer no longer appars as the old Win7 version, but instead has reverted back (up to?) the Win8 version (which I dislike) for a totally unknown...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook