Windows 8 and 8.1 Forums

Win 8.1 UEFI won't boot after modifying GPT partitions

  1. #1

    Posts : 2
    Windows 8.1

    Win 8.1 UEFI won't boot after modifying GPT partitions

    Hello Windows experts.

    I've been using Windows very little these past years and now I bought a laptop that is very 8.1 friendly and I'm clueless. I need your help.

    I first wiped everything off the disk and installed other systems (GNU/Linux). Then I installed Windows 8.1 Single Language 64 bits alongside my other OS. Installation was fine and they lived together happily. Until one day Windows stopped booting. I'm not sure why, but I believe it has to do with modifying other GPT partitions (erasing/creating) which in turn weren't related to Windows at all (ext4 partitions). I used to do this with previous Windows versions installed in other computers and there was no problems, but I guess Windows got very "touchy" (pun intended) and doesn't like this anymore.

    Now Windows boots but resets and then enters in the recovery mode. So I tried the repair options, and I also tried with the installation disk I created with media creation tool, but no joy. Everything fails. The log file at C:\Windows\System32\Logfiles\Srt\SrtTrail.txt mentions only 0x0 and 0x490 as errors. But that doesn't say anything to me (I hope it does to you).

    So it doesn't boot through, but I can access the troubleshooting options. That's all.

    I hope this isn't too serious and you can point me in the right direction to fix this baby soon without re-installing Windows.

    Thanks in advance!

    PS: Secure boot and Fast boot were always disabled and the system has also always been working in UEFI mode.
    Last edited by passerby8; 09 Jun 2015 at 03:46. Reason: more data

      My System SpecsSystem Spec

  2. #2

    Posts : 2
    Windows 8.1

    Solved it !

    Got it!

    Deep searching the web I found my answer.

    It was simple and dumb, I can't believe all the automated recovery/repairing processes couldn't solve this!

    It turns out that Win messed up the drive letters. What should be C was instead E.

    This post was my key!

    Based on it, this is the procedure I followed:

    Get into the command prompt (either from a recovery disk, installation disk, or the menu that comes up after Windows tries to Diagnose, Recovery, etc).

    Don't even bother with the automated recovery process, it will not work as it cannot find a Windows partition.
    Once in the command prompt, type:


    In case you only have one drive, then:

    DISKPART> sel disk 0

    DISKPART> list vol

    And take a look here, pay attention to what is the letter assigned to the Windows root (main) partition. Now make it match with the letter it had prior the mess up. Assuming your root partition is vol 3, and that it had the letter C:, this is (basically) what you should do:

    DISKPART> sel vol 3 (Enter)

    DISKPART> assign letter=C:

    DISKPART> exit

    Now close the command prompt and continue with the Windows booting process.

    Hope this helps somebody else! (I love this pink elephant, it's so irreverent!)
      My System SpecsSystem Spec

  3. #3

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Passerby8 ^_^,

    Thanks a lot for posting the solution which worked for you. I am sure this would help the future visitors.

    Let us know in case of any further problems ^_^

      My System SpecsSystem Spec

Win 8.1 UEFI won't boot after modifying GPT partitions
Related Threads
Hi, I'm following this guide and using the UEFI install instructions from this forum. I do meet all of the requirements (Windows 8 64-bit iso, ASRock Z87 Extreme4 mobo, blank SSD). When I get to Step 7 in the UEFI guide, I only get 2 partitions instead of the 4 shown(Recovery, System, MSR,...
♫ Just bought a Dell Optiplex 7010 Mini-Tower with Win 8 Pro 64-bit, 8 GB RAM, 500 GB hard drive and an Intel i5 3470 processor. Right now, it has Dell BIOS version A16. It is normally in UEFI ON and Secure Boot ON, so that F12 on bootup (one-time boot options) does NOT normally show the...
Hallo, After creating a UEFI bootable USB thumb drive with Rufus (using Windows 8.1 Enterprise ISO x64), for a Dell Optiplex 3010 (configured as UEFI only, no CSM, latest firmware version, Windows 8 installed), I didn't see a USB boot option, so I tried to add one manually. Unfortunately I...
Hello to the forum. Thanks for the welcome. And thanks for pointing me in this subforum. I have a notebook toshiba satellite L850-1HU with UEFI Default is win 8 os, recently upgraded to 8.1. Now I need to win 7. I have a professional license N sp1 x64 and then supports UEFI
Dear Friends, Long time reader of this forum but a first time poster, so please forgive me if this question has already been asked and answered. Laptop: ASUS UX31A-DB71, latest BIOS: 218 Originally my laptop came with Windows 7 and when i looked at disk management my disks were formatted...
Hello, first post here... First, some context: I have a Dell Inspiron 15R SE that came with Windows 8. I've managed to get a working dual-boot system with Ubuntu 12.10. I can't remember exactly how I done that, but I remember that I had to disable secure boot. I think that the boot...
My notebook has a Win 8 OEM key in UEFI. After wiping my hard disc I want to install Win 8 retail instead of OEM version. Because this is not possible with stored OEM Win 8 key I want to boot with a Win 7 BootCD and patch the UEFI with a Win 8 retail serial key. For that I need a Program...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook