Windows 8 and 8.1 Forums


bad_pool_caller on win 8 64bit

  1. #1


    Posts : 4
    windows 8 CP

    bad_pool_caller on win 8 64bit


    When I hibernate my laptop and try to turn it back on it gives me blue screen with Bad_Pool_Caller problem. Anyone knows how to solve it?

    I'm on Win 8 CP 64bit
    I've attached minidump rar

      My System SpecsSystem Spec

  2. #2


    Posts : 5,139
    Win8.1Pro - Finally!!!


    Please provide this info: https://www.eightforums.com/crashes-d...tructions.html

    Hibernation issues usually involve video, storage, and chipset drivers - please update them all. If you already have the most recent versions, please uninstall them and then install a fresh copy.

    Running the May and June memory dumps (11 of them).......
    And nearly all of them blame HssDrv.sys - a driver component of HotSpotShield.
    Please uninstall the program to see if it fixes the problems.

    You have a 341 mHz overclock - I'd suggest removing that until the system is stable again.

    Please check the links below for drivers dated 2009/10 and earlier.
    Then use the links below that to find and update these older drivers.
    In particular, your chipset drivers are very old and should be updated.

    The following info is just FYI, I've already addressed the issues that I saw in the above paragraphs

    - Further info on BSOD error messages available at: http://www.carrona.org/bsodindx.html
    - Info on how to troubleshoot BSOD's (DRAFT): http://www.carrona.org/userbsod.html
    - How I do it: http://www.carrona.org/howidoit.html

    3RD PARTY DRIVERS PRESENT IN THE DUMP FILES
    Code:
    
    kd.dll             Fri Feb 17 23:37:13 2012 (4F3F2AF9)
    SCDEmu.SYS         Thu Feb 09 00:59:50 2012 (4F3360D6)
    WdFilter.sys       Fri Feb 17 23:35:36 2012 (4F3F2A98)
    wfplwfs.sys        Fri Feb 17 23:30:50 2012 (4F3F297A)
    taphss.sys         Tue Sep 15 15:58:23 2009 (4AAFF1DF)
    Rt630x64.sys       Wed Oct 19 08:12:55 2011 (4E9EBEC7)
    igdkmd64.sys       Fri Feb 11 14:16:32 2011 (4D558B10)
    HECIx64.sys        Thu Sep 17 15:54:16 2009 (4AB293E8)
    rtl8192se.sys      Mon May 09 09:52:17 2011 (4DC7F191)
    SynTP.sys          Thu Mar 31 21:30:00 2011 (4D952A98)
    ATK64AMD.sys       Tue May 12 21:04:54 2009 (4A0A1CB6)
    HssDrv.sys         Thu Sep 02 13:47:07 2010 (4C7FE31B)
    ASMMAP64.sys       Thu Jul 02 05:13:26 2009 (4A4C7A36)
    dump_storahci.sys  Fri Feb 17 23:37:12 2012 (4F3F2AF8)
    snp2uvc.sys        Wed May 20 04:11:05 2009 (4A13BB19)
    sncduvc.SYS        Mon Dec 29 04:14:26 2008 (495894F2)
    hiber_storahci.sys Fri Feb 17 23:37:12 2012 (4F3F2AF8)
    usbaapl64.sys      Tue Jan 10 19:56:04 2012 (4F0CDE24)
    
    http://www.carrona.org/drivers/driver.php?id=SCDEmu.SYS
    http://www.carrona.org/drivers/driver.php?id=WdFilter.sys
    http://www.carrona.org/drivers/driver.php?id=taphss.sys
    http://www.carrona.org/drivers/driver.php?id=igdkmd64.sys
    http://www.carrona.org/drivers/driver.php?id=HECIx64.sys
    http://www.carrona.org/drivers/driver.php?id=rtl8192se.sys
    http://www.carrona.org/drivers/driver.php?id=SynTP.sys
    http://www.carrona.org/drivers/driver.php?id=ATK64AMD.sys
    http://www.carrona.org/drivers/driver.php?id=HssDrv.sys
    http://www.carrona.org/drivers/driver.php?id=ASMMAP64.sys
    http://www.carrona.org/drivers/driver.php?id=snp2uvc.sys
    http://www.carrona.org/drivers/driver.php?id=sncduvc.SYS
    http://www.carrona.org/drivers/driver.php?id=usbaapl64.sys

    BSOD BUGCHECK SUMMARY
    Code:
    
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\060112-35343-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Fri Jun  1 05:17:28.633 2012 (UTC - 4:00)
    System Uptime: 3 days 22:07:42.451
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`04440000 fffffa80`04009010
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\052812-24296-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Mon May 28 07:09:08.413 2012 (UTC - 4:00)
    System Uptime: 0 days 9:07:13.650
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`04440000 fffffa80`04a21010
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\052812-28921-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Sun May 27 22:01:24.248 2012 (UTC - 4:00)
    System Uptime: 3 days 10:21:27.317
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`00440000 fffffa80`09c9f010
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\052412-32375-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Thu May 24 11:39:22.033 2012 (UTC - 4:00)
    System Uptime: 2 days 1:32:36.608
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`04440015 fffffa80`05006160
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\052212-25265-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Tue May 22 10:06:22.244 2012 (UTC - 4:00)
    System Uptime: 1 days 2:26:53.397
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`04440000 fffffa80`0a0fb010
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\052112-32781-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Mon May 21 07:37:50.639 2012 (UTC - 4:00)
    System Uptime: 7 days 4:08:29.884
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`00440012 fffffa80`09d107b0
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\051412-29875-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Mon May 14 03:27:06.538 2012 (UTC - 4:00)
    System Uptime: 4 days 16:15:06.111
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`04440000 fffffa80`04b03010
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\050912-25156-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Wed May  9 10:16:34.070 2012 (UTC - 4:00)
    System Uptime: 0 days 23:48:23.643
    *** WARNING: Unable to verify timestamp for Unknown_Module_00000000`00000000
    Probably caused by : ndis.sys ( ndis!NdisFreeMemory+15 )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_ndis!NdisFreeMemory+15
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`0444000f fffffa80`09fdbbd0
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\050412-24156-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Fri May  4 02:28:33.345 2012 (UTC - 4:00)
    System Uptime: 0 days 20:01:26.636
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`04440002 fffffa80`05d9e3c0
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\050312-27546-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Thu May  3 06:26:38.025 2012 (UTC - 4:00)
    System Uptime: 0 days 13:21:39.603
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`04440000 fffffa80`09c2b010
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
    Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\050212-36562-01.dmp]
    Built by: 8250.128.amd64fre.winmain_win8beta_se.120330-1316
    Debug session time: Wed May  2 17:02:48.553 2012 (UTC - 4:00)
    System Uptime: 6 days 12:36:31.126
    *** WARNING: Unable to verify timestamp for HssDrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
    Probably caused by : HssDrv.sys ( HssDrv+2bac )
    BUGCHECK_STR:  0xc2_7_aPmI
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac
    Bugcheck code 000000C2
    Arguments 00000000`00000007 00000000`00001183 00000000`04440008 fffffa80`0a18d5f0
    BiosVersion = U31F.207
    BiosReleaseDate = 02/23/2011
    CPUID:        "Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz"
    MaxSpeed:     2400
    CurrentSpeed: 2741
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
      
      
      My System SpecsSystem Spec

  3. #3


    Posts : 4
    windows 8 CP


    Thanks for Your respond.

    I have attached the file you asked. Can you tell me how to remove that HotSpotShield, because I cant find it under programs in control panel (I am not very good with computers).

    This Bad_Pool_Caller happens when I put my laptop to sleep as well. Computer does not wake up from sleep so I have to do power shut down and then when I turn it back on I get the blue screen, so I have to power shut down it again and then it works just fine.

    Thank You
      My System SpecsSystem Spec

  4. #4


    Posts : 5,139
    Win8.1Pro - Finally!!!


    These are the instructions from the HotSpot Shield website:
    If you decide to uninstall Hotspot Shield at any time, please, follow the usual steps: select "Control Panel" from Start menu, click "Add or Remove Programs" (Programs and Features in Win7), highlight "Hotspot Shield" entry and click "Change/Remove" button.
    More suggestions here: Uninstall Hotspot Shield Completely? - Tech Support Forum

    There are other, more risky ways to remove this - so try my suggestions and post back if they don't work. Then we'll move on to other methods if necessary.

    Another simpler option is to wipe the system clean and then install the Win8 Release Preview that was just released.
      My System SpecsSystem Spec

  5. #5


    Posts : 4
    windows 8 CP


    there is no program called HotSpotShield in there. I cant even find it using search
      My System SpecsSystem Spec

  6. #6


    Posts : 5,139
    Win8.1Pro - Finally!!!


    Follow these instructions to make a System Repair Disc: System Repair Disc - Create in Windows 8
    Test the disc to make sure you can get into System Restore when using it.
    Set a System Restore Point

    Use this free program and search for all instances of HssDrv.sys: Autoruns for Windows
    Disable them by removing the check mark in the left hand column
    Go to C:\Windows\System32\drivers (in Windows Explorer) and rename HssDrv.sys to HssDrv.BAD
    Reboot and check to make sure that HssDrv.BAD stays renamed to that.

    If you get any error messages, report them exactly as they happened.
    If the system doesn't boot to Windows, use the System Repair Disc to reset the system to the System Restore point that you made earlier.
      My System SpecsSystem Spec

  7. #7


    Posts : 4
    windows 8 CP


    Thank You... Problem is kind of solved. Hibernation works good, which was my initial purpose. Sleep is still not perfect, but I dont get a blue screen anymore, after it sleeps and I try wake the laptop up it restarts.
      My System SpecsSystem Spec

  8. #8


    Posts : 5,139
    Win8.1Pro - Finally!!!


    Search Google/Bing for instructions to remove all of the HotSpotShield stuff - it may result in a better "fix" for you.
    Good luck!
      My System SpecsSystem Spec

bad_pool_caller on win 8 64bit
Related Threads
Hi, When I updated it left me with an old windows folder can I delete this or dose this have to stay there? Thanks
Bad_Pool_Caller in BSOD Crashes and Debugging
Good Morning folks, I've a problem about the button sleep. It's not working properly. Whenever I pressed it, the screen will eventually dim and after a few minutes it will restart. Also when I used the wireless mobile broadband it will automatically (BSOD). What can I do to resolved this...
Solved Bad_pool_caller in BSOD Crashes and Debugging
Hi I'm having some trouble with the BAD_POOL_CALLER error. I'm currently running on Windows 8.1 Preview. The issue seems only to appear when opening a certain selection of images (.jpg, but not all .jpg). I have zipped my .dmp files from the minidump folder. Hope someone can take the time to...
Bad_Pool_Caller in BSOD Crashes and Debugging
I just bought my new laptop yesterday and I keep getting this error. Here are the files
bad_pool_caller in BSOD Crashes and Debugging
Hello everyone, i have the same problem as so often described... bad_pool_caller See attached file Pleas help!
bad_pool_caller in BSOD Crashes and Debugging
Hi, I've had the error listed in the title. I've uploaded the file. Can anyone tell me what happened?
BAD_POOL_CALLER goes BAD... in BSOD Crashes and Debugging
Dear forum users, Since a couple of days, I've got a windows eight pro installation. Now every time the machine comes out of standby, it crashes. The laptop i'm working with is a Lenovo Z580. I'd really like some advice from y'all, because I do not know what's happening... I've included...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook