Windows 8 and 8.1 Forums


  1. #1

    Posts : 1
    Windows 8.1


    I have a BSOD issue with the calls BAD_POOL_HEADER and BAD_POOL_CALLER. The bugcheck codes are: 0x19 ans 0xC2 respectively.

    BlueScreenViewer has pointed to dxgmms1.sys as the faulting driver. The only time I get BSODs are playing GTA V. At one point I had a BSOD for atidxx64.dll for the same issue.

    I've read tons of articles and posts about the issue and dozens of fixes including a complete reinstall of Windows.

    Here's what I've done so far:
    Reinstall/Install drivers both normal and safe mode.
    Reinstall windows
    Replaced RAM

    I've included the zip of what the DM Log Collector collected, so I thought I'd let you smart people look over it all, and see if there's something else I should do.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Pazuzu156 & welcome to the forums ^_^,

    I have analysed your dump files and below has been provided an analysis of the same for informative purposes -

    The current thread is making a bad pool request. Typically this is at a bad IRQL level or double freeing the same allocation, etc.
    Arg1: 0000000000000007, Attempt to free pool which was already freed
    Arg2: 0000000000001200, (reserved)
    Arg3: 00000000a4831080, Memory contents of the pool block
    Arg4: ffffe000a3380df0, Address of the block of pool being deallocated
    Let's see what is the type of allocation at the address highlighted in RED -
    0: kd> !pool ffffe000a3380df0
    Pool page ffffe000a3380df0 region is Unknown
     ffffe000a3380000 size:  170 previous size:    0  (Allocated)  Ntfx
     ffffe000a3380170 size:   20 previous size:  170  (Free)       Free
     ffffe000a3380190 size:  120 previous size:   20  (Allocated)  FMsl
     ffffe000a33802b0 size:  110 previous size:  120  (Allocated)  MmCa
     ffffe000a33803c0 size:  120 previous size:  110  (Allocated)  FMsl
     ffffe000a33804e0 size:  170 previous size:  120  (Allocated)  Ntfx
     ffffe000a3380650 size:  150 previous size:  170  (Allocated)  File
     ffffe000a33807a0 size:   20 previous size:  150  (Free)       Free
     ffffe000a33807c0 size:   80 previous size:   20  (Allocated)  Ntfr
     ffffe000a3380840 size:  380 previous size:   80  (Free)       FMsl
     ffffe000a3380bc0 size:  110 previous size:  380  (Allocated)  MmCa
    *ffffe000a3380cd0 size:  220 previous size:  110  (Free)      *Free
      Owning component : Unknown (update pooltag.txt)
     ffffe000a3380ef0 size:  110 previous size:  220  (Allocated)  MmCa
    So, it is an act of freeing a block which is already free.
    Let's check the stack to see if it reveals something or not -
    0: kd> knL
     # Child-SP          RetAddr           Call Site
    00 ffffd000`25efbe38 fffff803`f951dff2 nt!KeBugCheckEx
    01 ffffd000`25efbe40 fffff801`b1e7fa06 nt!ExAllocatePoolWithTag+0x1102
    02 ffffd000`25efbf30 fffff801`b1e7f66a dxgmms1!VIDMM_GLOBAL::DestroyOneAllocation+0x366
    03 ffffd000`25efc110 fffff801`b1d23984 dxgmms1!VIDMM_GLOBAL::DestroyAllocation+0x5a
    04 ffffd000`25efc140 fffff801`b1d2422f dxgkrnl!DXGDEVICE::DestroyAllocations+0x3e4
    05 ffffd000`25efc240 fffff801`b1d74622 dxgkrnl!DXGDEVICE::TerminateAllocations+0x2af
    06 ffffd000`25efc2e0 fffff801`b1d20cf3 dxgkrnl!DXGDEVICE::DestroyAllocationInternal+0x61022
    07 ffffd000`25efc340 fffff801`b1d1f8cc dxgkrnl!DxgkDestroyAllocationInternal+0x2a3
    08 ffffd000`25efc610 fffff803`f93d54b3 dxgkrnl!DxgkDestroyAllocation+0x5cc
    09 ffffd000`25efca80 00000000`7706741a nt!KiSystemServiceCopyEnd+0x13
    0a 00000000`056ce5b8 00000000`00000000 0x7706741a
    We see that the DirectX is destroying and terminating all the allocations which have been made by it.

    Below is a list of 3rd party drivers present on your system -
    **************************Tue Apr 21 01:59:54.372 2015 (UTC + 5:30)**************************
    RemoteSystemMonitorSensor.sys   Sat Jul 26 18:59:37 2008 (488B26C1)
    speedfan.sys                    Sun Dec 30 02:29:35 2012 (50DF59B7)
    RTCore64.sys                    Mon Mar 11 11:02:06 2013 (513D6C56)
    ScpVBus.sys                     Mon May  6 03:01:26 2013 (5186CFAE)
    Rt630x64.sys                    Fri May 10 15:29:08 2013 (518CC4EC)
    cthda.sys                       Tue Jul 30 06:46:56 2013 (51F71408)
    cthdb.sys                       Tue Jul 30 06:47:03 2013 (51F7140F)
    AODDriver2.sys                  Tue Feb 11 16:36:52 2014 (52FA044C)
    xusb22.sys                      Tue Mar 18 13:48:41 2014 (53280161)
    rzpmgrk.sys                     Fri Apr 18 01:06:12 2014 (53502D2C)
    rzpnk.sys                       Sat Oct 18 01:08:10 2014 (54417022)
    amdkmpfd.sys                    Tue Oct 28 04:56:38 2014 (544ED4AE)
    AMDACPKSL.SYS                   Sun Dec 21 09:08:02 2014 (5496409A)
    AtihdWB6.sys                    Sun Dec 21 09:08:19 2014 (549640AB)
    rzendpt.sys                     Tue Dec 30 15:02:47 2014 (54A2713F)
    rzudd.sys                       Tue Dec 30 15:02:50 2014 (54A27142)
    atikmpag.sys                    Wed Apr  1 01:39:30 2015 (551AFEFA)
    atikmdag.sys                    Wed Apr  1 02:01:21 2015 (551B0419)

    Kindly follow the below steps -

    1. See if using another driver version resolves this problem or not. For removing the drivers related to graphics, I would suggest you to use the Display Driver Uninstaller from this **LINK**.
    2. Please physically detach your Razer device and see if the problem resolves or not because the Razer drivers are very well known to cause problems.

    Also, is this happening only while playing GTA V or with other games as well?

    Let me know how it goes ^_^

      My System SpecsSystem Spec

Related Threads
Random BSOD Bad_Pool_Header in BSOD Crashes and Debugging
I've been getting random BSOD every few days for the last week now. Searching online tells me that it could be caused by drivers that need updating, but I don't know which driver is causing the problem. Possibly related information: A few weeks ago, I installed Comodo Firewall. I also have had...
BSOD -BAD_POOL_HEADER TCPIP.sys in BSOD Crashes and Debugging
Hey All, I've been getting BSOD for the past 2 weeks and have finally had time to sit down and look into it. I can't quite figure it out and there's been no similar issue. Attached is the dump files created from...
title says it all any help is appreciated thanks in advance :D
BSOD: Bad_pool_header in BSOD Crashes and Debugging
Hi, I have a lenovo z580 running 8.1. I've been experiencing several bsods lately. One of the is the 'bad pool header' the other being 'dpc watch dog violation' It usually happens whever I am using a second screen. I've attached the dump files. I hope you can help me resolve the problem.
Solved BSOD Bad_Pool_Header in BSOD Crashes and Debugging
I bought my ASUS Q501L with Windows 8 last June and from the start I've had problems with it. At first I had problems connecting to the internet a lot and cannot get sound through the HDMI port. Within the past couple months I've been getting BSOD for Bad_Pool_Header. This happens at least once...
Solved BSOD BAD_POOL_HEADER ntoskrnl.exe in BSOD Crashes and Debugging
Hi all, I have run WhoCrashed program to try and figure out why my computer crashed. I came up with 2 problems, Avast and MS NT Kernel & System: On Thu 2/13/2014 11:02:08 AM GMT your computer crashed crash dump file: C:\Windows\Minidump\021314-112227-01.dmp This was probably caused by the ...
Solved BSOD with BAD_POOL_HEADER in BSOD Crashes and Debugging
We are getting BSOD with BAD_POOL_HEADER error. It says, "The pool is already corrupt at the time of the current request. This may or may not be due to the caller.". Is there a kernel based utility which can force the error to occur exactly when the pool is corrupted? We have our own driver which...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook