Windows 8 and 8.1 Forums


Error: CRITICAL_STRUCTURE_CORRUPTION

  1. #1


    Posts : 21
    windows 7 64 bit

    Error: CRITICAL_STRUCTURE_CORRUPTION


    I got his BSOD since yesterday or the day before.

    I used whocrashed and bluescreen viewer analyzed the error.

    On Thu 3/26/2015 11:41:59 PM GMT your computer crashed
    crash dump file: C:\Windows\Minidump\032615-68531-01.dmp
    This was probably caused by the following module: wanarp.sys (0xFFFFF800C3019000)
    Bugcheck code: 0x109 (0xA3A01F592BCD289C, 0xB3B72BDF7E4D16EB, 0xFFFFF800C3019000, 0x19)
    Error: CRITICAL_STRUCTURE_CORRUPTION
    file path: C:\Windows\system32\drivers\wanarp.sys
    product: Microsoft? Windows? Operating System
    company: Microsoft Corporation
    description: MS Remote Access and Routing ARP Driver
    Bug check description: This indicates that the kernel has detected critical kernel code or data corruption.
    This might be a case of memory corruption. More often memory corruption happens because of software errors in buggy drivers, not because of faulty RAM modules.
    The crash took place in a standard Microsoft module. Your system configuration may be incorrect. Possibly this problem is caused by another driver on your system that cannot be identified at this time.

    sfc scan, found no error. I also checked spyware.

    The system still automatically restart with BSOD 'CRITICAL_STRUCTURE_CORRUPTION.' no error code.

    how to solve this problem ?

      My System SpecsSystem Spec

  2. #2


    Ft. Myers
    Posts : 104
    Windows 10 v.10049


    Hi newuser1,

    Can you follow the link below and post the required files?
    Blue Screen of Death (BSOD) Posting Instructions
      My System SpecsSystem Spec

  3. #3


    Posts : 21
    windows 7 64 bit


    ok. here is file generated from the tool you instructed.
      My System SpecsSystem Spec

  4. #4


    Ft. Myers
    Posts : 104
    Windows 10 v.10049


    Hello newuser1,

    Your Zip file is empty.

    Try running DM Log collector as an Administrator
      My System SpecsSystem Spec

  5. #5


    Posts : 21
    windows 7 64 bit


    Here is the new one.

    I got a new problem here that is why when run as administrator the file generated is empty.

    when I right click on anything. It says 'Failed to load resource DLL' .
      My System SpecsSystem Spec

  6. #6


    Ft. Myers
    Posts : 104
    Windows 10 v.10049


    One thing that would be helpful is to fill out your full system specs while I analyze your BSOD

    System Info - See Your System Specs - Windows 7 Help Forums
      My System SpecsSystem Spec

  7. #7


    Ft. Myers
    Posts : 104
    Windows 10 v.10049


    Ok, before I get too far into debugging, lets do some cleaning up.

    Lets start by removing Comodo, McAfee and 360 Total Security.

    You already have Revo uninstaller so open that and remove anything related to these programs.

    When running Revo, Check the Advanced option > Select all/Delete all for both scans

    Activate Windows Defender (And then run a scan)
    Windows Defender - Turn On or Off in Windows 8

    Remove the following programs (if they do not show up in Revo, Look in Control Panel > Programs and Features) :
    Avant Browser
    Comodo Ice Dragon
    JJvod
    Anything McAfee
    Spybot Search & Destroy
    The KMPlayer
    Anything that says "Toolbar"

    Reset your hosts file:
    How can I reset the Hosts file back to the default?


    Also a question, do you know of a reason for a lot of your Programs to be showing up in Chinese/Japanese character? If not, I'll have to ask someone about that, its suspicious to me.

    Download and run the following programs:
    TDSS Killer
    Kaspersky TDSSKiller: Detect / Repair TDSS Rookits - Windows 7 Help Forums

    Malwarebytes
    Malwarebytes Anti-Malware Free - Windows 7 Help Forums

    Superantispyware
    SUPERAntiSpyware - Downloads

    ADWCleaner
    AdwCleaner Download

    Ensure you are not connected to a proxy Server
    http://support.microsoft.com/en-us/kb/2289942

    Reset Internet Settings
    http://support.microsoft.com/en-us/kb/923737

    Download Autoruns: Unzip Folder and Extract autoruns.exe to the Desktop. Right-click autoruns.exe and click Run As Administrator
    Delete any and all entries that appear yellow
    https://technet.microsoft.com/en-us/.../bb963902.aspx

    Report back with the results. Post the text files as attachments from the virus scanners

    This may not fix your issue outright, but it will be a more stable system to work with.
      My System SpecsSystem Spec

Error: CRITICAL_STRUCTURE_CORRUPTION
Related Threads
CRITICAL_STRUCTURE_CORRUPTION (win32k.sys) in BSOD Crashes and Debugging
Hello, Just two weeks ago, my laptop experienced a string of BSODs which ultimately led to the "Your PC needs to be repaired" error. I tried to boot a Windows installation on USB but it failed so I sent it to the service centre to be repaired. When I got my laptop back a few days ago, I was that...
HI guys today I was playing Dishonored on my windows 8.1 x64 PC when suddenly this damn BSOD appeared giving the error CRITICAL_STRUCTURE_CORUPTION ntfs.sys . I upgraded to windows 8 two days ago and i'm really regretting it after Windows 7 when I got BSOD sometimes with the error 0x000008E. PLease...
Hi gang. I upgraded to 8.1 (.1) yesterday...updated all my drivers and everything seemed great. I was typing an email in comodo dragon browser a few minutes ago and BOOM bsod. I'm hoping it's just a one off. If any of you seasoned bsod researchers could take a look i would greatly appreciate it. ...
Hi EightForums! To add to the BSOD info, this just happened to me once and it was while watching YouTube (hence me mentioning it in the title). My laptop was borrowed for a few weeks by a relative. I dont know if she experienced BSODs while it was in her possession. I will be doing malware...
BSOD - Critical_Structure_Corruption (109) in BSOD Crashes and Debugging
Over the past few days I have been getting a blue screen on my laptop with the error message CRITICAL_STRUCTURE_CORRUPTION. It happens when I am performing any sort of task and can be as frequent as one every few minutes. It seems that the frequency of them has reduced slightly but I would...
CRITICAL_STRUCTURE_CORRUPTION CI.dll in BSOD Crashes and Debugging
Ever since upgrading to Windows 8 and subsequently 8.1 I have been getting Blue Screens non-stop and lately they have been happening more often and always because of CI.dll. Details of my system are on my profile and if you require any other info besides what has been collected by the SF...
I have got error 0x8007371 when I tried to install .netframework 3.5 which was required to install windows essentials. I ran DISM command to fix 0x80073712 error, and received another error message in the command prompt: Error 14098 Component store has been corrupted. THen I ran sfc/scannow...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook