Windows 8 and 8.1 Forums

BSOD when computer is idle

  1. #1

    Posts : 4
    Windows 8.1

    BSOD when computer is idle

    Hello, I am receiving a "attempted execute of noexecute memory" error while my laptop is idle.
    This has been happening over the last two weeks or so. I does not happen all the time however. I have ran a memory check
    and it has checked out fine. I have rolled back a few drivers to before i believe the error began and have also done a
    system restore. The drivers i have rolled back include a NVIDIA graphics driver an INTEL HD Graphics driver and a WD SES device driver. I am still receiving the error. Any help with my issue would be greatly appreciated. Thanks.

    MSI GT70
    Windows 8.1 64Bit
    i7-4800MQ 2.70GHz
    16GB RAM
    NVIDIA 780M
    INTEL HD Graphics 4600

    Updated Dump File
    Last edited by SWilson; 15 Apr 2015 at 16:10.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Swilson & Welcome to the forums ^_^,

    I have analysed your dump files and below has been provided an analysis of the same for informative purposes :-

    An attempt was made to execute non-executable memory. The guilty driver is on the stack trace (and is typically the current instruction pointer). When possible, the guilty driver's name (Unicode string) is printed on the bugcheck screen and saved in KiBugCheckDriver.

    Sadly, the dump file did not save the KiBugcheckDriver variable . Let's check the stack -
    00 ffffd000`bdf21c28 fffff802`9243b5fa nt!KeBugCheckEx
    01 ffffd000`bdf21c30 fffff802`9248c50a nt!MI_CHECK_KERNEL_NOEXECUTE_FAULT
    02 ffffd000`bdf21c70 fffff802`9240844d nt!MiRaisedIrqlFault+0x152
    03 ffffd000`bdf21cb0 fffff802`923e7c2f nt!MmAccessFault+0x1a59d
    04 ffffd000`bdf21e70 ffffe000`4c3fbb68 nt!KiPageFault+0x12f
    05 ffffd000`bdf22000 00000000`00000000 0xffffe000`4c3fbb68
    The dump file did not save the 3rd party driver as well . But, it did capture one thing -
    PROCESS_NAME:  KillerService.
    Seems like the Killer Ethernet is responsible for the crashes. Below is a list of 3rd party drivers present on your system -
    **************************Fri Mar 27 06:10:03.394 2015 (UTC + 5:30)**************************
    MBfilt64.sys               Fri Jul 31 09:10:32 2009 (4A7267B0)
    ElbyCDIO.sys               Fri Dec 17 04:28:13 2010 (4D0A9985)
    GEARAspiWDM.sys            Fri May  4 01:26:17 2012 (4FA2E2E1)
    ETD.sys                    Thu Jun 28 07:54:39 2012 (4FEBC067)
    AnyDVD.sys                 Sun Aug 26 18:26:20 2012 (503A1CF4)
    000.fcl                    Fri Nov 23 14:47:29 2012 (50AF3F29)
    HECIx64.sys                Tue Dec 18 01:02:21 2012 (50CF7345)
    btath_bus.sys              Mon Jan 21 14:48:42 2013 (50FD07F2)
    RtsPer.sys                 Fri Feb  1 12:39:27 2013 (510B6A27)
    bwcW8x64.sys               Wed Feb 13 22:55:48 2013 (511BCC9C)
    iaStorA.sys                Tue Mar 19 05:06:36 2013 (5147A504)
    e22w8x64.sys               Thu Mar 21 02:54:01 2013 (514A28F1)
    RTKVHD64.sys               Fri Mar 29 19:10:06 2013 (515599B6)
    intelppm.sys               Thu Aug 22 14:16:35 2013 (5215CFEB)
    tap0901.sys                Thu Aug 22 18:10:01 2013 (521606A1)
    akwbx64.sys                Wed Aug 28 02:09:47 2013 (521D0E93)
    mcvidrv.sys                Mon Nov 25 16:32:33 2013 (52932E49)
    mcaudrv_x64.sys            Wed Dec  4 12:42:31 2013 (529ED5DF)
    SamsungRapidDiskFltr.sys   Tue Sep 16 14:23:25 2014 (5417FA85)
    SamsungRapidFSFltr.sys     Tue Sep 16 14:23:46 2014 (5417FA9A)
    iwdbus.sys                 Sat Oct  4 06:01:12 2014 (542F3FD0)
    nvvad64v.sys               Thu Nov 20 21:03:54 2014 (546E09E2)
    NvStreamKms.sys            Mon Jan 12 23:26:42 2015 (54B40ADA)
    nvkflt.sys                 Thu Feb  5 23:20:27 2015 (54D3AD63)
    nvpciflt.sys               Thu Feb  5 23:20:32 2015 (54D3AD68)
    nvlddmkm.sys               Thu Feb  5 23:31:37 2015 (54D3B001)
    VBoxAswDrv.sys             Wed Feb 18 23:43:19 2015 (54E4D63F)
    igdkmd64.sys               Tue Mar  3 22:59:44 2015 (54F5EF88)
    aswMonFlt.sys              Fri Mar 20 17:13:56 2015 (550C07FC)
    aswRvrt.sys                Fri Mar 20 17:13:59 2015 (550C07FF)
    aswHwid.sys                Fri Mar 20 17:14:25 2015 (550C0819)
    aswSnx.sys                 Fri Mar 20 17:14:43 2015 (550C082B)
    aswRdr2.sys                Fri Mar 20 17:14:46 2015 (550C082E)
    aswVmm.sys                 Fri Mar 20 17:27:07 2015 (550C0B13)
    aswSP.sys                  Fri Mar 20 17:27:29 2015 (550C0B29)
    aswStm.sys                 Fri Mar 20 17:29:44 2015 (550C0BB0)
    **************************Thu Mar 26 08:48:34.725 2015 (UTC + 5:30)**************************
    iwdbus.sys                 Wed Jun 18 03:24:22 2014 (53A0B90E)
    igdkmd64.sys               Tue Aug  5 21:17:18 2014 (53E0FC86)
    akwbx64.sys - this driver hasn't been added to the DRT as of this run. Please search Google/Bing for the driver if additional information is needed.

    Please follow the below canned speech (Thanks usasma!) -
    I would suggest you to follow the below quote (Follow Note 2 first. If it does not work, follow note 1) -

    (Thanks Usasma!)At times the Killer Network Manager may cause BSOD problems:

    NOTE1:Link thanks to blueelvis (15Oct2014): This is a method for removing all the network software and only installing the driver. Perfect for those issues that can't be resolved any other way!

    NOTE2: See this link first: BSOD while playing on msi gt70 dragon edition 2 (thanks to kaelaan) It appears that the Killer Service problem was solved with the latest release of the Qualcomm versions of the drivers (so try updating to a version dated from later in 2014).
    The Qualcomm Atheros Killer Service/KillerNetManager is known to cause BSOD's. Please follow the workaround instructions here:

    First, open the Run dialog (Win + R keys) and type in "services.msc" (without the quotes) and press Enter
    Scroll down and locate the "Qualcomm Atheros Killer Service" and right click on it. Select "Stop"
    Right click on it again and this time select "Properties"
    In the dropdown box for "Startup type", select "Disabled", then click on the "OK" button at the bottom of the window

    Next, open Task Manager (right click on TaskBar and select "Task Manager")
    Click on the "More details" dropdown (if present)
    Click on the "Startup" tab
    Scroll down and locate the "KillerNetManager" entry, right click on it and select "Disable"
    There may also be an Install Shield (with the Killer gaming K next to it), if so Right click on it and select "Disable"
    Finally, restart the system in order for the changes to take affect.

    At times the Killer Network Manager will continue to load. If so, it's usually listed in the MSINFO32...Software Environment...Startup Programs section. If it is, please try this:

    It may be that the instructions aren't stopping everything.
    In some cases, there's a program running out of the Program Files/Program Files (x86) directory.
    "c:\program files\qualcomm atheros\killer network manager\killer~1.exe" (NOTE: killer~1.exe is most likely killernetmanager.exe)
    In other cases, there's a program running out of c:\windows\installer\{Long string of letters, numbers, and dashes}\networkmanager.exe_130c27d738f34c89bddf21bcfd74b56d.exe (the long string of letters and numbers may change)

    Here's some things to try
    1) Please see if there are any entries in the Startup tab of Task Manager that are related to Qualcomm/Atheros/Killer Network Manager (and NOT the card itself) and disable them (please let us know what you find) Be careful as the wrong selection can disable the network card.
    2) Check in "msconfig" for any entries that aren't in the Startup tab of Task Manager. Let us know if you find any Qualcomm/Atheros/Killer entries there (we'll disable them differently if they are there).
    3) Locate the "c:\program files\qualcomm atheros\killer network manager\killer~1.exe" and rename the .exe to .BAD (the killer~1 is actually a filename that starts with killer and ends with .exe) There will be an error in event viewer, but it'll stop the bugger from loading.
    4) Locate the "c:\windows\installer\{Long string of letters, numbers, and dashes}\networkmanager.exe_130c27d738f34c89bddf21bcfd74b56d.exe" entry and rename the last .exe to .BAD (the long string of letters and numbers may change)

    Just FYI - here are the MSI workaround instructions: MSI USA - Online Technical Support FAQ
    In case the above does not fix the problem, kindly remove Avast till the time we are troubleshooting the system using this **TOOL**.

    Let me know how it goes ^_^

      My System SpecsSystem Spec

  3. #3

    Posts : 4
    Windows 8.1

    Hi blueelvis,
    Thank you for looking into my problem. Greatly appreciated!
    I have followed your instructions in note 2, disabling Qualcomm Atheros Killer Service/KillerNetManager. After rebooting
    I believe i have succesfully killed off any process having to do with the Qualcomm Atheros Killer Service/KillerNetManager.

    I would like to download the latest release of Qualcomms versions of the drivers as indicated in your post but having problems
    finding them. When i click on links to the updated drivers, i always come to a missing page on Qualcomms site. Could you steer me to a place to download the latest drivers? Thank You.

    Now Testing Results............
    Will report back soon
      My System SpecsSystem Spec

  4. #4

    Posts : 4
    Windows 8.1

    Hello again blueelvis,
    Have been testing over the last 2 days and have not gotten any BSOD's.
    I have also located the newest Killer Network Manager software which i have not installed.
    The system seems to run fine without the Killer Network Manager. Do you think
    there is any reason/benefit to install the newer version, or just continue to keep it disabled?

    I am going to leave the thread unsolved for a few more days just in case but i think the issue has been resolved.
    Fingers crossed.
    Thank you for your time and help!
      My System SpecsSystem Spec

  5. #5

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Swilson ^_^,

    I am really sorry for the delayed response. I saw that this thread did not had any reply since 2 days. I did not figure that it would be your second reply. Sorry.

    I am glad that the system is more stable ^_^

    If I remember correctly, the latest versions of the Killer Network Manager have solved the problem of BSOD. But, I have seen some people getting the BSOD even on the latest update, so you can try with the latest update.

    Surely there would be certain improvements if you install the newer version in terms of latency and bandwidth priority.

    In case of any problems, please do not hesitate to post back ^_^. If you think your problem has been solved, kindly mark this thread as solved.

    Always happy to help ^_^

      My System SpecsSystem Spec

  6. #6

    Posts : 4
    Windows 8.1

    Hi blueelvis,
    Well i spoke to soon. Got another BSOD for the same thing, "attempted execute of noexecute memory".
    Just a few notes FYI.
    Killer Network Manager was still disabled when receiving the BSOD. I did not update to the new version.
    I have ran the MemTest program for 8 passes with no errors.
    Installed CyberGhost5.
    I have not uninstalled avast as of yet.
    Awaiting your further instructions. Thanks blueelvis.
    Last edited by SWilson; 15 Apr 2015 at 16:11.
      My System SpecsSystem Spec

  7. #7

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Swilson,

    I am extremely sorry for taking such a long time to respond to your post . I have been extremely busy with university. Do you still need help with this? The latest dump file has failed to identify any faulting component.

    If you are still facing problems, kindly turn on Driver Verifier according to this **GUIDE** and let it crash the system. Once the system has crashed few times, kindly re-run the diagnostic utility and attach a freshly generated ZIP file so that it could be analysed.

    Let me know how it goes ^_^

      My System SpecsSystem Spec

BSOD when computer is idle
Related Threads
Hello! Another BSOD victim here. I get a "attempted execute of no execute memory" BSOD whenever I leave the computer for a few minutes and it's idle. I have looked through various "this will fix it"-threads but I haven't been successful I'm afraid. Have attached the DM log as asked. Please...
Hello, My computer has problem of freezing lately. After i idle my computer for 2~4 hours when i try to relogin to the account my comp freeze and only restart solved the problem. Thank you.
Good Evening! I've been having several different BSOD's. I've read many different threads that only contain parts of my problem the BSODs have many different names including: SYSTEM_THREAD-EXCEPTION_NOT_HANDLED MEMORY_MANAGEMENT SYSTEM_SERVICE_EXCEPTION CRITICAL_SERVICE_FAILED...
Solved BSOD when computer is idle in BSOD Crashes and Debugging
52656 I have been getting these blue screens at random times when the computer is idle. This is a brand new machine. The tech that built it has already replaced the memory modules hoping to solve the problem, but it didn't do the trick. I have never had it throw the blue screen while I was...
Computer rebooted randomly today with no BSOD. Found this in the event log. I've ran a sfc /scannow with no errors reported and also re-imaged my machine using the DISM tool. Here is a link to my MEMORY.DMP file it's 1.1GB! Is that normal? ...
BSOD occuring when windows defender quick scan is running and when computer is left idle for a couple of minutes. Gives a "Attempted execute of no execute memory (ndis.sys)" Bluescreen. I tried using the SF Diagnostic tool but it gives me the error where it cant find the path. I have tried...
Hey guys, So I've been getting random BSOD's almost daily whenever the computer is idle. I've used the debugger tool and looked at the dump files and it says pci.sys is the problem so I updated my laptops drivers and it's still having issues. I've attached the required file below, thanks...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook