Windows 8 and 8.1 Forums

BSOD after dropping laptop; Safe mode OK

  1. #1

    Posts : 8
    Windows 8, Windows 7

    BSOD after dropping laptop; driver power state failure

    Hi all,

    Thanks in advance for your time and efforts helping me solve this issue. My laptop is an HP Envy 14-k016tx running Windows 8.1; the BSOD error given (with the :( face) was DRIVER_POWER_STATE_FAILURE. I had tried a few fixes through CMD [sfc scannow, etc.] that I found online but to no avail. I used "WhoCrashed" and it points to "0xFFFFE00147FBE060" (unknown), "nt+0x1509A0" (ntoskrnl.exe), and also iastora.sys (intel rapid storage technology). I had IRQL not less or equal BSOD around a year ago and used the warranty to reinstall windows (apparently I cannot do that on my own because customers are not given the Windows Disc and I had to take a long trip around the city for that. Now I have moved to the US). HP phone support would not assist me because I purchased the device outside of the US.

    Original problem:
    Boot into HP logo, then some brightness changes into a black screen. Mouse cursor shows up and can be controlled. After a while it goes into the BSOD and auto-reboots, probably into a loop (I used the physical button to switch it off).

    Basic system diagnostics come back normal (HP bundled software, tapping F2 key on startup). I accidentally got into safe mode by changing BIOS settings (secure boot) which somehow got me into the blue recovery environment and therefore Safe Boot. After a few repeats I used CMD to add the boot options menu to save me the trouble of doing this every time I want to boot into safe mode.

    If I use F11 on startup to go into default recovery options without using the weird BIOS secure boot change method, It gives me an error code 0xc0000225, and "A required device isn't connected or can't be accessed." Continuing to F8 (startup settings) or Enter (try again) will just cause the screen to flash in strange distorted black bars. Escape key leads to BIOS options.

    I tried to use the Windows debugging tools, but I have trouble installing it because of errors with Windows Installer. I also suspected the HP 3D driveguard (protecting hard drive in case of dropping laptop/accelerometer changes) caused this but I could not uninstall it. I tried updating some of the drivers I suspected to be the problem but the BSOD remains.

    I also attempted to follow some online fixes for MS installer errors (for uninstalling drive guard & installing the debug tool) but with no positive results. I disabled the RAID acceleration with SSD.

    Device manager in safe mode shows a yellow warning triangle for "Monitors" (Generic PnP Monitor) and I can't find any drivers for it. I used the official HP site: HP ENVY 14-k016tx Sleekbook Drivers & Downloads | HP® Support

    Also perhaps it is a hardware error? My RAM in system properties shows only 7.78GB usable instead of 8.00GB. Not sure if this has any relevance, maybe it was already like this before the BSOD.

    Current problem:
    I can actually boot, with some delay, into the lock screen, but after keying in my password the "Welcome" and loading spinning circle just spins for a while and then stops, eventually going back to BSOD :( screen so not much progress made here.

    I have attached the zip file as per instructed. Thanks again in anticipation for your analyses and help!
    Last edited by SALaunch; 26 Mar 2015 at 06:29.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi SALaunch & welcome to the forums ^_^,

    I have analysed your dump files and below has been provided an analysis of the same for informative purposes -

    A driver has failed to complete a power IRP within a specific time.
    1: kd> !irp ffffe0005b9eaca0
    Irp is active with 6 stacks 5 is current (= 0xffffe0005b9eae90)
     No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  Pending has been returned
         cmd  flg cl Device   File     Completion-Context
     [  0, 0]   0  2 00000000 00000000 00000000-00000000    
       Args: 00000000 00000000 00000000 ffffffffc000000e
     [  0, 0]   0  0 00000000 00000000 00000000-00000000    
       Args: 00000000 00000000 00000000 00000000
     [  0, 0]   0  0 00000000 00000000 00000000-00000000    
       Args: 00000000 00000000 00000000 00000000
     [ 16, 0]   0  2 ffffe0004f9665c0 00000000 fffff8010b4d737c-ffffd000af1cd8f0    
            \Driver\pci dxgkrnl!DpiFdoPowerCompletionRoutine
       Args: 00000000 00000000 00000000 00000000
    >[ 16, 2]   0 e1 ffffe0005739b1f0 00000000 fffff80213f26efc-ffffe0005bbaef08 Success Error Cancel pending
           Unable to load image \SystemRoot\system32\DRIVERS\nvlddmkm.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for nvlddmkm.sys
    *** ERROR: Module load completed but symbols could not be loaded for nvlddmkm.sys
     \Driver\nvlddmkm nt!PopRequestCompletion
       Args: 00000000 00000001 00000001 00000000
     [  0, 0]   0  0 00000000 00000000 00000000-ffffe0005bbaef08    
       Args: 00000000 00000000 00000000 00000000
    I checked all of your dump files and each dump pointed to the NVIDIA driver and not the Intel Rapid Storage driver

    The driver you are using has got a timestamp which is 5 days older than the driver hosted on HP Support. I know that this is very, very insignificant but I would surely give it a try.

    Since, you are facing problems in logging in to the system, I would suggest you to try and boot into "Safe Mode". Download the display driver uninstaller from this **LINK** and then uninstall the currently installed NVIDIA driver. Once you have removed the driver, reboot the system and see if you are able to login normally into the system.

    If you are not able to login, use safe mode. If you are able to login normally, install the driver from there. Here is the NVIDIA Driver from HP Support - **LINK**.

    If you are still facing the problem, then uninstall the driver and try installing the latest driver from NVIDIA's website below -
    Drivers - Download NVIDIA Drivers

    Regarding the less amount of RAM available, some of the hardware resources are reserved for future and internal uses. For example, even if you buy a 1TB Hard Disk, you would get only around 930GB which is usable. Similarly, some amount of RAM is reserved for internal usage and hence is not available for general purpose.

    I hope this clears the confusion

    Let me know how it goes ^_^

      My System SpecsSystem Spec

  3. #3

    Posts : 8
    Windows 8, Windows 7

    Hi Pranav,

    Thanks for the reply! Sorry for not writing back sooner.

    I tried installing and uninstalling a few drivers using the internet and 3DP Chip and the laptop suddenly could function. However, it asks me to "Activate Windows" as if my copy wasn't genuine but at least I can dismiss the annoying full screen notification. There's also "Windows 8.1 Build 9600" on the bottom right corner of my desktop wallpaper. Sorry for this complication. How might I be able to give you information about this?

    Your first link to the uninstaller leads only to the forum homepage; should I still go through with installing the provided driver?

    Apologies for the mess and of course, your help is much appreciated! Thank you again!

    PS regarding the amount of RAM, I am absolutely certain that it showed 8.00GB before. My max processor speed decreased too; not sure what happened there, but this isn't as important.
      My System SpecsSystem Spec

  4. #4

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi SaLaunch ^_^,

    Don't worry about not writing sooner. I know everyone is busy

    Regarding the Windows activation, have you tried activating the Windows while your system is connected to the Internet? It is strange because I was not able to find any symptoms of a counterfeit copy.

    If you are not experiencing any issues, I don't think that it would be necessary to follow the steps which I have asked in my previous post.

    Have you tried performing a RESET of the BIOS settings?

    Let me know how it goes ^_^

      My System SpecsSystem Spec

BSOD after dropping laptop; Safe mode OK
Related Threads
Hi guys, I'm hoping you guys can help me with a BSOD issue I've been facing. I've been experiencing frequent BSODs since last night. It started after my screen went black while I was away from the PC. PC was unresponsive so I restarted it and there would be a BSOD every time Windows would...
Dear all, I am having a recurring SYSTEM_SERVICE_EXCEPTION on boot in Windows 8.1. I have a Lenovo y50 (the one with the SSD). I can boot into safemode. The only way I can get my computer running is through System Restoring. This problem does not happen on every reboot. It also doesn't happen...
every time I shut down the computer there is a page fault in non paged area error, and then the computer restarts love to know why. any help would be great thanks :D
Hello everyone, I have a friend who has tasked me with removing the dreaded "Interpol" scareware virus from his Windows 8 laptop. Sadly, this means he can't boot into Windows 8, as the virus just locks him out. How can I boot into Safe Mode, so I can run the "Power Eraser" tool from Norton...
Hi everyone I am facing a strange issue. My screen seems to have a grey filter overlaying it. See attached. When i booted it in safe mode, the screen is showing the right vibrant colors. When i booted it back to normal mode, the screen is greyish but strangely the mouse is showing the...
I've had this computer less than a week. It tried to do an update and keeps getting stuck at 12%. Researching online, I've found ways to put it into safe mode but none work. Please help.
Safe Mode in WDP in General Support
For those wondering about safe mode in WDP, there are 2 ways to get into it. 1) For safe mode on next boot (or till you turn it off manually), use the regular msconfig way. In msconfig, click boot tab, check "safe boot" and radio button "minimal". Hit OK. You can restart straight away or later,...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook