Windows 8 and 8.1 Forums

Windows 8 Freezes with Disk at 100%, etc

  1. #1

    Posts : 6
    Windows 8 Consumer Preview

    Windows 8 Freezes with Disk at 100%, etc

    I am suspecting hardware... except that I was seeing similar behavior back before I replaced the Motherboard, some of the memory, etc. Am now thinking I must be doing something particularly bad, or that my external drive is causing weirdness even though I've tried it on both USB2 and FW connections. Event Log just shows some issues with files taking "abnormally long" to write the internal.

    In any case, I've performed an MSInfo and attached. Any suggestions greatly appreciated!

      My System SpecsSystem Spec

  2. #2

    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Install the proprietary AHCI storage driver from the manufacturer:

    Name    Standard SATA AHCI Controller
    Manufacturer    Standard SATA AHCI Controller
    Status    OK
    PNP Device ID    PCI\VEN_1B4B&DEV_9123&SUBSYS_91231B4B&REV_11\4&1E836D5&0&0010
    I/O Port    0x0000DF00-0x0000DF07
    I/O Port    0x0000DE00-0x0000DE03
    I/O Port    0x0000DD00-0x0000DD07
    I/O Port    0x0000DC00-0x0000DC03
    I/O Port    0x0000DB00-0x0000DB0F
    Memory Address    0xF3DFF000-0xF3DFF7FF
    IRQ Channel    IRQ 16
    Driver    c:\windows\system32\drivers\storahci.sys (6.2.8250.0, 70.30 KB (71,992 bytes), 2/17/2012 10:37 PM)
    I'd help you out more about it but it must be some super rare type because even the vendor id website will not list anything for 1B4B.

    I think it's Marvell though. If their website doesn't have the storage driver, then get it from the motherboard manufacturer's site.
      My System SpecsSystem Spec

  3. #3

    Posts : 6
    Windows 8 Consumer Preview

    OK, turns out it was a kind of Marvell, but even the EVGA website doesn't address which one. I did DL the one version I could actually use (they have a number of versions designed to install from floppy, but it won't unpack even onto a small USB stick with the A drive assigned), and so far things don't seem to be all that different. Then again, I also haven't had any freezes, so we'll see how the next couple of days go.

    Thanks for the suggestion!
      My System SpecsSystem Spec

  4. #4

    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86

    Quote Originally Posted by NaweG View Post
    and so far things don't seem to be all that different. Then again, I also haven't had any freezes
    That's a little confusing to me. Did you check your Device Manager to make sure it shows Marvell now?

    You're welcome.

    Tell me which motherboard you have if you still need help. Check with CPU-Z if you don't know, since the msinfo32 does not say.
      My System SpecsSystem Spec

  5. #5

    Posts : 6
    Windows 8 Consumer Preview

    Yes, it now says Marvell, but I have to say the EVGA site didn't make finding a version you can actually install easy. And the Marvell site is even less helpful (if you can believe it).

    Motherboard is the EVGA X58 131-GT-E767. CPU is an Intel Core i7-920. At this point things have been stable about as long as they ever have been, so I'm optomistic that installing the Intel Driver Collection (which I presume updated the North/South bridge chips and other related items) and the version of the Marvell controller have addressed any remaining issues from the system I rebuilt this one from.

    Thanks again!
      My System SpecsSystem Spec

  6. #6

    Posts : 6
    Windows 8 Consumer Preview

    Well, I guess I should have known better. The last couple of days the problem has reasserted itself. Several messages of the type:

    svchost (1444) SRUJet: A request to write to the file "C:\Windows\system32\SRU\SRUDB.dat" at offset 0 (0x0000000000000000) for 4096 (0x00001000) bytes succeeded, but took an abnormally long time (26 seconds) to be serviced by the OS. In addition, 4 other I/O requests to this file have also taken an abnormally long time to be serviced since the last message regarding this problem was posted 105 seconds ago. This problem is likely due to faulty hardware. Please contact your hardware vendor for further assistance diagnosing the problem.

    What's interesting is that it seems to almost always be this file. So I am a little suspicious of the connection. Still, I assume it's about time I try replacing the Hard Drive and seeing if that "fixes" it. Would you agree?
      My System SpecsSystem Spec

  7. #7

    Posts : 5,139
    Win8.1Pro - Finally!!!

    GMan is no longer with us. I'd suggest that you try a fresh install of Win8. Since the Release Preview is due out shortly, I'd go with that one.
      My System SpecsSystem Spec

  8. #8

    Posts : 1
    Win 8 Pro

    I had the same symptoms on my son's month old laptop and suspected a hardware or hard drive error. I just ran a chkdsk /r and it found an error on srudb.dat file, and I had jetSRU errors too. After the chkdsk /r said it replaced bad clusters in the srudb.dat file I rebooted and everything is fine and back to normal, like brand new. I see ESENT events that say windows.edb recovery was complete and the Search service successfully started. I'm not sure, but I suspect if you rename or delete the srudb.dat file, Windows will recreate it and your problems might be gone. Worth a shot. I can't believe how much time I wasted suspecting hardware and running diags to no avail. I was sure the hard drive was crapping out, and though I'd have to start from scratch with the brand new laptop (which I bought because I was sick of repairing the old laptop).

    I'm not sure what caused this issue, but I think it is a metro app and/or associated driver. Since it's my son's computer I'm not sure what he had installed recently, but thankfully my nightmare is over now.
      My System SpecsSystem Spec

Windows 8 Freezes with Disk at 100%, etc
Related Threads
Hello I have a HDD 750G with 2 partitions NTFS with data. used externally in a USB3 box connected to my windows 8.1 asus laptop. No idea what I do, I always use 'eject' before disconnecting this HDD, but now I see that with diskpart : DISKPART> list disk
My laptop (Lenovo Y500 Laptop | Lenovo US) has a 1TB 5400rpm hard drive C: and it also has a 24GB chached SSD D:. The link only shows a 16, but mine was 24. Today, I left my computer idle while I was at class (I'm in college) and when I came back it was frozen on the start up screen Lenovo Logo. As...
Hello, thanks for reading and any help you may be able to offer. I have a Western Digital external hard drive. Model WD5000C032 500GB. It's an older device that was working just fine on my Mac (I don't know what OS it was running and do not have access to it any longer). I have brought this HD...
Ever since i got my pc it has had this issue. I thought updates would fix it because the last pc i bought had the same problem. When it freezes i can move the mouse but everything else is unresponsive for a while. It often freezes after the pc has started up or when im browsing, often at random...
Unable to start Disk Management. I tried the following without success: - Check file integrity - Repair with DISM - Start the Virtual Disk Service and Volume SHadoy Copy manually and set them to Automatic and Manual (it starts, but Disk Management cannot connect to it) - Disable Firewall and...
Hi Question before I proceed please : Have 2 hard drives (SSDs). Drive 1 : OS Win 8.1 for general web, office and junk running Drive 2 : OS Win 8.1 for tweaked hobby work; Audio recording etc Whilst I wish to not physically disconnect the drives on each boot. I would like to have the...
Is it still possible to bring a disk offline using Disk Management (diskmgmt.msc) in Windows 8 the same way it was possible in Windows 7 or is using Diskpart.exe the only way?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook