Windows 8 and 8.1 Forums


  1. #1

    Posts : 4
    Windows 8.1



    Just two weeks ago, my laptop experienced a string of BSODs which ultimately led to the "Your PC needs to be repaired" error. I tried to boot a Windows installation on USB but it failed so I sent it to the service centre to be repaired. When I got my laptop back a few days ago, I was that it was an OS failure and they had helped to format my laptop again to Windows 8.1.

    It was running fine for a day and I had downloaded and installed Windows Updates but on the next day, I experienced another string of BSODs again. Some of the BSOD errors I remembered getting are: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (fltmgr.sys), CRITICAL_STRUCTURE_CORRUPTION (win32k.sys) and DRIVER_IRQL_NOT_LESS_OR_EQUAL (Smb_driver_Intel.sys).

    Then after a few more BSODs, it led to the "Your PC needs to be repaired" error again. However, this time I managed to load the installation media from the USB and got to the troubleshoot page. I initially tried to the recovery option but it failed, the refresh PC option also failed. Then I used the reset option which worked. So the laptop was back to Windows 8. Next, I used Windows Update to install those updates and then upgraded to 8.1 and then I used Windows Update again.

    So my laptop was running fine for a few hours and then I experienced another BSOD again (CRITICAL_STRUCTURE_CORRUPTION (win32k.sys)). Any help on how to solve this?

    Here's my dump file from the latest crash: Microsoft services[1]
    Attachment 59206
    System Specs:
    Machine name: VAIO
    Operating System: Windows 8.1 64-bit (6.3, Build 9600) (9600.winblue_r8.150127-1500)
    Language: English (Regional Setting: English)
    System Manufacturer: Sony Corporation
    System Model: SVS13133CGP
    BIOS: R1021C8
    Processor: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz (4 CPUs), ~2.6GHz
    Memory: 8192MB RAM
    Available OS Memory: 8072MB RAM

      My System SpecsSystem Spec

  2. #2

    1: kd> .bugcheck
    Bugcheck code 00000109
    Arguments a3a01f5a`3aa374fa b3b72be0`8d238679 fffff960`00143328 00000000`0000000c
    1: kd> ln fffff96000143328
    (fffff960`00143328)   win32k!PUBLIC_PFTOBJ::bLoadFonts   |  (fffff960`00221380)   win32k!xxxDwmProcessStartup
    1: kd> u win32k!PUBLIC_PFTOBJ::bLoadFonts
    fffff960`00143328 488bc4          mov     rax,rsp
    fffff960`0014332b 48895820        mov     qword ptr [rax+20h],rbx
    fffff960`0014332f 44894018        mov     dword ptr [rax+18h],r8d
    fffff960`00143333 48895010        mov     qword ptr [rax+10h],rdx
    fffff960`00143337 48894808        mov     qword ptr [rax+8],rcx
    fffff960`0014333b 55              push    rbp
    fffff960`0014333c 56              push    rsi
    fffff960`0014333d 57              push    rdi
    One bit corruption, most likely bad RAM.
    Memtest86 is your best bet, run for a minimum of eight passes.
    If your laptop is under warranty, then I recommend you RMA it and ask for RAM replacement.
      My System SpecsSystem Spec

  3. #3

    Posts : 4
    Windows 8.1

    I am unable to run Memtest86+. I've followed the instructions here: Guide to using Memtest86+ - How-To Guides and Tutorials

    The steps I've taken:
    - Downloaded "Pre-Compiled Bootable ISO (.zip)"
    - Extracted .iso file to desktop
    - Inserted blank CD and burned the .iso file into the CD using ImgBurn
    - Shut down computer and entered BIOS
    - Set Internal Optical Disk Drive to be first priority
    - Saved changes and restarted. I was brought to the regular login page
    - Logged in, shut down and then turn on again. Still regular login page

    I've attached an image of my current BIOS settings. Is there anything that I did wrong?
      My System SpecsSystem Spec

  4. #4

    Put external device as the 1st boot priority.
      My System SpecsSystem Spec

  5. #5

    Posts : 4
    Windows 8.1

    That didn't work either but when I changed boot mode from uefi to legacy it managed to run. So right now I'll have to wait for the results before doing anything else. Thanks for the quick reply!
      My System SpecsSystem Spec

  6. #6

    Posts : 4
    Windows 8.1

    Update: After running the memtest for a few hours (it was on pass #4), it showed that there were 30000+ errors on pass #2 so I stopped the memtest. This means that either one of my RAM module is faulty right? If so, should look for Sony to replace it or should I look for RAM manufacturer?
      My System SpecsSystem Spec

  7. #7

    Yes, a RAM module is failing.
    If you laptop is under warranty RMA it, if not you can buy laptop RAM online.
      My System SpecsSystem Spec

Related Threads
KERNEL_DATA_INPAGE_ERROR Win32k.SYS in BSOD Crashes and Debugging
OS : WIN 8.1 Problem : my windows 8.1 last 2 days show up with the blue screen KERNEL_DATA_INPAGE_ERROR Win32k.SYS Test done : Memory check : passed SMART check : passed Long DST : failed Failure id : qLHU83 - 6J9788 - MFPXOK - 61CU03
HI guys today I was playing Dishonored on my windows 8.1 x64 PC when suddenly this damn BSOD appeared giving the error CRITICAL_STRUCTURE_CORUPTION ntfs.sys . I upgraded to windows 8 two days ago and i'm really regretting it after Windows 7 when I got BSOD sometimes with the error 0x000008E. PLease...
Hi gang. I upgraded to 8.1 (.1) yesterday...updated all my drivers and everything seemed great. I was typing an email in comodo dragon browser a few minutes ago and BOOM bsod. I'm hoping it's just a one off. If any of you seasoned bsod researchers could take a look i would greatly appreciate it. ...
Hi EightForums! To add to the BSOD info, this just happened to me once and it was while watching YouTube (hence me mentioning it in the title). My laptop was borrowed for a few weeks by a relative. I dont know if she experienced BSODs while it was in her possession. I will be doing malware...
BSOD - Critical_Structure_Corruption (109) in BSOD Crashes and Debugging
Over the past few days I have been getting a blue screen on my laptop with the error message CRITICAL_STRUCTURE_CORRUPTION. It happens when I am performing any sort of task and can be as frequent as one every few minutes. It seems that the frequency of them has reduced slightly but I would...
Ever since upgrading to Windows 8 and subsequently 8.1 I have been getting Blue Screens non-stop and lately they have been happening more often and always because of CI.dll. Details of my system are on my profile and if you require any other info besides what has been collected by the SF...
Solved PAGE_FAULT_IN_NONPAGED_AREA (Win32k.sys) in BSOD Crashes and Debugging
Hi okay so i was just running a virtual machine on vmware and running some few other apps including spotify, skype. Then suddenly a bsod came up on my screen (The error was: PAGE_FAULT_IN_NONPAGED_AREA (Win32k.sys)). So i restarted. This boot took longer than usual though and the metro start...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook