Windows 8 and 8.1 Forums

Random BSOD 0xc000021a brand new laptop

  1. #1

    Posts : 7
    Windows 8.1

    Random BSOD 0xc000021a brand new laptop

    Hi EightForums.
    Just before Christmas I bought a brand new laptop, decided to get a nice new SSD to speed it up a bit, used the Asus tool Backtracker to switch the OS across to the new SSD. Now following that my laptop crashes either just after startup (with the BSOD 0xc000021a) or after a couple of hours of normal use. It seems to be happening every couple of times I turn my laptop on as well (for example after when it crashes, the next time it is on it definitely does not crash)(seems to be every couple of times I turn it on).
    Really struggling to figure out what is causing it.
    Also have noticed that my laptop screen is not turning off (even after half an hour of not touching it) but that could be totally unrelated.
    Thanks for any help!

      My System SpecsSystem Spec

  2. #2

    1: kd> .bugcheck
    Bugcheck code C000021A
    Arguments ffffc000`46915d00 00000000`00000000 00000000`00000000 00000000`00000000
    1: kd> kn
     # Child-SP          RetAddr           Call Site
    00 ffffd000`291866b8 fffff801`25da3991 nt!KeBugCheckEx
    01 ffffd000`291866c0 fffff801`25d9d4ea nt!PopGracefulShutdown+0x2c9
    02 ffffd000`29186700 fffff801`25b741b3 nt!NtSetSystemPowerState+0x269a
    03 ffffd000`29186840 fffff801`25b6c600 nt!KiSystemServiceCopyEnd+0x13
    04 ffffd000`291869d8 fffff801`25fb91b3 nt!KiServiceLinkage
    05 ffffd000`291869e0 fffff801`25eeca27 nt!PopIssueActionRequest+0x73f43
    06 ffffd000`29186aa0 fffff801`25ac5b8e nt!PopPolicyWorkerAction+0x63
    07 ffffd000`29186b10 fffff801`25ac33ac nt!PopPolicyWorkerThread+0xba
    08 ffffd000`29186b50 fffff801`25af0280 nt!ExpWorkerThread+0x28c
    09 ffffd000`29186c00 fffff801`25b6efc6 nt!PspSystemThreadStartup+0x58
    0a ffffd000`29186c60 00000000`00000000 nt!KiStartSystemThread+0x16
    1: kd> dc ffffc00046915d00
    ffffc000`46915d00  646e6957 2073776f 7473756d 776f6e20  Windows must now
    ffffc000`46915d10  73657220 74726174 63656220 65737561   restart because
    ffffc000`46915d20  65687420 4f434420 6553204d 72657672   the DCOM Server
    ffffc000`46915d30  6f725020 73736563 75614c20 6568636e   Process Launche
    ffffc000`46915d40  65732072 63697672 65742065 6e696d72  r service termin
    ffffc000`46915d50  64657461 656e7520 63657078 6c646574  ated unexpectedl
    ffffc000`46915d60  00000079 05000000 00000012 0000000c  y...............
    ffffc000`46915d70  03030108 624e4d43 c4fc5257 b5c0c704  ....CMNbWR......
    Can we have a Complete memory dump for the next time you crash, these minidumps contain no useful information.
    Go the Start
    Right click My Computer
    Select Properties
    Click Advanced system settings
    Click on the Advanced tab
    Select Settings under Startup and Recovery
    Then under Write debugging information select Complete memory dump.

    Once a dump is created go to:
    Copy the file to the desktop, zip it up and upload it to a file sharing site like Onedrive. After the upload is done post the download link in your next reply.
      My System SpecsSystem Spec

  3. #3

    Posts : 7
    Windows 8.1

    Ok to do that I had to set paging file to be managed automatically by system for all drives.
    Will wait till laptop crashes again, then will upload the new memory.dmp if it is possible (the internet is really slow here).
    Thanks for the quick reply! =)
      My System SpecsSystem Spec

  4. #4

    Posts : 7
    Windows 8.1

    Ok I managed to upload it today =)
      My System SpecsSystem Spec

  5. #5

    Posts : 7
    Windows 8.1

    A bit more information: i get an error message "exception EOIeSysError in module networx.exe at .................." just before my laptop crashes.

    Looking in the Windows Event Viewer Administritive Events, the first error when turning on my laptop is
    "A TDI filter (\Driver\networx) was detected. This filter has not been certified by Microsoft and may cause system instability."

    Could Networx be the problem?
      My System SpecsSystem Spec

  6. #6

    Netowrx.exe is a bandwidth monitoring program, it's not requried. I suggest you remove it.

    //The thread that bugchecked the system
    ffffd000`2431e6b8 fffff801`b3616991 : 00000000`0000004c 00000000`c000021a ffffd000`5a9b43f8 ffffe000`473e26d0 : nt!KeBugCheckEx
    ffffd000`2431e6c0 fffff801`b36104ea : ffffe000`46985600 ffffd000`2431e7d9 00000000`00000000 00000000`00000002 : nt!PopGracefulShutdown+0x2c9
    ffffd000`2431e700 fffff801`b33e71b3 : ffffe000`46985340 00000000`00000000 00000000`c0000004 00000000`00000000 : nt!NtSetSystemPowerState+0x269a
    ffffd000`2431e840 fffff801`b33df600 : fffff801`b382c1b3 00000000`00000001 ffffd000`2431ea58 00000000`c0000004 : nt!KiSystemServiceCopyEnd+0x13 (TrapFrame @ ffffd000`2431e840)
    ffffd000`2431e9d8 fffff801`b382c1b3 : 00000000`00000001 ffffd000`2431ea58 00000000`c0000004 ffffd000`5f5d2180 : nt!KiServiceLinkage
    ffffd000`2431e9e0 fffff801`b375fa27 : 00000000`00000000 00000000`00000000 ffffd000`5f5d2180 ffffe000`46985480 : nt!PopIssueActionRequest+0x73f43
    ffffd000`2431eaa0 fffff801`b3338b8e : fffff801`b3338ad4 00000000`00000000 00000000`00000002 fffff801`b353d300 : nt!PopPolicyWorkerAction+0x63
    ffffd000`2431eb10 fffff801`b33363ac : fffff801`00000002 fffff801`b354ad40 ffffe000`46985340 fffff801`b353d300 : nt!PopPolicyWorkerThread+0xba
    ffffd000`2431eb50 fffff801`b3363280 : ffffe000`458cf920 ffffe000`46985340 00000000`00000080 ffffe000`46985340 : nt!ExpWorkerThread+0x28c
    ffffd000`2431ec00 fffff801`b33e1fc6 : ffffd000`5f4f9180 ffffe000`46985340 ffffd000`5f5053c0 ffffc000`ef1e2a50 : nt!PspSystemThreadStartup+0x58
    ffffd000`2431ec60 00000000`00000000 : ffffd000`2431f000 ffffd000`24319000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16
    //Here's the thread that actually caused the crash
    ffffd000`5a9b3d80 fffff801`b33254fe : ffffd000`5ac88180 ffffe000`461f8080 ffffe000`fffffffe ffffd000`fffffffe : nt!KiSwapContext+0x76 //Swap the thread context
    ffffd000`5a9b3ec0 fffff801`b3324f79 : ffffe000`461f8080 fffff801`b330ca78 00000000`00000000 00000000`00000000 : nt!KiSwapThread+0x14e //Change thread execution
    ffffd000`5a9b3f60 fffff801`b32f7340 : 00000000`00000000 00000000`00000000 ffffd000`000000aa 00000000`00000004 : nt!KiCommitThreadWait+0x129 //Place thread in a wait state
    ffffd000`5a9b3fe0 fffff801`b375f188 : ffffe000`453c8a90 ffffd000`00000005 00000000`00000000 fffff801`00000002 : nt!KeWaitForSingleObject+0x2c0 //Wait for conditions
    ffffd000`5a9b4070 fffff801`b33e71b3 : ffffe000`461f8080 ffffd000`5a9b43f8 00000000`00000000 fffff801`b33e5d57 : nt!NtInitiatePowerAction+0x170 //Initiate the power action policy
    ffffd000`5a9b4100 fffff801`b33df600 : fffff801`b389c0b8 00000000`00000100 00000000`00000801 00000000`00000001 : nt!KiSystemServiceCopyEnd+0x13 (TrapFrame @ ffffd000`5a9b4100) //Kernel mdoe transition
    ffffd000`5a9b4298 fffff801`b389c0b8 : 00000000`00000100 00000000`00000801 00000000`00000001 ffffd000`5a9b43d8 : nt!KiServiceLinkage //User mode transition
    ffffd000`5a9b42a0 fffff801`b3619376 : ffffe000`446a5490 ffffe000`473e26d0 ffffe000`476d8900 00000000`00000100 : nt!PoShutdownBugCheck+0xd4 //Initiate bugcheck
    ffffd000`5a9b4340 fffff801`b33e3c32 : 00000000`00000000 00000000`00000354 00000001`00000001 00000000`00000013 : nt!ExpSystemErrorHandler2+0x64e
    ffffd000`5a9b4590 fffff801`b38d8c30 : 00000000`c000021a 00000000`00000001 00000000`00000001 ffffd000`5a9b49c8 : nt!ExpSystemErrorHandler+0xd2 //Error handler
    ffffd000`5a9b45d0 fffff801`b38d902d : 00000000`00000300 fffff801`b363b715 ffffd9f0`e775cb18 ffffd000`00000800 : nt!ExpRaiseHardError+0x12c
    ffffd000`5a9b4950 fffff801`b33e71b3 : fffff6fb`7dbed7f8 fffff6fb`7daffed8 fffff6fb`5ffdb4f8 fffff6bf`fb69f428 : nt!NtRaiseHardError+0x1b9
    ffffd000`5a9b4a90 00007ffa`2c2d225a : 00007ff6`d3e7143e 0000009a`aba997c0 00007ff6`d3e843a8 0000009a`ab70f5c0 : nt!KiSystemServiceCopyEnd+0x13 (TrapFrame @ ffffd000`5a9b4b00)
    0000009a`ab70f558 00007ff6`d3e7143e : 0000009a`aba997c0 00007ff6`d3e843a8 0000009a`ab70f5c0 0000009a`aba997c0 : ntdll!NtRaiseHardError+0xa //Hard error, looks like a disk fault
    0000009a`ab70f560 00007ffa`2c259b9b : 00007ff6`d3e3b930 00007ff6`d3e3b930 0000009a`ab1e5000 0000009a`ab1be800 : services!CRebootContext::Perform+0x1be //Undocumented function. Possibly switch switch the context?
    0000009a`ab70f9e0 00007ffa`2c25daca : 00007ffa`2c259b00 0000009a`ab1e5000 0000009a`ab70fbf8 0000009a`00000102 : ntdll!RtlpTpWaitCallback+0x9b //Wait for the callback routine
    0000009a`ab70fa40 00007ffa`2c274a5d : 0000009a`abacce80 0000009a`ab1dd1d0 00000000`00000000 0000009a`ab1b3868 : ntdll!TppExecuteWaitCallback+0x92
    0000009a`ab70fa80 00007ffa`2bed13d2 : 00000000`00000000 00007ffa`2c2745e0 0000009a`ab1b7cc0 00000000`00000000 : ntdll!TppWorkerThread+0x47d
    0000009a`ab70fe60 00007ffa`2c2aeb64 : 00007ffa`2bed13b0 00000000`00000000 00000000`00000000 00000000`00000000 : KERNEL32!BaseThreadInitThunk+0x22
    0000009a`ab70fe90 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x34
    4: kd> .trap ffffd000`5a9b4b00
    NOTE: The trap frame does not contain all registers.
    Some register values may be zeroed or incorrect.
    rax=0000000000000000 rbx=0000000000000000 rcx=0000000000000000
    rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
    rip=00007ffa2c2d225a rsp=0000009aab70f558 rbp=0000000000000102
     r8=0000000000000000  r9=0000000000000000 r10=0000000000000000
    r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
    r14=0000000000000000 r15=0000000000000000
    iopl=0         nv up ei pl nz na pe nc
    0033:00007ffa`2c2d225a c3              ret
    4: kd> u @rip
    00007ffa`2c2d225a c3              ret
    00007ffa`2c2d225b 0f1f440000      nop     dword ptr [rax+rax]
    00007ffa`2c2d2260 4c8bd1          mov     r10,rcx
    00007ffa`2c2d2263 b848010000      mov     eax,148h
    00007ffa`2c2d2268 0f05            syscall
    00007ffa`2c2d226a c3              ret
    00007ffa`2c2d226b 0f1f440000      nop     dword ptr [rax+rax]
    00007ffa`2c2d2270 4c8bd1          mov     r10,rcx
    Okay so a hard error occurred on boot, meaning the disk is most likely at fault. It could be faulting memory but because of its consistency, it's most likely a disk error.
    Do you still have warranty on your SSD?
      My System SpecsSystem Spec

  7. #7

    Posts : 7
    Windows 8.1

    I would still have warranty on the SSD but I'm living in the Falkland Islands, so sending the hard drive back would be quite difficult, and could take weeks.

    I've uninstalled Networx (even though it's very important for me to monitor how much data I use (I only get 3.5GB of usage per month between my laptop and my mobile))

    I've also updated a bunch of drivers (ATK, Chipset, IRST, KBFilter, Thunderbolt and USBChargerPlus) just in case that was causing issues.

    I've had no crashes for days now. Could something I have done have fixed it?
      My System SpecsSystem Spec

  8. #8

    Posts : 7
    Windows 8.1

    Crashed again today....
      My System SpecsSystem Spec

  9. #9

    Upload the dump file, again, it's most likely a bad drive.
    If you haven't already memtest86+ can eliminate the RAM possibility.
    Run it for a minimum of 8 passes.
      My System SpecsSystem Spec

  10. #10

    Posts : 7
    Windows 8.1

    well i've started my laptop a bunch of times, and it doesn't seem to have crashed in awhile now... the only thing that i'm doing differently is giving it a few seconds to start up. because normally it takes about 3 seconds to boot up, and i log in within about 5 seconds, but now i leave it about 10 seconds and then log in and no crashes in while.
      My System SpecsSystem Spec

Random BSOD 0xc000021a brand new laptop
Related Threads
Rather rare and random 0xc000021a BSODs in BSOD Crashes and Debugging
Once in a while I get a 0xc000021a BSOD, which seem to be happening right after boot. Here are the latest two. ---------------- Windows 8.1 enterprise, with all updates except September update KB2984006. P.S. The SF Diagnostic Tool doesn't work for me. It gives no results.
Solved Random BSOD when I start my laptop in BSOD Crashes and Debugging
OK, I am experiencing a strange problem on my Windows 8.1 laptop. For the past few days, most of the time when I start my laptop after at least 12 hours of not using it, I get a message "Your PC ran into a problem and needs to restart". So it shuts down by itself and restarts. This time, on the 2nd...
Many random BSODs on brand-new Windows 8.1 PC in BSOD Crashes and Debugging
I've tried lots of different driver updates across everything to solve these BSOD errors and at many times had thought I'd solved them only to crash later. They *mostly* occur during gaming, but a couple times have just been while browsing the web. I've uploaded the required .zip according to...
BSOD on a brand new 2 day old Lenovo laptop in BSOD Crashes and Debugging
I just got the Lenovo Z710 laptop with I7-4700, 8gb, 1TB, Intel HD Graphics 4600 and Nvidia GEForce 745 graphics card. We had only loaded CCleaner, Auslogics Disk Defrag, AVG anti-virus & World of Warcraft (WoW) gaming. As soon as my son logged onto WoW, he got a black screen & then the BSOD. I am...
Hi, I recently bought a brand new laptop (MSI GT70 2OD, Dragon Editon 2) in August and even since I bought it I kept on getting lots of BSOD. First I thought I was a driver issue so uninstall my Nvidia Drivers (Back to stock drivers). Then few days after I got another one, so I decided to refresh...
Hi All, I have been using my Acer Aspire v3-772G for three days now and have now 10 blue screens. 4 times IRQL_NOT_LESS_OR_EQUAL 2 times SYSTEM_SERVICE_EXCEPTION I can not say there is pattern how to reproduce it - it has been coming suddenly most of the times. What I have tried so far:...
Hey guys, So I've been getting random BSOD's almost daily whenever the computer is idle. I've used the debugger tool and looked at the dump files and it says pci.sys is the problem so I updated my laptops drivers and it's still having issues. I've attached the required file below, thanks...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook