Windows 8 and 8.1 Forums

BSOD startup [Oppo/Android USB driver] [KSCE]

  1. #1

    Posts : 3
    Windows 8.1

    BSOD startup [Oppo/Android USB driver] [KSCE]

    After connecting an Oppo Find7 device to my Windows 8.1 PC and it "installing drivers" [I'd assume for USB tethering] my PC now blue screens [Kernal Security Check Error] every startup after about 5 seconds of getting to the login screen.

    I have included here the Zip file created by the DM Log collector Tool.

    Attachment 57764

    Can you get me the names of the drivers causing the crashes, if it is the drivers? I thought I'd removed all of the Oppo drivers but it still crashes with the same error. Thank you for any help given.
    Last edited by Templar3lf; 11 Feb 2015 at 10:06.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Templar3lf & Welcome to the forums ^_^,

    I have analysed your dump files and below has been provided an analysis of the same for informative purposes :-

    A kernel component has corrupted a critical data structure. The corruption could potentially allow a malicious user to gain control of this machine.
    6: kd> knL
     # Child-SP          RetAddr           Call Site
    00 ffffd000`24987f68 fffff800`03d6b5e9 nt!KeBugCheckEx
    01 ffffd000`24987f70 fffff800`03d6b910 nt!KiBugCheckDispatch+0x69
    02 ffffd000`249880b0 fffff800`03d6ab34 nt!KiFastFailDispatch+0xd0
    03 ffffd000`24988290 fffff801`a2c73a29 nt!KiRaiseSecurityCheckFailure+0xf4
    04 ffffd000`24988420 fffff801`a2d69572 ndis!ndisNsiGetInterfaceInformation+0x22b49
    05 ffffd000`249884d0 fffff801`a3bdba25 NETIO!NsiGetParameterEx+0x222
    06 ffffd000`24988630 fffff801`a3bdbbe3 nsiproxy!NsippGetParameter+0x195
    07 ffffd000`249887c0 fffff800`03ff01ef nsiproxy!NsippDispatch+0x53
    08 ffffd000`24988800 fffff800`03fef78e nt!IopXxxControlFile+0xa4f
    09 ffffd000`249889a0 fffff800`03d6b2b3 nt!NtDeviceIoControlFile+0x56
    0a ffffd000`24988a10 00007ffc`4a9e0cba nt!KiSystemServiceCopyEnd+0x13
    0b 0000003d`e246f288 00000000`00000000 0x00007ffc`4a9e0cba
    So, we see that in the stack, Ndis.sys (Networking Driver of Windows) gets the Information regarding the Interfaces available on the system which in turn raises a security check failure and causes the crash of the system.
    Below is a list of 3rd party drivers present on your system -
    **************************Tue Feb 10 03:35:18.716 2015 (UTC + 5:30)**************************
    mvxxmm.sys                  Thu Jan 19 12:20:44 2012 (4F17BD44)
    mvs91xx.sys                 Thu Jan 19 12:21:00 2012 (4F17BD54)
    AODDriver2.sys              Tue Mar  6 15:25:00 2012 (4F55DEF4)
    Rt630x64.sys                Tue Jun 12 19:07:53 2012 (4FD74631)
    usbfilter.sys               Tue Jun 19 16:37:40 2012 (4FE05D7C)
    amd_sata.sys                Tue Jul 24 00:04:48 2012 (500D9948)
    amd_xata.sys                Tue Jul 24 00:04:52 2012 (500D994C)
    bdfndisf6.sys               Tue Aug 28 19:55:03 2012 (503CD4BF)
    SnakeEyes.sys               Wed Sep  5 11:01:26 2012 (5046E3AE)
    AppleCharger.sys            Thu Oct 25 06:21:02 2012 (50888CF6)
    bdfwfpf.sys                 Mon Oct 29 17:53:28 2012 (508E7540)
    avchv.sys                   Wed Oct 31 22:35:22 2012 (50915A52)
    xhcdrv.sys                  Wed Jan  2 14:53:41 2013 (50E3FC9D)
    ViaHub3.sys                 Wed Jan  2 14:53:45 2013 (50E3FCA1)
    CORK40.sys                  Fri Oct 18 09:09:08 2013 (5260AD5C)
    nvhda64v.sys                Thu Oct  9 22:32:27 2014 (5436BFA3)
    nvvad64v.sys                Thu Nov 20 21:03:54 2014 (546E09E2)
    VBoxNetFlt.sys              Mon Nov 24 16:36:09 2014 (54731121)
    VBoxUSBMon.sys              Mon Nov 24 16:36:09 2014 (54731121)
    VBoxNetAdp.sys              Mon Nov 24 16:36:09 2014 (54731121)
    VBoxDrv.sys                 Mon Nov 24 16:37:17 2014 (54731165)
    nvlddmkm.sys                Sat Jan 10 03:52:06 2015 (54B0548E)
    **************************Tue Feb 10 03:14:08.466 2015 (UTC + 5:30)**************************
    avc3.sys                    Fri Jul 19 19:08:03 2013 (51E9413B)
    avckf.sys                   Fri Jul 19 19:11:15 2013 (51E941FB)
    gzflt.sys                   Fri Aug 23 16:18:49 2013 (52173E11)
    NvStreamKms.sys             Fri Dec 19 15:00:28 2014 (5493F034)

    Kindly follow the below steps, one step at a time -

    1. Please update your Marvell drivers since they are old.
    2. Kindly uninstall the BitDefender Antivirus till the time we are troubleshooting using this **LINK**.
    3. Kindly remove AMD Overdriver (AODDriver2.sys) as it is known to cause problems.

    Let me know how it goes ^_^

      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8.1

    Ok, so I managed to remove AMD Overdrive quite easily, although BitDefender was slightly harder. Most of my computer seemed adamant that it wasn't installed, and I was sure I hadn't installed it myself, and so did not know what version of un-installer I had to get. In the end went through all the links you listed looking for drivers related to BitDefender and removed them individually.

    Updating Marvell drivers seems to be more difficult, I can't seem to find much information online regarding version updates, and the Marvell website drivers I attempted to install didn't seem to recognise the operating system as 64 bit while I tried to install them in safe mode (couldn't boot to normal mode as blue screen every time).

    In the end I decided to remove the Marvell drivers completely, and re-install later if need be. What really seemed to help was removing BitDefender, which I actually think was installed as a part of Adaware, which would make sense.

    No Blue screen now, thank you so much for your help!
      My System SpecsSystem Spec

  4. #4

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Templar3lf ^_^,

    Glad to hear that the problem was solved ^_^. Kindly mark this thread as SOLVED

    In case of any further problems, do not hesitate to post back.

      My System SpecsSystem Spec

BSOD startup [Oppo/Android USB driver] [KSCE]
Related Threads
Hello. From time to time I'm required to use USB Tethering to connect my Nexus 4 (Android 4.4.4) with my laptop so I can access internet (either mobile data or wifi from the phone to the laptop (because sometimes it gets better from where it is)). The thing is that in around 95% of the times...
Hi all. My computer has always had intermittent BSOD but generally it's been only 1-2 a month and after a system restart everything works fine. In the last couple of weeks I've been getting BSOD after only a few minutes of operation every time I start up and generally after these errors the...
BSOD on startup in BSOD Crashes and Debugging
Hello again, Recently I thought I solved my BSOD problem, listed here. I thought it was Norton 360's fault. I uninstalled Norton and all of the sudden I am Blue Screening again on...
Please see the attached logs. This is a fresh installation of Windows 8. System Specs is on my user profile.
BSOD on almost every startup of my new PC. in BSOD Crashes and Debugging
Hi ! I keep getting 1 BSOD on almoste every startup of my new PC. After the restart no more BSOD appears, until next start.... The casue is almost all the the time causewd by driver hal.dll and 1ce61... Any ideas? Greetings from Sweden
Solved BSOD at startup in BSOD Crashes and Debugging
I turn on my computer, then the classic mainboard ad and some millisecond text come, and Windows 8 starts loading (that screen with the fish and a spinning thing). It spins for about 4-5 times then I get a BSOD (for reference, it usually takes 6 spins of the icon to load). I didn't install anything...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook