Windows 8 and 8.1 Forums


Display glitch: have to restart Explorer.exe after Sleep

  1. #1

    Display glitch: have to restart Explorer.exe after Sleep


    Hi

    I think I might be down to my last Win8 problem. When the PC wakes up, I get this ghosted display issue that is solved only by terminating and restarting Explorer.exe (see attached jpeg).

    I'm hoping this is a common problem with a simple solution.

    Thanks for any help!

      My System SpecsSystem Spec

  2. #2


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Hi,

    Not common at all but whatever the solution is, whether we find it or not, is.

    You can run the tool in the top thread of this subforum. Post the zip it and its linked thread show to make. We'll see what we can do.

    If you have 3rd party security like antivirus or firewall, don't even bother with that yet. Just remove it/them in safe mode with the specific tool(s) for it/them.
      My System SpecsSystem Spec

  3. #3


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    I just realized you're the same person I helped with fixing the bsods by removing AVG.

    All of your drivers are good or I would have suggested to update, so they're not the issue.

    You can type msinfo32 in the Start screen and press Enter. File | save.

    Right click the saved file and choose Send To>>>Compressed (Zip) Folder. Then attach the zip it makes to a new post here. Some software you have installed is likely the cause. I can probably guess which it is on first try.
      My System SpecsSystem Spec

  4. #4

    *.nfo attached


    Thanks so much! I have uploaded the nfo.
      My System SpecsSystem Spec

  5. #5


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Quote Originally Posted by jomardl View Post
    Thanks so much! I have uploaded the nfo.
    You're missing the SMBus Controller driver from Intel:

    Code:
    SM Bus Controller    PCI\VEN_8086&DEV_1C22&SUBSYS_47428086&REV_05\3&33FD14CA&0&FB    The drivers for this device are not installed.
    Visit their site and manually (no autoscan - will not work for Windows 8) download the latest Intel Chipset Update Utility for your chipset/motherboard, then use the device manager to install the driver, if running normally does not install it.

    I also recommend you install the latest Rapid Storage driver from Intel, as well.

    Code:
    Name    Standard SATA AHCI Controller
    Manufacturer    Standard SATA AHCI Controller
    Status    OK
    PNP Device ID    PCI\VEN_8086&DEV_1C02&SUBSYS_47428086&REV_05\3&33FD14CA&0&FA
    I/O Port    0x00003068-0x0000306F
    I/O Port    0x00003074-0x00003077
    I/O Port    0x00003060-0x00003067
    I/O Port    0x00003070-0x00003073
    I/O Port    0x00003020-0x0000303F
    Memory Address    0xF6426000-0xF64267FF
    IRQ Channel    IRQ 19
    Driver    c:\windows\system32\drivers\storahci.sys (6.2.8250.0, 70.30 KB (71 992 bytes), 2012/02/18 06:37 AM)
    After those things, if still necessary to try, uninstall Extensis Suitcase then reboot.

    Let me know how it goes and we'll take things from here, if still necessary.
      My System SpecsSystem Spec

  6. #6


    That appears to have solved it - so far so good at least. Much appreciated!
      My System SpecsSystem Spec

  7. #7


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Nice! Good job with updating and you're very welcome.
      My System SpecsSystem Spec

  8. #8


    Oh no. Looks like I wasn't that lucky - it happened again. I have resent the nfo file, in case you want to have a look at the current state.

    Attachment 6103
      My System SpecsSystem Spec

  9. #9


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Type msconfig in the start menu then press Enter. Go to Services tab. Check the box to hide all MS services, then click disable all.

    Then use Task Manager to disable all startup items.

    Reboot and see how it goes. If successful, you'll have to figure out which item disabled above is the cause.

    If there is a bios update, install it.
      My System SpecsSystem Spec

  10. #10


    Disabling services did not help but since I updated the BIOS it hasn't happened again. Looks like it happened mostly (if not always) with Photoshop running. I'm going to wait a few days before marking as solved but so far so good. Thanks very much.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Display glitch: have to restart Explorer.exe after Sleep
Related Threads
Since I have installed windows 8.1, every time for example if I don't use my laptop for 10 minutes, and because of the battery saving setting plan, my display turns off. Before I installed windows 8.1, I could just move a mouse or press any key and display would turn on, but since the installation...
Solved explorer.exe glitch in General Support
Hello, as you can see I have a problem with my Windows 8. I downloaded the Comodo Firewall which managed to somehow not allow me to open any programs or do anything, so I went into safe mode and did a system restore. After the system restore, I realized that every few minutes or so there's a weird...
Internet Explorer When viewing a YouTube video via youtube.com, or a plugin . Internet explorer , will automatically refresh the page. Hence rendering me incapable of viewing YouTube in any form on IE touch. This of which forces me to do so, by means of another browser. In which it is of more than...
Hi there, I was running Windows 7 home premium on my pc on a 2TB hdd, and it was running fine, I had a 500GB as a separate hdd aswell, attached at the time. So I installed windows 8 on the 500GB hdd, activated it, tried to restart, I restarts, but now in both windows 8 and 7, I am having...
Sleep Mode Causes Restart in BSOD Crashes and Debugging
I'm having the problem with my PC restarting after trying to come out of sleep mode. I've followed the dump instructions and have attached my zip file. I think it's a driver issue but no idea which one. Thanks for you help.
Can't restart, shutdown, or sleep in BSOD Crashes and Debugging
Hi there I have a Samsung ATIV Smart PC and have been running into some trouble. Whenever the tablet goes into sleep mode, I can't get it to wake up like it normally would. I can't seem to shut it down or restart the machine either. Sorry I'm a bit of a noob when it comes to this stuff. I...
pls wheneva i try to sleep, and i try to restart again, it brings this blue screen and says error and i will have to shutdown and on before my laptop can work properly just like this same problem you guys are discusiing can somebody help this poor boy and describe this compatibility step to me....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook