Windows 8 and 8.1 Forums

BSOD: mostly Memory Management, also Kernal + Pool Header

  1. #41

    Posts : 28
    Windows 8.1

    Ran small, large, and blend for 3 hours each. No errors or warnings on any test or core. Temp of the CPU stayed between 68-71 C for all three.
    I updated the HD audio driver (had forgotten to do that on reinstall of the OS a while back).
    3DP chip showed everything else as fine except my GPU driver. It says I have 14.501.1003.0 from 11-20-2014, but the latest is 14.501.1003.1001, also from 11-20-2014. However, I installed the driver from AMD's site, which shows it as the most recent wit a release date of 12-8-2014.

      My System SpecsSystem Spec

  2. #42

    Posts : 2,480
    Windows 10 Pro x64

    OK. How's the crashing now?
      My System SpecsSystem Spec

  3. #43

    2: kd> .bugcheck
    Bugcheck code 0000007A
    Arguments fffff6fc`0000c1a8 ffffffff`c000003f 00000001`85280860 fffff800`01835b64
    2: kd> !error ffffffff`c000003f
    Error code: (NTSTATUS) 0xc000003f (3221225535) - {Bad CRC}  A cyclic redundancy check (CRC) checksum error occurred.
    //Cyclic redundancy check failed, an inconsistency within the data has been detected via checksum. Most likely bad RAM, or a failing drive.
    2: kd> kn
     # Child-SP          RetAddr           Call Site
    00 ffffd000`2b36cf98 fffff800`80b6f717 nt!KeBugCheckEx //BSOD
    01 ffffd000`2b36cfa0 fffff800`80a3ac94 nt!MiWaitForInPageComplete+0xa187 //Wait for the page operation to complete
    02 ffffd000`2b36d090 fffff800`80a6dbdf nt!MiIssueHardFault+0x184 //Memory not present (hard fault), page it in from disk
    03 ffffd000`2b36d150 fffff800`80b5f32f nt!MmAccessFault+0x3cf //MM page fault handler
    04 ffffd000`2b36d290 fffff800`01835b64 nt!KiPageFault+0x12f //Page fault, memory not found
    05 ffffd000`2b36d428 fffff800`0182c6c5 AtihdWB6+0x35b64 //AMD high definition audio
    06 ffffd000`2b36d430 ffffcf80`045ce9b0 AtihdWB6+0x2c6c5
    07 ffffd000`2b36d438 ffffcf80`046ccf90 0xffffcf80`045ce9b0 //System range, functions not saved, context switch? Context not saved
    08 ffffd000`2b36d440 ffffcf80`045ce9b0 0xffffcf80`046ccf90 
    09 ffffd000`2b36d448 fffff800`01805ebd 0xffffcf80`045ce9b0
    0a ffffd000`2b36d450 ffffcf80`046d4e60 AtihdWB6+0x5ebd
    0b ffffd000`2b36d458 00000000`00000000 0xffffcf80`046d4e60
    It would appear the data has been corrupted when we brought the data into memory; most likely due to address corruption.

    1: kd> .bugcheck
    Bugcheck code 0000001A
    Arguments 00000000`00005003 fffff580`10804000 00000000`000020de 0000020d`c0fc41bc
    //Working set list entry corruption
    1: kd> kn
     # Child-SP          RetAddr           Call Site
    00 ffffd000`2656e998 fffff800`d9f7eff5 nt!KeBugCheckEx //BSOD
    01 ffffd000`2656e9a0 fffff800`d9e65fbe nt!MiAllocateWsle+0x12a65 //Allocating the working set list entry
    02 ffffd000`2656ea00 fffff800`d9e673ad nt!MiCompleteProtoPteFault+0x1be //Resolve the proto pte fault
    03 ffffd000`2656eab0 fffff800`d9e6a327 nt!MiResolveDemandZeroFault+0x76d //Reference allocated virtual address
    04 ffffd000`2656ebd0 fffff800`d9e6912b nt!MiResolveProtoPteFault+0x5d7 //Prototype PTE fault
    05 ffffd000`2656ec70 fffff800`d9e74b74 nt!MiDispatchFault+0x9ab 
    06 ffffd000`2656eda0 fffff800`d9e6d713 nt!MmAccessFault+0x364 //MM page fault handler
    07 ffffd000`2656eee0 fffff800`d9e6cd51 nt!MiProbeLeafFrame+0x413 //Frame pointer
    08 ffffd000`2656f020 fffff800`0167bb09 nt!MmProbeAndLockPages+0x241 //Probes virtual pages and locks them in memory
    09 ffffd000`2656f100 fffff800`0167b99f dxgmms1!VIDMM_SEGMENT::SafeProbeAndLockPages+0xd9
    0a ffffd000`2656f160 fffff800`016780dc dxgmms1!VIDMM_SEGMENT::LockAllocationBackingStore+0x93
    0b ffffd000`2656f1e0 fffff800`0166aba7 dxgmms1!VIDMM_MEMORY_SEGMENT::EvictResource+0x5a4
    0c ffffd000`2656f3a0 fffff800`0166ab11 dxgmms1!VIDMM_GLOBAL::EvictAllAllocationInList+0x6b
    0d ffffd000`2656f3e0 fffff800`01676bb7 dxgmms1!VIDMM_GLOBAL::EvictAllReclaimedAllocation+0x4d
    0e ffffd000`2656f420 fffff800`0166b827 dxgmms1!VIDMM_GLOBAL::ProcessDeferredCommand+0x43f
    0f ffffd000`2656f580 fffff800`0166b7d4 dxgmms1!VidMmiProcessSystemCommand+0x23
    10 ffffd000`2656f5b0 fffff800`0166b77f dxgmms1!VidSchiSubmitSystemCommand+0x48
    11 ffffd000`2656f5e0 fffff800`01642a58 dxgmms1!VidSchiSubmitQueueCommand+0x37
    12 ffffd000`2656f610 fffff800`01672eb8 dxgmms1!VidSchiSubmitQueueCommandDirect+0x174
    13 ffffd000`2656f6a0 fffff800`0166bb60 dxgmms1!VidSchiSubmitCommandPacketToQueue+0x3c8
    14 ffffd000`2656f710 fffff800`0166bca7 dxgmms1!VIDMM_GLOBAL::QueueSystemCommandAndWait+0x50
    15 ffffd000`2656f770 fffff800`0167efb0 dxgmms1!VIDMM_GLOBAL::QueueDeferredCommandAndWait+0x4f
    16 ffffd000`2656f7f0 fffff800`014bad0d dxgmms1!VIDMM_GLOBAL::PinOneAllocation+0x48
    17 ffffd000`2656f840 fffff800`0152de94 dxgkrnl!VIDMM_EXPORT::VidMmPinAllocation+0x45
    18 ffffd000`2656f870 fffff800`0152d97f dxgkrnl!DXGDEVICE::PinPrimaryAllocations+0xf8
    19 ffffd000`2656f8c0 fffff960`001ed099 dxgkrnl!DxgkSetDisplayMode+0x317
    1a ffffd000`2656fa50 fffff800`d9f678b3 win32k!NtGdiDdDDISetDisplayMode+0x16
    1b ffffd000`2656fa80 00007fff`7698183a nt!KiSystemServiceCopyEnd+0x13
    1c 000000c2`e325e5d8 00000000`00000000 0x00007fff`7698183a
    1: kd> !wsle 1
    Working Set @ fffff58010804000
        FirstFree     20de  FirstDynamic        5
        LastEntry     2748  NextSlot            5  LastInitialized     27b3
        NonDirect        0  HashTable           0  HashTableSize          0
    Reading the WSLE data .......Unable to get Wsle table block - address fffff58010805260 - count 1024 - page 0x200
    What has happened is the working set has trimmed a page which has multiple PTEs referencing it, thus making the page a transition page for one process, and a working set page for another. We've then gone about accessing the page again and bringing it into the process's working set. It's difficult to say why it happened because we only have a minidump, and thus the context isn't saved for most information.

    I know you've already tested your RAM, but this is almost certainly bad RAM, just by looking at the dump files.
    You can try to take all your RAM sticks out but one, then move it about the DIMM slots.
    Is your computer under warranty? I would certainly try to RMA the RAM if possible.
      My System SpecsSystem Spec

  4. #44

    Posts : 28
    Windows 8.1

    softwaremaniac: I haven't used it since the test last night. I won't get a chance most of today, but tonight I'll boot it up a bunch and see if I can do anything to make it crash. Still don't know what makes it tick, so we'll see. What do you think about Briggs' suggestion of RAM?

    Briggs: Which post of mine was that crash from? Just so I can keep things straight in my head My comp is a custom build. I got the RAM from Newegg a little less than 3 years ago, and Newegg says it has a limited lifetime warranty, so I could RMA it if need be.
      My System SpecsSystem Spec

  5. #45

    Posts 34&38.
    The two latest crashes.
      My System SpecsSystem Spec

  6. #46

    Posts : 2,480
    Windows 10 Pro x64

    I agree with Mysers.
      My System SpecsSystem Spec

  7. #47

    Posts : 28
    Windows 8.1

    I'll submit an RMA on the RAM then. Thanks both of you for your help. I'll post updates.

    Out of curiosity, can bad RAM cause it to look like a driver is bad?
      My System SpecsSystem Spec

  8. #48

    It can, depending on what went wrong. If a driver is behaving as it should be, but the address it is trying to allocate is corrupt, then it can appear to be the driver making bad references, when in fact the RAM is bad. This is usually what happens when we get 0x1A 5003 bugchecks, working set list corruption.
      My System SpecsSystem Spec

  9. #49

    Posts : 28
    Windows 8.1

    I got new RAM from G.SKILL. A note on the RMA process below. I'll use the new RAM for a few days and post if there are any crashes. If not, I'll mark as solved.

    The RMA process for the RAM went smoothly. I shipped it almost two weeks ago, G.SKILL got it 2/18 midday and shipped a replacement the next day, and I got the replacement last night. My only complaint is that G.SKILL did not communicate with me at any point other than accepting my RMA. They did not let me know they got the RAM, if they tested the RAM, or that they were sending me new RAM. I only know from the shipping services when packages were sent and received.
      My System SpecsSystem Spec

Page 5 of 5 FirstFirst ... 345
BSOD: mostly Memory Management, also Kernal + Pool Header
Related Threads
Random BSOD's usually bad pool header in BSOD Crashes and Debugging
54178 Usually get these randomly but seemingly more prevalent running flash videos. I have cleaned and installed my latest Catalyst drivers
BSOD Bad Pool Header 4 times in 30 mins in BSOD Crashes and Debugging
I always had bad pool header issues since I got this laptop (ASUS K55N) earlier this year but decided to get help today since it happened 4 times in 30 minutes. I have been looking around and Kaspersky seems to be a common cause of this, not sure if that is the issue at hand here for me. I get bad...
Hello, I am very new to the forums and was browsing around looking at other people with similar problems and thought I would post up my issues and see if anyone can help point me in the right directions. I have a couple of ideas but I am unsure if I am right... I have attached the ZIP of the...
BSOD Memory Management error please help in BSOD Crashes and Debugging
I'm going crazy and need some help with this. I have replaced every piece of hardware on this build and I cant get rid of the memory management bsod. It happens randomly. During games, installations, boot up, basically whenever it feels like it. I've tried everything I can think of and would really...
my computer keeps on freezing and its either bad pool header or DCP.watchdog.violation. its becoming more frequent and cant link it to any activity happening on my PC. attached a diagnostic downloaded from you website. any ideas?
Hi, Attached is the SF zip. Here's a rundown of what I've been trying to deal with: I've started on Windows 7 with SP1 installed. I had frequent BSOD's, I then also noticed every time I shut down the PC it would try to install 11 updates but stop before completing. Wondering about this I went...
Solved BSOD - Bad Pool Caller/Header in BSOD Crashes and Debugging
Hi, I have the Bad Pool Caller BSOD when I turn on my web browser or at other random moments. This happens ONLY when I have wifi ON. With wifi off the computer works fine. Recently I installed Comodo Internet Security but it didnt show up in installed programs so I used the uninstall app delivered...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook