Windows 8 and 8.1 Forums


2x WHEA_UNCORRECTABLE_ERROR BSODs in 3 days

  1. #1


    Posts : 3
    Windows 8.1

    2x WHEA_UNCORRECTABLE_ERROR BSODs in 3 days


    I suffered my first BSOD 2 days ago while playing Elite Dangerous. It was a WHEA_UNCORRECTABLE_ERROR with references to GenuineIntel, WIN8_DRIVER_FAULT, and the process was Elite Dangerous.

    I put it down to faulty code in the game somewhere, but just tonight, while browsing on Firefox, I suffered my second BSOD, with the same faults, except the given process this time was Firefox.

    I ran a tool to open up the latest memory dump and it gave me a lot of gobbledygook (pasted below) which is also probably contained in the two zips I am informed I have to upload with the thread.

    I self built the pc 1 year ago, and these are my first BSODs.

    Any help is appreciated, if I can give any more info, please let me know.




    Code:
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck 124, {0, ffffe000046ae028, bf800000, 124}
    
    Probably caused by : GenuineIntel
    
    Followup: MachineOwner
    ---------
    
    6: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    WHEA_UNCORRECTABLE_ERROR (124)
    A fatal hardware error has occurred. Parameter 1 identifies the type of error
    source that reported the error. Parameter 2 holds the address of the
    WHEA_ERROR_RECORD structure that describes the error conditon.
    Arguments:
    Arg1: 0000000000000000, Machine Check Exception
    Arg2: ffffe000046ae028, Address of the WHEA_ERROR_RECORD structure.
    Arg3: 00000000bf800000, High order 32-bits of the MCi_STATUS value.
    Arg4: 0000000000000124, Low order 32-bits of the MCi_STATUS value.
    
    Debugging Details:
    ------------------
    
    
    BUGCHECK_STR:  0x124_GenuineIntel
    
    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
    
    PROCESS_NAME:  firefox.exe
    
    CURRENT_IRQL:  f
    
    ANALYSIS_VERSION: 6.3.9600.17298 (debuggers(dbg).141024-1500) amd64fre
    
    STACK_TEXT:  
    ffffd000`a9789df8 fffff802`f504d213 : 00000000`00000124 00000000`00000000 ffffe000`046ae028 00000000`bf800000 : nt!KeBugCheckEx
    ffffd000`a9789e00 fffff802`f524cbed : 00000000`00000001 ffffe000`020ae3a0 ffffe000`020ae3a0 ffffe000`046ae028 : hal!HalBugCheckSystem+0xcf
    ffffd000`a9789e40 fffff802`f504d6a0 : 00000000`00000728 00000000`00000006 ffffd000`a978a230 00000000`00000000 : nt!WheaReportHwError+0x22d
    ffffd000`a9789ea0 fffff802`f504da0d : ffffe000`00000010 ffffe000`020ae3a0 ffffd000`a978a048 ffffe000`020ae3a0 : hal!HalpMcaReportError+0x50
    ffffd000`a9789ff0 fffff802`f504d8f8 : ffffe000`020ada30 00000000`00000001 00000000`00000006 00000000`00000000 : hal!HalpMceHandlerCore+0xe1
    ffffd000`a978a040 fffff802`f504db42 : 00000000`00000008 00000000`00000001 00000000`00000000 00000000`00000000 : hal!HalpMceHandler+0xe4
    ffffd000`a978a080 fffff802`f504dccf : ffffe000`020ada30 ffffd000`a978a2b0 00000000`00000000 00000000`00000000 : hal!HalpMceHandlerWithRendezvous+0xce
    ffffd000`a978a0b0 fffff802`f51e14bb : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : hal!HalHandleMcheck+0x40
    ffffd000`a978a0e0 fffff802`f51e1271 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxMcheckAbort+0x7b
    ffffd000`a978a220 fffff802`f515b3f2 : 00000000`00000001 fffff802`f50df3a6 00000000`400000c0 0000000e`00000208 : nt!KiMcheckAbort+0x171
    ffffd000`220d6940 fffff800`4d83cdb4 : ffffc000`4d80d8c8 ffffc000`47e64900 ffffd000`220d69e0 00000000`00000000 : nt!ExTryAcquirePushLockExclusiveEx+0xea
    ffffd000`220d6980 fffff800`4d8446de : ffffe000`025ac4d0 00000000`00000000 00000000`00000000 ffffe000`04c37480 : dxgkrnl!DXGPROCESSVIDMMLOCK::DXGPROCESSVIDMMLOCK+0x40
    ffffd000`220d69b0 fffff800`4d8a0b7b : ffffc000`4d80d860 ffffc000`484afe30 ffffd000`220d6b80 ffffd000`220d6a70 : dxgkrnl!VIDMM_EXPORT::VidMmReclaimAllocation+0x32
    ffffd000`220d69e0 fffff800`4d89a1e5 : ffffc000`4db49000 ffffc000`4db49000 00000000`00000001 00000000`0d400000 : dxgkrnl!DXGDEVICE::ReclaimAllocations+0x19b
    ffffd000`220d6a40 fffff802`f51e21b3 : ffffe000`03428500 ffffc000`4db49000 ffffc000`4db49000 00000000`ff22c000 : dxgkrnl!DxgkReclaimAllocations+0x1b5
    ffffd000`220d6b00 00000000`772b77ba : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
    00000000`0d30e2f8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x772b77ba
    
    
    STACK_COMMAND:  kb
    
    FOLLOWUP_NAME:  MachineOwner
    
    MODULE_NAME: GenuineIntel
    
    IMAGE_NAME:  GenuineIntel
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  0
    
    IMAGE_VERSION:  
    
    FAILURE_BUCKET_ID:  0x124_GenuineIntel_PROCESSOR_CACHE
    
    BUCKET_ID:  0x124_GenuineIntel_PROCESSOR_CACHE
    
    ANALYSIS_SOURCE:  KM
    
    FAILURE_ID_HASH_STRING:  km:0x124_genuineintel_processor_cache
    
    FAILURE_ID_HASH:  {4c8f3f5e-1af5-ed8b-df14-d42663b1dfa7}
    
    Followup: MachineOwner


    EDIT: I have had two further BSODs this evening since making this post. The first while trying to run an update on the Realtek Audio driver, the second while trying to play a song to see if the driver had actually installed due to the BSOD.

    I cannot now seem to install the Realtek Audio driver, it is giving me an error. :S
    Last edited by Nomadski; 09 Jan 2015 at 18:29.

      My System SpecsSystem Spec

  2. #2


    Posts : 40
    Windows 8.1 Pro 64bit, Linux Mint 17 64bit


    If I were to take a guess, the processor (particularly the cache) might be bad. However, I would wait for someone else to determine what the problem is before doing anything.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8.1


    Following on from a thread on another site, I uninstalled Asus AI Suite 3. I also unplugged the front mic and headphones and my HOTAS USBs from the rear. I managed to clean the Realtek drivers, and install new ones and ran Windows update.

    I then reset the BIOS to default, and only changed the XMP profile back on.

    I also ran Intels CPU Diagnostic Utility and it passed though it gave one area of concern -

    --- Reading CPU Frequency ---

    Expected CPU Frequency is --> 3.50


    Detected CPU Frequency is --> 4.29498

    CPU Frequency Test Passed with Warning!!!

    The processor frequency could be affected by power management features. In order
    to ensure the processor frequency is not affected by a power management setting,
    enter BIOS, load defaults, and disable any 'Over-Clocking' or power
    management features that may affect processor frequency. Also, set any
    software applications which control power management features to default.


    Which was when I set BIOS to default and removed AI Suite. Ran the test again and...

    --- Reading CPU Frequency ---

    Expected CPU Frequency is --> 3.50


    Detected CPU Frequency is --> 3.8936

    CPU Frequency Test Passed with Warning!!!

    The processor frequency could be affected by power management features. In order
    to ensure the processor frequency is not affected by a power management setting,
    enter BIOS, load defaults, and disable any 'Over-Clocking' or power
    management features that may affect processor frequency. Also, set any
    software applications which control power management features to default.


    So a bit strange frequency is still a bit off, even on defaults?

    So far since my last BSOD and doing the above, I haven't had another one, but am far from sure its fixed.

    I have plugged the front mic and headset back in, and will run the pc over a while (I have no idea if it could possibly cause BSODs, nor the USB at rear, but I thought the more I eliminate the better).

    I've been using Speccy to monitor heat levels, but my CPU sits at around 35C while doing little, and when encoding some video rose to 54C.

    Hopefully I can get some more precise suggestions from someone here.
      My System SpecsSystem Spec

  4. #4


    Code:
    ===============================================================================
    Section 2     : x86/x64 MCA
    -------------------------------------------------------------------------------
    Descriptor    @ ffffe000046ae138
    Section       @ ffffe000046ae2c0
    Offset        : 664
    Length        : 264
    Flags         : 0x00000000
    Severity      : Fatal
    
    Error         : DCACHEL0_WR_ERR (Proc 6 Bank 1)
      Status      : 0xbf80000000000124
      Address     : 0x0000000208028940
      Misc.       : 0x0000000000000086
    [CPU Information]
    ~MHz = REG_DWORD 3500
    Component Information = REG_BINARY 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
    Configuration Data = REG_FULL_RESOURCE_DESCRIPTOR ff,ff,ff,ff,ff,ff,ff,ff,0,0,0,0,0,0,0,0
    Identifier = REG_SZ Intel64 Family 6 Model 60 Stepping 3
    ProcessorNameString = REG_SZ Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz
    Update Status = REG_DWORD 0
    VendorIdentifier = REG_SZ GenuineIntel
    MSR8B = REG_QWORD 1a00000000
    A level 0 cache write error occurred, specifically when processor #6 writes to the first memory bank. This is consistent in both bugchecks, so to me this appears to be a failing CPU. It would appear to be some kind of cache corruption, given that we fail on a write error. Either that, or the processor #6 isn't performing accurate instructions. Either way, a failing processor is almost certain.

    Try to restore your settings back to defaults again, just to be safe.
    You've already checked temperatures. You also don't appear to be overclocking, so that is out of the question.

    I would RMA your CPU if it is still covered by warranty, otherwise you're looking at buying a new CPU.

    The only other thing I can suggest is make sure you don't have any bloatware or hardware modifying tools which can interfere with the CPU, such as AI suite etc.
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    Windows 8.1


    Could these errors be caused by anything else? Like the motherboard?

    Or is that error only caused by a dodgy cpu? I wouldn't want to RMA the CPU and find it was another component that caused the CPU to fail.
      My System SpecsSystem Spec

  6. #6


    It could be the motherboard, yes. Although there is no way to find out. It's most likely a CPU though, fialing motherboards usually have more 'random' symptons.
    If you can RMA I would certainly do it.
      My System SpecsSystem Spec

2x WHEA_UNCORRECTABLE_ERROR BSODs in 3 days
Related Threads
Four different BSODs in two days in BSOD Crashes and Debugging
Hi, In the past two days my Dell laptop (Win8 OS) has crashed four times with different BSOD error messages. What I have attempted is to run my anti-malware software and to go back to a restore point, but it hasn't work so I'm worried it is a problem with the RAM. The errors shown are...
52522 Hello there. I've been trying to fix this myself for days but I can't still fix it. Mind to help me? Also, there's something wrong with my desktop.52523
Hi there Google seems to be getting more and more USELESS these days I am messing around with a DEBIAN 7.4 ("Wheezy") system at the moment and forgot the command to show all the hardware the system thinks I've got on my system (rather like Device manager in Windows). It's not difficult but if...
Random BSODs - WHEA_UNCORRECTABLE_ERROR in BSOD Crashes and Debugging
Hello, I've been encountering random BSODs since i build my computer this summer and installed windows 8. I ran a SF diagnostic tool, I attached the results. Thank you very much for your time. I don't know where else to go.
Solved BSODs over the last couple of days in BSOD Crashes and Debugging
Over the last couple of days I've been having random BSOD after a few hours of use or so. I've been unable to find anything that causes it to occur, it appears to just happen randomly. Thanks for any help!
Solved Various BSODs in Past Two Days in BSOD Crashes and Debugging
About two weeks ago I upgraded to Windows 8 (from Windows 7) and I've been getting regular BSODs, 3 of which occurred in the past two days. I've been copy/pasting dump debugs from WinDbg, but your SF Diagnostic Tool seems like a much better option! Let me know if you think you know what the problem...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook