Windows 8 and 8.1 Forums

RAID controller causing DPC timeout

  1. #1

    Posts : 3
    Windows 8.1 Pro

    RAID controller causing DPC timeout

    I purchased this RAID 5 controller: Rosewill RSV-S5 SATA 3G 2.5" & 3.5" HDD 5-Bay RAID 0/1/5/10/5+spare/Spanning/JBOD Storage Enclosure System with 120mm cooling fan/ Port Multiplier/ PCIe card included/ Tray design -

    It has never worked. I have installed 5 1TB HDDs, and the controller card bios only recognizes 1 drive.
    The Disk Manager sees all 5 of the drives, so I ran the HDDs as pass-through, and used Windows' "Storage Spaces" to create a parity drive.

    Files under 2gb can be moved to the storage space (Nefas, the N: drive) while only occasionally causing the display drivers to stop, and sometimes BSODing. Files larger than that cannot be transferred without causing a DPC timeout: corrupting the file.

    I figured one option may be to extend the timeout period in the registry, but I don't know how. Optimally, the controller card bios should be able to set up a RAID 5 array, but from what I gather Silicone Image is known for their bad hardware, which is probably why only 1/5 of the HDDs are recognized in it's bios.

    I have installed various operating systems (XP, Vista, Server 2012, 8), every driver available for this tower (most recent vista drivers :X); tried creating a RAID 5 array through the disk management menu, and through the included ArrayManager software for the tower. (Both methods always fail and orphans one of the drives).

    Attached are the diagnostic logs.

    Any help would be greatly appreciated!!
    Thank you for your time.

    Attachment 56157

      My System SpecsSystem Spec

  2. #2

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Fleentrain89 & Welcome to the forums ^_^,

    I have analysed your dump files and below has been provided an analysis of the same for informative purposes :-
    2: kd> knL
     # Child-SP          RetAddr           Call Site
    00 ffffd001`dd5ebc88 fffff803`7b587fd8 nt!KeBugCheckEx
    01 ffffd001`dd5ebc90 fffff803`7b458165 nt! ?? ::FNODOBFM::`string'+0xb928
    02 ffffd001`dd5ebd20 fffff803`7bbbb67f nt!KeClockInterruptNotify+0x785
    03 ffffd001`dd5ebf40 fffff803`7b4fe76a hal!HalpTimerClockInterrupt+0x4f
    04 ffffd001`dd5ebf70 fffff803`7b56d62a nt!KiCallInterruptServiceRoutine+0x8a
    05 ffffd001`dd5ebfb0 fffff803`7b56da0f nt!KiInterruptSubDispatchNoLockNoEtw+0xea
    06 ffffd001`dd5dd140 fffff803`7bbb86b1 nt!KiInterruptDispatchLBControl+0x11f           //Interrupt Is Dispatched  
    07 ffffd001`dd5dd2d0 fffff800`8e349c07 hal!KeStallExecutionProcessor+0x123             //The Silicon Driver asking to stall thread
    08 ffffd001`dd5dd360 ffffe001`595d2738 Si3132r5+0xcc07                                         //Silicon Image Driver
    09 ffffd001`dd5dd368 00000000`01217464 0xffffe001`595d2738
    0a ffffd001`dd5dd370 00000000`00000000 0x1217464
    So, as we can see from the Stack, the Silicon Image Driver is asking the processor to wait for the current thread for some time which is probably greater than the DPC Timeout and the processor is unable to service other Interrupts or signals which is causing the system to crash ultimately.

    Let us check the date of the driver -
    2: kd> lmvm Si3132r5
    start             end                 module name
    fffff800`8e33d000 fffff800`8e393000   Si3132r5 T (no symbols)           
        Loaded symbol image file: Si3132r5.sys
        Image path: \SystemRoot\system32\DRIVERS\Si3132r5.sys
        Image name: Si3132r5.sys
        Timestamp:        Wed Sep 17 06:21:09 2008 (48D0547D)
        CheckSum:         0005B617
        ImageSize:        00056000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    The driver dates back to 2008 which is extremely old.
    Below is a list of 3rd party drivers present on your system -
    **************************Sun Jan  4 22:30:44.869 2015 (UTC + 5:30)**************************
    SiWinAcc.sys                Tue Nov  2 00:53:29 2004 (41868D31)
    SiRemFil.sys                Thu Oct 19 03:50:39 2006 (4536A8B7)
    Si3132r5.sys                Wed Sep 17 06:21:09 2008 (48D0547D)
    netr6164.sys                Wed Apr  7 17:37:21 2010 (4BBC7579)
    HECIx64.sys                 Wed Oct 20 05:03:43 2010 (4CBE2AD7)
    Rt630x64.sys                Fri May 10 15:29:08 2013 (518CC4EC)
    intelppm.sys                Thu Aug 22 14:16:35 2013 (5215CFEB)
    dump_storahci.sys           Thu Aug 22 17:10:39 2013 (5215F8B7)
    point64.sys                 Thu Dec 12 18:46:17 2013 (52A9B721)
    nvlddmkm.sys                Wed Jul  2 23:12:02 2014 (53B4446A)

    The highlighted drivers are related to your RAID and must be updated ASAP.

    Let me know how it goes ^_^

      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8.1 Pro

    Thank you so much for your response-

    Those links directed me to and after searching for sil 3132, I installed the latest SATA RAID manager.

    I installed the specified driver and bios versions to compliment the manager tool, and after rebooting experienced the same exact issues.

    The drivers I installed are from 2010, and the bios is from 2009.

    Attached are the new logs.

    Thank you so much for your help.

    Edit: I am using 5 of these hard drives: Samsung Desktop Class Spinpoint F3 1 TB SATA 3.0 Gb-s 32 MB Cache 3.5-Inch Internal Bare-OEM Drives, HD103SJ: Electronics

    Not sure if that is relevant.
      My System SpecsSystem Spec

  4. #4

    Posts : 3
    Windows 8.1 Pro

    is it possible to extend the DPC timeout period in the registry?
      My System SpecsSystem Spec

  5. #5

    Posts : 2,097
    Windows 8.1 Industry Pro B-)

    Hi Fleentrain89 ^_^,

    Same stack again.
    3: kd> knL
     # Child-SP          RetAddr           Call Site
    00 ffffd000`2c679c88 fffff802`e5973fd8 nt!KeBugCheckEx
    01 ffffd000`2c679c90 fffff802`e5844165 nt! ?? ::FNODOBFM::`string'+0xb928
    02 ffffd000`2c679d20 fffff802`e5fa767f nt!KeClockInterruptNotify+0x785
    03 ffffd000`2c679f40 fffff802`e58ea76a hal!HalpTimerClockInterrupt+0x4f
    04 ffffd000`2c679f70 fffff802`e595962a nt!KiCallInterruptServiceRoutine+0x8a
    05 ffffd000`2c679fb0 fffff802`e5959a0f nt!KiInterruptSubDispatchNoLockNoEtw+0xea
    06 ffffd000`2c66b140 fffff802`e5fa46b1 nt!KiInterruptDispatchLBControl+0x11f
    07 ffffd000`2c66b2d0 fffff801`4638dc07 hal!KeStallExecutionProcessor+0x123
    08 ffffd000`2c66b360 ffffe000`21c65668 Si3132r5+0xcc07
    09 ffffd000`2c66b368 00000000`0121739c 0xffffe000`21c65668
    0a ffffd000`2c66b370 00000000`00000000 0x121739c
    Have you tried updating the BIOS of the host machine? It dates back to 2012.

    You need to report the issue to Silicon Image and see what they say on this because I am certain that the system is crashing due to the Silicon Image's driver.

    And no, there is no such method I am aware of which can increase the DPC Tick Count.

      My System SpecsSystem Spec

RAID controller causing DPC timeout
Related Threads
I have MSI laptop 17.3" Core i7-3630QM/16GB DDR3/NV GTX 675MX, 4GB, Windows 8.1 upgraded to from win 8. Wifi: Intel Centurino Wireless N2230 Not only on Windows 8.1 but on Windows 8 as well ever since I am on the new system, I get too many times 'This page cannot be displayed'. This happens like...
I have an HP EliteBook 8760w laptop (XU099UT#ABA) running Windows 8.1 64-bit with an Intel hardware RAID 0 array that contains two 750 GB WD hard drives (WDD7500BPKT-75PK4T0). I just upgraded the Intel RST driver to the latest version ( I recently discovered that if I go into the...
Solved can't change boot timeout in General Support
I've tried everything and the boot timeout always reverts to 30 seconds. I've used the internal boot menu, msconfig and easybcd to change it to 10 seconds but it always reverts back. I even tried using the win 7 text menu with the same results. Currently I use the graphical menu because I like it...
Login screen timeout... in Customization
Can anyone tell me how to adjust the timeout whereby the login screen appears asking for my password. It appears to be triggered after about 5 minutes of inactivity. Thanks Rob
My motherboard is an MSI P67a-GD65 (B3) with a Marvell SATA 6G controller on it. I use that controller to mirror a pair of 1TB drives. When I go to install windows 8 (technet RTM\Final version) or even after I do install Windows 8, the inital boot screen will take about 3 1/2 minutes to load. I...
Timeout in windows 8 in General Support
No matter what I do, and, I have done everything, Windows 8 goes to lock screen after 1 minute. When I go to control panel, even for screensaver to make it 15 minutes, when I apply and come back in, it resets to 1 minute.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook