Windows 8 and 8.1 Forums

HP Envy M6 BSOD BAD_POOL_CALLER while using Bittorrent

  1. #1

    Posts : 4
    Windows 8.1



    This is my first time posting on the forum, sorry to make it an issue!

    I reside in Australia, however recently I have come over to japan to visit relatives and since then my computer has been getting a BAD_POOL_CALLER error whenever I use bittorrent, i can initiate this error at will, it doesn't seem to occur randomly, nevertheless id still like it to be solved lest it still affects anything that requires a medium to high amount of download.

    I have followed many instructions on updating drivers and using driver verifier to try and figure out what driver is causing an issue, i have updated all the drivers i have been able to find (i think) i used slim driver to scan and update the drivers, i also cleaned the registry using ccleaner by Piriform.

    When i use Driver verifier, a blue screen occurs however it is usually the intel graphics driver that fails, while when i am not using verifier and initiate the BSoD on Bittorrent the dumps suggest that NETIO.sys is the fault and is also causing a failure in one of the windows kernels, (i think ntoskrnl.exe?) although i dont really know what this means.

    I have read that NETIO.sys errors can be caused by Network card drivers but i cant seem to find any updates.

    While in japan, i have not had my external monitor (which i usually connect to my laptop to extend the desktop) nor my usual mouse and keyboard (i use a seperate one) i am also using a japanese power adapter which causes the hp power adapter utility (i think when its recieving a lower amount of power) to engage.

    In my attempts to rid myself of this error, i uninstalled trend micro titanium antivirus, and deleted everything that i could find that was related to it, however i am unsure of whether i have managed to remove EVERYTHING.

    I have also tried uninstalling bittorrent, reinstalling it as well as trying other softwares but every single one causes the crash when a torrent is started.

    There is only one Dump file in the .zip because i accidentally deleted the rest with CCleaner, i caused a BSoD to get this dump, i havent analysed it but all the others listed NETIO.sys as the cause.

    Any Help would be greatly appreciated!


    BSoD when using BitTorrent, Dumps say Netio.sys is the cause, feel like i have tried everything! Help Greatly Appreciated!

    Thanks!Attachment 56102


    Since Coming to japan i have also noticed that my touchpad freezes, this is not caused by turning the touchpad off, i havent noticed it before, but then i usually use a mouse.

    Attachment 56142
    Last edited by TarO; 03 Jan 2015 at 22:30.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,480
    Windows 10 Pro x64

    I can see that there is a problem with Ralink Bluetooth PCIe Adapter. Ralink Bluetooth PCIe Adapter has a driver problem Windows 8.1 - code - Microsoft Community
    As far as graphics is concerned, try updating your GPU drivers from your manufacturer site or from here:!8QgmAZbK!Oeu30f...F6enW4OX0IwbXI
      My System SpecsSystem Spec

  3. #3

    Posts : 4
    Windows 8.1

    Quote Originally Posted by softwaremaniac View Post
    I can see that there is a problem with Ralink Bluetooth PCIe Adapter. Ralink Bluetooth PCIe Adapter has a driver problem Windows 8.1 - code - Microsoft Community
    As far as graphics is concerned, try updating your GPU drivers from your manufacturer site or from here:!8QgmAZbK!Oeu30f...F6enW4OX0IwbXI
    Hi thanks, For replying to my thread:

    The Ralink Driver you have given the link to is for a desktop pc, my computer is a laptop (sorry i didnt mention), will this driver still work for my computer?

      My System SpecsSystem Spec

  4. #4

    Posts : 2,480
    Windows 10 Pro x64

    I have given you a solution to your problem, and not the driver itself. It should work if that is compatible with W 8.1
      My System SpecsSystem Spec

  5. #5

    Posts : 4
    Windows 8.1

    Hi Softwaremaniac,

    So I deleted and installed a recommended version of the bluetooth driver and the issue regarding that seems to have disappeared (there was a yellow exclamation triangle icon on my computer in devices and printers). I tried to cause a Blue Screen by starting a torrent, and all seemed well but a few minutes later the same blue screen occured, having a quick look at the dump, it still says NETIO.sys is the cause T_T

    Sorry to make this ongoing, Thanks for your help!

    I have attached the latest files in the original post as an edit.

    Thanks so much!
      My System SpecsSystem Spec

  6. #6

    Posts : 2,480
    Windows 10 Pro x64

    What AV are you using? Are you connected via wireless when that happens?
    I think I can see traces of Teredo. Run Command propmpt as admin and enter: netsh interface teredo set state disabled
    It should say Ok. Reboot then try torrents again.
    Microsoft (R) Windows Debugger Version 6.3.9600.17237 AMD64
    Copyright (c) Microsoft Corporation. All rights reserved.
    Loading Dump File [C:\Users\Mihael\SysnativeBSODApps\010315-29531-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available
    ************* Symbol Path validation summary **************
    Response                         Time (ms)     Location
    Deferred                                       SRV*C:\SymCache*
    Symbol search path is: SRV*C:\SymCache*
    Executable search path is: 
    Windows 8 Kernel Version 9600 MP (4 procs) Free x64
    Product: WinNt, suite: TerminalServer SingleUserTS Personal
    Built by: 9600.17328.amd64fre.winblue_r3.140827-1500
    Machine Name:
    Kernel base = 0xfffff800`2fe01000 PsLoadedModuleList = 0xfffff800`300d7370
    Debug session time: Sat Jan  3 04:39:07.696 2015 (UTC + 1:00)
    System Uptime: 0 days 0:52:22.469
    Loading Kernel Symbols
    Press ctrl-c (cdb, kd, ntsd) or ctrl-break (windbg) to abort symbol loads that take too long.
    Run !sym noisy before .reload to track down problems loading symbols.
    Loading User Symbols
    Loading unloaded module list
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    Use !analyze -v to get detailed debugging information.
    BugCheck C2, {7, 1200, 0, ffffe001068d19e8}
    GetPointerFromAddress: unable to read from fffff80030161138
    unable to get nt!MmNonPagedPoolStart
    unable to get nt!MmSizeOfNonPagedPoolInBytes
    Probably caused by : NETIO.SYS ( NETIO!NetioFreeMdl+20d7f )
    Followup: MachineOwner
    3: kd> !analyze -v
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    The current thread is making a bad pool request.  Typically this is at a bad IRQL level or double freeing the same allocation, etc.
    Arg1: 0000000000000007, Attempt to free pool which was already freed
    Arg2: 0000000000001200, (reserved)
    Arg3: 0000000000000000, Memory contents of the pool block
    Arg4: ffffe001068d19e8, Address of the block of pool being deallocated
    Debugging Details:
    POOL_ADDRESS:  ffffe001068d19e8 
    BUGCHECK_STR:  0xc2_7_Mdl 
    PROCESS_NAME:  System
    ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) amd64fre
    LAST_CONTROL_TRANSFER:  from fffff800300a308a to fffff8002ff501a0
    ffffd000`209a2a28 fffff800`300a308a : 00000000`000000c2 00000000`00000007 00000000`00001200 00000000`00000000 : nt!KeBugCheckEx
    ffffd000`209a2a30 fffff801`d682f91f : 00000000`00000000 fffff801`d681e62d 00000000`00000000 00000000`00000000 : nt!ExAllocatePoolWithTag+0x113a
    ffffd000`209a2b20 fffff801`d6dc3ca5 : 00000000`00000000 00000000`00000000 ffffd000`209a2c40 fffff801`d681d2bb : NETIO!NetioFreeMdl+0x20d7f
    ffffd000`209a2b70 fffff801`d68018c1 : ffffe001`07bb0ae0 fffff801`00000001 00000000`00000000 fffff801`d681a7b0 : tcpip!FlpReturnNetBufferListChain+0xbd455
    ffffd000`209a2bc0 fffff801`d6f4676a : ffffe001`07bb0ae0 ffffe001`07bb0ae0 00000000`00000000 00000000`00000000 : NETIO!NetioDereferenceNetBufferList+0xc1
    ffffd000`209a2c40 fffff801`d6f472e5 : ffffe001`07bb0ae0 ffffe001`030909c0 00000000`00000000 00000000`00000000 : fwpkclnt!FwppDereferenceNetioNetBufferList+0x46
    ffffd000`209a2c90 fffff801`dbc11eba : ffffe001`07bb0ae0 ffffe001`07bb0ae0 ffffe001`0348b030 00000000`00000001 : fwpkclnt!FwpsDereferenceNetBufferList0+0x25
    ffffd000`209a2cc0 fffff801`dbc11f75 : ffffe001`0839f4e0 00000000`00000002 ffffe001`07b8d1a0 fffff800`2fe672f0 : tunnel!TunnelUserRestoreAndFreeNblAndNbState+0x6a
    ffffd000`209a2d10 fffff801`d6ac9d50 : ffffe001`02c92910 ffffe001`03ce7290 ffffe001`02415180 ffffc002`05344140 : tunnel!TunnelUserReturnNetBufferLists+0x26
    ffffd000`209a2d50 fffff801`d6ac9c2d : ffffcbf2`b7d2ec01 ffffe001`0348b030 00000000`00000001 fffff801`d6e8d370 : ndis!ndisInvokeNextReceiveCompleteHandler+0x30
    ffffd000`209a2de0 fffff801`d6ac9cf2 : ffffe001`07b8d1a0 00000000`00000000 ffffe001`0348b030 ffffe001`08a41a90 : ndis!ndisReturnNetBufferListsInternal+0x12d
    ffffd000`209a2e40 fffff801`d6d068f6 : ffffe001`0348b190 00000000`00000000 00000000`00000000 fffff801`d6cc8aef : ndis!NdisReturnNetBufferLists+0x72
    ffffd000`209a2ea0 fffff801`d68011f3 : 00000000`00000000 00000000`00000001 00000000`00000001 00000000`00000000 : tcpip!FlpReturnNetBufferListChain+0xab
    ffffd000`209a2ef0 fffff801`d6d135cf : 00000000`00000000 00000000`00000000 ffffe001`08a1c010 ffffe001`0348b030 : NETIO!NetioDereferenceNetBufferListChain+0xd3
    ffffd000`209a2f90 fffff801`d6d10abc : 00000000`209a3400 ffffd000`209a31c0 00000000`00000000 00000000`00000000 : tcpip!IppReceiveHeaderBatch+0x37f
    ffffd000`209a30c0 fffff801`d6d06eed : ffffe001`08a1c670 00000000`00000000 ffffd000`209a3400 00000000`00000000 : tcpip!IppFlcReceivePacketsCore+0xa4d
    ffffd000`209a3440 fffff801`d6d06ab6 : 00000000`00000017 00000000`00000000 fffff801`d6d06850 00000000`00000000 : tcpip!FlpReceiveNonPreValidatedNetBufferListChain+0x313
    ffffd000`209a3530 fffff800`2febcf46 : ffffe001`034c7d00 00000000`00000001 ffffe001`03a0f600 ffffd000`2099e000 : tcpip!FlReceiveNetBufferListChainCalloutRoutine+0x175
    ffffd000`209a3660 fffff801`d6d06b96 : fffff801`d6d06940 ffffd000`209a3780 ffffe001`08d38400 ffffd000`209a38c0 : nt!KeExpandKernelStackAndCalloutInternal+0xe6
    ffffd000`209a3750 fffff801`d6ac9903 : 00000000`00000000 ffffd000`209a3831 ffffe001`00000001 ffffe001`08d38440 : tcpip!FlReceiveNetBufferListChain+0xb6
    ffffd000`209a37d0 fffff801`d6aca08a : fffff801`20204400 00000000`00000000 ffffe001`00000000 fffff800`00000001 : ndis!ndisMIndicateNetBufferListsToOpen+0x123
    ffffd000`209a3890 fffff801`dbc0e046 : fffff801`dbc1e3b8 fffff801`dbc09dc2 00000000`00000000 fffff07e`f3fbef8e : ndis!NdisMIndicateReceiveNetBufferLists+0x32a
    ffffd000`209a3a70 fffff801`dbc09f8a : fffff801`dbc1e3b8 ffffe001`030909c0 ffffe001`03090880 fffff800`2fe81339 : tunnel!TeredoWfpIndicationWorker+0x67
    ffffd000`209a3ab0 fffff800`2fe70ce8 : ffffe001`07b274c0 ffffe001`066b9630 ffffd000`4860faf8 ffffffff`fb061f00 : tunnel!LwWorker+0x1e
    ffffd000`209a3ae0 fffff800`2fe705e3 : ffffe001`0380ade0 fffff800`2fe70c68 ffffd000`209a3bd0 00000000`00c3e000 : nt!IopProcessWorkItem+0x80
    ffffd000`209a3b50 fffff800`2feffe70 : ffffe001`02556040 ffffe001`03090880 ffffe001`03090880 ffffe001`02451340 : nt!ExpWorkerThread+0x293
    ffffd000`209a3c00 fffff800`2ff567c6 : ffffd000`20378180 ffffe001`03090880 ffffe001`02556040 26ad27cd`7d9f3a98 : nt!PspSystemThreadStartup+0x58
    ffffd000`209a3c60 00000000`00000000 : ffffd000`209a4000 ffffd000`2099e000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16
    fffff801`d682f91f 90              nop
    SYMBOL_NAME:  NETIO!NetioFreeMdl+20d7f
    FOLLOWUP_NAME:  MachineOwner
    IMAGE_VERSION:  6.3.9600.17337
    FAILURE_BUCKET_ID:  0xc2_7_Mdl__NETIO!NetioFreeMdl
    BUCKET_ID:  0xc2_7_Mdl__NETIO!NetioFreeMdl
    FAILURE_ID_HASH_STRING:  km:0xc2_7_mdl__netio!netiofreemdl
    FAILURE_ID_HASH:  {f2c46e80-d936-89a0-13f9-f9b302dc640b}
    Followup: MachineOwner
    3: kd> !pool ffffe001068d19e8
    Pool page ffffe001068d19e8 region is Unknown
     ffffe001068d1000 size:  190 previous size:    0  (Allocated)  EtwG
     ffffe001068d1190 size:   10 previous size:  190  (Free)       Free
     ffffe001068d11a0 size:   40 previous size:   10  (Allocated)  MmSe
     ffffe001068d11e0 size:   80 previous size:   40  (Allocated)  SeTl
     ffffe001068d1260 size:   90 previous size:   80  (Allocated)  KETR
     ffffe001068d12f0 size:   d0 previous size:   90  (Allocated)  Mdl 
     ffffe001068d13c0 size:   d0 previous size:   d0  (Allocated)  Mdl 
     ffffe001068d1490 size:  240 previous size:   d0  (Allocated)  286R
     ffffe001068d16d0 size:   d0 previous size:  240  (Allocated)  Mdl 
     ffffe001068d17a0 size:  240 previous size:   d0  (Allocated)  286R
    *ffffe001068d19e0 size:   d0 previous size:  240  (Allocated) *Mdl 
            Pooltag Mdl  : Io, Mdls
     ffffe001068d1ab0 size:  240 previous size:   d0  (Allocated)  286R
     ffffe001068d1cf0 size:   d0 previous size:  240  (Allocated)  Mdl 
     ffffe001068d1dc0 size:  240 previous size:   d0  (Allocated)  286R
    3: kd> k
    Child-SP          RetAddr           Call Site
    ffffd000`209a2a28 fffff800`300a308a nt!KeBugCheckEx
    ffffd000`209a2a30 fffff801`d682f91f nt!ExAllocatePoolWithTag+0x113a
    ffffd000`209a2b20 fffff801`d6dc3ca5 NETIO!NetioFreeMdl+0x20d7f
    ffffd000`209a2b70 fffff801`d68018c1 tcpip!FlpReturnNetBufferListChain+0xbd455
    ffffd000`209a2bc0 fffff801`d6f4676a NETIO!NetioDereferenceNetBufferList+0xc1
    ffffd000`209a2c40 fffff801`d6f472e5 fwpkclnt!FwppDereferenceNetioNetBufferList+0x46
    ffffd000`209a2c90 fffff801`dbc11eba fwpkclnt!FwpsDereferenceNetBufferList0+0x25
    ffffd000`209a2cc0 fffff801`dbc11f75 tunnel!TunnelUserRestoreAndFreeNblAndNbState+0x6a
    ffffd000`209a2d10 fffff801`d6ac9d50 tunnel!TunnelUserReturnNetBufferLists+0x26
    ffffd000`209a2d50 fffff801`d6ac9c2d ndis!ndisInvokeNextReceiveCompleteHandler+0x30
    ffffd000`209a2de0 fffff801`d6ac9cf2 ndis!ndisReturnNetBufferListsInternal+0x12d
    ffffd000`209a2e40 fffff801`d6d068f6 ndis!NdisReturnNetBufferLists+0x72
    ffffd000`209a2ea0 fffff801`d68011f3 tcpip!FlpReturnNetBufferListChain+0xab
    ffffd000`209a2ef0 fffff801`d6d135cf NETIO!NetioDereferenceNetBufferListChain+0xd3
    ffffd000`209a2f90 fffff801`d6d10abc tcpip!IppReceiveHeaderBatch+0x37f
    ffffd000`209a30c0 fffff801`d6d06eed tcpip!IppFlcReceivePacketsCore+0xa4d
    ffffd000`209a3440 fffff801`d6d06ab6 tcpip!FlpReceiveNonPreValidatedNetBufferListChain+0x313
    ffffd000`209a3530 fffff800`2febcf46 tcpip!FlReceiveNetBufferListChainCalloutRoutine+0x175
    ffffd000`209a3660 fffff801`d6d06b96 nt!KeExpandKernelStackAndCalloutInternal+0xe6
    ffffd000`209a3750 fffff801`d6ac9903 tcpip!FlReceiveNetBufferListChain+0xb6
    ffffd000`209a37d0 fffff801`d6aca08a ndis!ndisMIndicateNetBufferListsToOpen+0x123
    ffffd000`209a3890 fffff801`dbc0e046 ndis!NdisMIndicateReceiveNetBufferLists+0x32a
    ffffd000`209a3a70 fffff801`dbc09f8a tunnel!TeredoWfpIndicationWorker+0x67
    ffffd000`209a3ab0 fffff800`2fe70ce8 tunnel!LwWorker+0x1e
    ffffd000`209a3ae0 fffff800`2fe705e3 nt!IopProcessWorkItem+0x80
    ffffd000`209a3b50 fffff800`2feffe70 nt!ExpWorkerThread+0x293
    ffffd000`209a3c00 fffff800`2ff567c6 nt!PspSystemThreadStartup+0x58
    ffffd000`209a3c60 00000000`00000000 nt!KiStartSystemThread+0x16
      My System SpecsSystem Spec

  7. #7

    Posts : 4
    Windows 8.1

    Hi Softwaremaniac,

    So I turned off teredo and that seeemed to do the trick!

    Thankyou so much for your help!
      My System SpecsSystem Spec

HP Envy M6 BSOD BAD_POOL_CALLER while using Bittorrent
Related Threads
BSOD every 10 min ! bad_pool_caller in BSOD Crashes and Debugging
Hello everyone, I'm having big troubles with my computer, I can't manage to use it more than 10 minutes since it keeps having BSODs.. I'm using Windows 8.1, and, during the time I wrote those few lines, it already restarted 3 times !! Here are specy snapshot, dump files and I used...
BSOD when downloading with bitTorrent in BSOD Crashes and Debugging
Hi and already thank you for looking into my post. Like the title says, im getting BSOD when using BitTorrent. Its not always, its hard to find a constant when its crashing... I have attached the zip file and hope you guys know what to look for in it. I have: Windows 7 ultimate...
Solved BSOD while using bittorrent clients in BSOD Crashes and Debugging
Whenever I start any download in my bittorrent clients (Vuze), after around 5-10mins my PC shows this BSOD Screen. I'am using Windows 8 pro 32-bit OS. And I've also attached the debug file. So please have a look into it and try to...
Hello everyone, New to this forum and forums in general. I thank anybody who can assist with my issue in advance. My laptop has had an ongoing BSOD issue for a couple months now. Randomly, it will BSOD and the computer will restart after running a process. It will go a long periods of time...
BSoD bad_pool_caller in BSOD Crashes and Debugging
check my error please :( BSoD make me crazy :confused: here my minidump
BSOD - Bad_Pool_Caller in BSOD Crashes and Debugging
Evening everyone, Can someone interpret this one for me please? Satellite sucks for downloading anything more than a couple mb so I can't read it on my own. Thanks, Tim
Bsod - bad_pool_caller in BSOD Crashes and Debugging
I have started getting lots of BSODs of different kinds mostly BAD_POOL_CALLER. Computer worked fine two days ago. Happens every 5 min.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook