Windows 8 and 8.1 Forums

Bsod: Driver_page_fault_in_freed_special_pool

  1. #1

    Posts : 3
    Windows 8

    Bsod: Driver_page_fault_in_freed_special_pool

    Hi all,

    I've been experiencing fairly frequent (once a day) BSOD. It's not the same message each time but it tends to involve the paging pool. I've run diagnostics on my memory (Memtest+-latest version), my SSD (Intel Toolbox-latest version), my CPU(Intel utility-latest version) and everything comes up clean. I've performed fresh installs of Win8, including fresh installs of all drivers multiple times but nothing seems to help. I've tried just about everything I can think of so I'm really hoping you can help.

    Thanks in advance.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,480
    Windows 10 Pro x64

    Update drivers in red
    SiLib.sys Wed Feb 7 00:13:54 2007 (45C90BB2)  
    USBXpress Development Kit 
    AseUSBCC.sys Wed  Feb 7 00:15:34 2007 (45C90C16) 
    Aladdin USB Key HASP Driver (also  associated w/Antec Liquid Cooling software) 
    MBfilt64.sys  Fri Jul 31 05:40:32 2009 (4A7267B0) 
    Realtek HiDefinition Audio  driver (file labelled as Creative Audio Driver) - Was found in the latest Win8  version available from Realtek on 07Sep2013 
    NTIOLib_X64.sys Wed Oct 20 08:45:49 2010 (4CBE901D)  
    MSI Afterburner driver (known BSOD issues with  Windows) Also found to be a part of MSI Live Update 5[br][br]Recently (Nov 2014)  there have been numerous instances of this driver in memory dumps. Analysis  reveals that they are scattered throughout the filesystem by the installed MSI  command utilities. For now I suggest uninstalling them all. 
    NETwNe64.sys Tue Dec 6 18:48:39 2011 (4EDE5577)  
    Intelฎ Wireless WiFi Link Adapter driver 
    intelppm.sys Tue Nov 6 04:55:02  2012 (50988A16) 
    Intel Processor driver 
    dump_storahci.sys Sat Mar 2  03:15:44 2013 (513160D0) 
    driver created to provide disk access during crash  dump file generation 
    TeeDriverx64.sys Thu Sep 5  20:02:18 2013 (5228C72A) 
    Intel Management Engine Interface driver 
    ikbevent.sys Fri Jan 10  18:52:53 2014 (52D03375) 
    Intel Keyboard Class Upper Filter Driver 
    imsevent.sys Fri Jan 10 18:52:53  2014 (52D03375) 
    Intel Mouse Class Upper Filter Driver 
    ISCTD.sys Wed Jan 22 20:37:35  2014 (52E01DFF) 
    Intel(R) Smart Connect Technology Device Driver 
    asstor64.sys Mon Jan 27 10:30:34  2014 (52E6273A) 
    Asmedia ASM-106x Sata 6G controller 
    e22w8x64.sys  Wed Mar 26 16:58:37 2014 (5332F92D) 
    Killer Networks Ethernet  Card. Driver dated Mon Dec 3 10:42:37 2012 (? and earlier) has Qualcomm Atheros  Killer Service BSOD issue. Workaround here:[br] 
    INETMON.sys Thu Apr 3 18:50:43  2014 (533D9163) 
    Intel Smart Connect Driver 
    bwcW8x64.sys Thu Apr 10 17:40:24  2014 (5346BB68) 
    Killer Bandwidth Control Filter Driver 
    RTKVHD64.sys Tue Jul 15 12:53:15  2014 (53C5081B) 
    Realtek High Definition Audio Function Driver 
    nvhda64v.sys Mon Jul 21 16:17:53  2014 (53CD2111) 
    nVidia HDMI Audio Device (nForce chipset driver) 
    rzkeypadendpt.sys Thu Aug 21  04:59:01 2014 (53F56075) 
    Razer keypad endpoint driver 
    rzendpt.sys Fri Sep 5  05:22:07 2014 (54092C5F) 
    Razer RzEndPt driver 
    rzudd.sys Fri Sep 5 05:22:11 2014  (54092C63) 
    Razer Rzudd Engine Driver 
    rzjstk.sys Fri Sep 5 05:22:30 2014  (54092C76) 
    Razer JoyStick Device driver 
    nvlddmkm.sys Sat Sep 13 21:59:50  2014 (5414A236) 
    nVidia Video drivers 
    Debug session time: Mon  Dec 29 18:17:11.026 2014 (UTC + 1:00) 
    Loading Dump File  [C:\Users\Mihael\SysnativeBSODApps\122914-22234-01.dmp] 
    Built by:  9200.16912.amd64fre.win8_gdr.140502-1507 
    System Uptime: 0 days 14:10:53.187  
    Probably caused by : dxgmms1.sys (  dxgmms1!VIDMM_GLOBAL::CloseOneAllocation+1bc ) 
    BugCheck D5,  {fffff98142400fa8, 0, fffff88003a1ea84, 0} 
    Bugcheck code 000000d5 
    Arg1: fffff98142400fa8,  memory referenced 
    Arg2: 0000000000000000, value 0 = read operation, 1 =  write operation 
    Arg3: fffff88003a1ea84, if non-zero, the address which  referenced memory. 
    Arg4: 0000000000000000, (reserved) 
    BUGCHECK_STR: 0xD5  
    PROCESS_NAME:  Wow-64.exe 
    FAILURE_BUCKET_ID:  0xD5_VRFK_dxgmms1!VIDMM_GLOBAL::CloseOneAllocation 
    MaxSpeed: 3500  
    CurrentSpeed: 3500 
    BiosVersion = V1.9 
    BiosReleaseDate = 07/18/2014  
    SystemManufacturer = MSI 
    SystemProductName = MS-7815  
    --- E O J --- 2014 Dec 29 18:45:20 PM _88-dbug Copyright  2012 Sysnative Forums 
    --- E O J --- 2014 Dec 29 18:45:20 PM _88-dbug  Copyright 2012 Sysnative Forums 
    --- E O J --- 2014 Dec 29 18:45:20 PM  _88-dbug Copyright 2012 Sysnative Forums

    The Qualcomm Atheros Killer Service/KillerNetManager is known to cause BSOD's.  Please follow the workaround instructions here:
     	 		 			 			 				First, open the Run dialog (Win + R keys) and type in "services.msc" (without the quotes) and press Enter
    Scroll down and locate the "Qualcomm Atheros Killer Service" and right click on it.  Select "Stop"
    Right click on it again and this time select "Properties"
    In the dropdown box for "Startup type", select "Disabled", then click on the "OK" button at the bottom of the window
    Next, open Task Manager (right click on TaskBar and select "Task Manager")
    Click on the "More details" dropdown (if present)
    Click on the "Startup" tab
    Scroll down and locate the "KillerNetManager" entry, right click on it and select "Disable"
    There may also be an Install Shield (with the Killer gaming K next to it), if so Right click on it and select "Disable" 
    Finally, restart the system in order for the changes to take affect. 			 		
    At times the Killer Network Manager will continue to load.  If so,  it's usually listed in the MSINFO32...Software Environment...Startup  Programs section.  If it is, please try this:
     	 		 			 			 				It may be that the instructions aren't stopping everything.
    In some cases, there's a program running out of the Program Files/Program Files (x86) directory.
    "c:\program files\qualcomm atheros\killer network manager\killer~1.exe"  (NOTE:  killer~1.exe is most likely killernetmanager.exe)
    In other cases, there's a program running out of  c:\windows\installer\{Long string of letters, numbers, and  dashes}\networkmanager.exe_130c27d738f34c89bddf21bcfd74b56d.exe (the  long string of letters and numbers may change)
    Here's some things to try
    1) Please see if there are any entries in the Startup tab of Task  Manager that are related to Qualcomm/Atheros/Killer Network Manager (and  NOT the card itself) and disable them (please let us know what you  find)  Be careful as the wrong selection can disable the network card.
    2) Check in "msconfig" for any entries that aren't in the Startup tab of  Task Manager. Let us know if you find any Qualcomm/Atheros/Killer  entries there (we'll disable them differently if they are there).
    3) Locate the "c:\program files\qualcomm atheros\killer network  manager\killer~1.exe" and rename the .exe to .BAD (the killer~1 is  actually a filename that starts with killer and ends with .exe)  There  will be an error in event viewer, but it'll stop the bugger from  loading.
    4) Locate the "c:\windows\installer\{Long string of letters, numbers,  and dashes}\networkmanager.exe_130c27d738f34c89bddf21bcfd74b56d.exe"  entry and rename the .exe to .BAD (the long string of letters and  numbers may change)
    Just FYI - here are the MSI workaround instructions:  MSI USA
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8

    Thanks softwaremaniac. I've updated the drivers you listed and disabled "KillerNetManager" though I didn't see it in my startup folder. I'll reboot and see if it's running again.
      My System SpecsSystem Spec

  4. #4

    Posts : 3
    Windows 8

    Bsod: System_thread_exception_not_handled

    I received another BSOD (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED this time) after making the above changes. I just checked in services.msc and the Qualcomm KillerNetManager is still disabled.

    Attaching a new file dump.

    Thanks in advance!
      My System SpecsSystem Spec

  5. #5

    Posts : 651
    Windows 8.1 x64

    The corruption appears to be in the PFN database:
    6: kd> !address fffff88003e646dbMapping user range ...
    Mapping system range ...
    Mapping non addressable range ...
    Mapping page tables...
    Mapping hyperspace...
    Mapping HAL reserved range...
    Mapping User Probe Area...
    Mapping system shared page...
    Mapping system cache working set...
    Mapping loader mappings...
    Mapping system PTEs...
    Mapping system paged pool...
    Mapping session space...
    Mapping dynamic system space...
    Mapping PFN database...
    Mapping non paged pool...
    Mapping VAD regions...
    Mapping module regions...
    Mapping process, thread, and stack regions...
    Mapping system cache regions...
    Base Address:           fffff802`a176f170
    End Address:            fffff802`a176f16f
    Region Size:            ffffffff`ffffffff
    VA Type:                PFNDatabase
    VAD Address:            0x27676e69727473
    Commit Charge:          0x60003000300030
    Protection:             0x30003000300030 []
    Memory Usage:           Private
    No Change:              no
    More info:              !vad 0xfffff802a176f170
    6: kd> !vad 0xfffff802a176f170
    GetPointerFromAddress: unable to read from fffff802a176f040
    VAD             level      start      end    commit
    Unable to get LeftChild of nt!_MMVAD_SHORT at fffff802a176f170
    6: kd> .cxr 0xfffff88007135d20;r
    rax=fffff980b2a40fb0 rbx=fffff980fe7c6e00 rcx=fffff980fe7c6e00
    rdx=fffff980b2cdaf90 rsi=fffff9808c182fb0 rdi=fffffa801af48000
    rip=fffff88003e646db rsp=fffff88007136720 rbp=0000000000000000
     r8=ffbff980c1a2afb0  r9=fffffa801af48001 r10=0000000000000003
    r11=0000000000000008 r12=0000000000000098 r13=0000000000000098
    r14=fffffa801a8c2140 r15=0000000000000028
    iopl=0         nv up ei ng nz na po nc
    cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010286
    fffff880`03e646db 49397008        cmp     qword ptr [r8+8],rsi ds:002b:ffbff980`c1a2afb8=????????????????
    Last set context:
    rax=fffff980b2a40fb0 rbx=fffff980fe7c6e00 rcx=fffff980fe7c6e00
    rdx=fffff980b2cdaf90 rsi=fffff9808c182fb0 rdi=fffffa801af48000
    rip=fffff88003e646db rsp=fffff88007136720 rbp=0000000000000000
     r8=ffbff980c1a2afb0  r9=fffffa801af48001 r10=0000000000000003
    r11=0000000000000008 r12=0000000000000098 r13=0000000000000098
    r14=fffffa801a8c2140 r15=0000000000000028
    iopl=0         nv up ei ng nz na po nc
    cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010286
    dxgmms1!VIDMM_GLOBAL::ReferenceAllocationForSubmission+0xa7:fffff880`03e646db 49397008        cmp     qword ptr [r8+8],rsi ds:002b:ffbff980`c1a2afb8=????????????????
    Because this is a minidump, it's impossible to see anything of value in the dump past that it's a PFN issue. However, it's DirectX that's getting hit, so the likelihood it's the video driver goes up to about 99%. It's not 100%, but there's little in the OS that interacts with DirectX without going through the video driver to get there. The only way to be sure would be to enable special pool and driver verifier again, and configure the system for a full (not mini) dump. Note that the GeForce driver set 347.09 (from December 23) is available if your card supports it. The version you're running isn't the newest WHQL version, for what it's worth.
      My System SpecsSystem Spec

  6. #6

    Hi contra!

    I guess my post will not help you greatly... bu I (perhaps) suffer from the same issue... John a.k.a "usasma" suspected my netweorkdriver which is a Killer / Atheros Qualcom one:

    I also found this piece of infromation: MSI USA - Online Technical Support FAQ

    But as It seems there are not only notebooks affected by this issue:

    Best regards


    P.S.: I also disabled the Killer Suite... so lets see.
      My System SpecsSystem Spec

Bsod: Driver_page_fault_in_freed_special_pool
Related Threads
I have been getting a ton of bsods I have re installed video drivers, updated and reinstalled windows 8. Did countless hardware test(Video ram, check memory, Cpu test) all passed temperatures stay around 25-35 c. Recently uninstalled all video drivers and re installed. The bsods sometimes go away...
BSOD When playing games random Bsod messages in BSOD Crashes and Debugging
Hey I have a problem with my pc I got a few weeks ago It keeps getting the bsod and turning on and off randomly at times I use it mostly to play games and watch youtube , twitch ext. also internet can sometimes crash pointing this out Bsod can happen when playing a game and when on the web...
I have a clients Laptop (Asus X550C) running Windows 8 and the first error I had was 0xc0000034, having a look around I tried some fixes but none worked, eventually I was left with the following error: 0xc0000001. As of now I am stuck here, I have a backup of the main files the client needs but do...
Hi, I've been getting hard locks where the audio continues to work while everything else becomes unresponsive that eventually degenerate into a BSOD with a DPC_Watchdog_Violation. Having looked at some of the events, I think it's probably some kind of SSD driver issue but I wanted to see if...
Hi, my problem with my laptop is Windows 8 BlueScreen and also Restart my laptop Without display BlueScreen and sometime this happened for more than 1 time regularly. this problem is happend Sometimes more than twice a day, when i'm doing regular things like reading a .pdf or watching a movie...
Hi, i'm new to this forum and i hope you guy can help me :) So my laptop is relatively new, it's not even a month old. I guess i've been downloading a lot of stuff that caused this error. Now, i'm not a computer expert or any type of expert, so please bear with me :D Before i go on, here are...
BSOD on a cold boot! After BSOD works fine! in BSOD Crashes and Debugging
Since getting my custom built PC, I have a BSOD that occurs after about 2 minutes of getting past the welcome screen and I only have this BSOD on a cold boot. If you could please help me and give me some advice on what i should do I would be extremely grateful! I originally posted this BSOD on...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook