Windows 8 and 8.1 Forums


Ongoing BSOD issue with RAID Setup

  1. #1


    Posts : 7
    Windows 8.1

    Ongoing BSOD issue with RAID Setup


    Hello,

    I've recently been having this issue with BSOD's on Windows login. I'm currently running a RAID array with 2 Samsung 250GB SSD's. Along with separate HDD of 3TB and 1TB. Other support sites have recommended me to update my AMD RAID controller, as mine is from 2012 in the device manager but i have had no luck in attempting this. Windows automatically restarts and I have access to my computer after each BSOD occurrence. I have also tried a fresh install of Windows with no external software watsoever with no luck as the BSOD still occurs. Ive checked the memory health with no issues stated. Help is appreciated if possible

      My System SpecsSystem Spec

  2. #2


    Posts : 2,480
    Windows 10 Pro x64


    Your BSODs appear to have been caused by Driver Reference Table
    Update drivers in red (remove Asus bloatware from your system).
    Code:
    LGBusEnum.sys Tue Nov 24 02:36:48 2009  (4B0B38B0) 
    Logitech Keyboard 
    http://www.carrona.org/drivers/driver.php?id=LGBusEnum.sys 
    
    LGVirHid.sys  Tue Nov 24 02:36:48 2009 (4B0B38B0) 
    Logitech Gamepanel Virtual  HID Device Driver 
    http://www.carrona.org/drivers/driver.php?id=LGVirHid.sys 
    
    AsUpIO.sys Tue  Aug 3 04:47:59 2010 (4C57835F) 
    ASUS hardware monitoring software  related 
    http://www.carrona.org/drivers/driver.php?id=AsUpIO.sys 
    
    AiChargerPlus.sys Thu Apr 19 03:17:35 2012 (4F8F67AF)  
    Asus Charger Driver [br] Likely BSOD cause - haven't  seen recently (15Jan2013) 
    http://www.carrona.org/drivers/driver.php?id=AiChargerPlus.sys 
    
    AsIO.sys Wed Aug 22 11:54:47  2012 (5034AC67) 
    Asus PCProbe Utility 
    http://www.carrona.org/drivers/driver.php?id=AsIO.sys 
    
    amdsbs.sys Tue Dec 11 22:21:44 2012  (50C7A3E8) 
    AMD AHCI Compatible Controller driver 
    http://www.carrona.org/drivers/driver.php?id=amdsbs.sys 
    
    hiber_amdsbs.sys Tue Dec 11  22:21:44 2012 (50C7A3E8) 
    
    hiber_amdsbs.sys - this driver hasn't been added to the DRT  as of this run. Please search Google/Bing for the driver if additional  information is needed. 
    
    ndisrd.sys Thu Feb 21 03:40:15 2013  (5125890F) 
    
    ndisrd.sys -  this driver hasn't been added to the DRT as of this run. Please search  Google/Bing for the driver if additional information is needed.  
    
    ladfGSCamd64.sys Mon Apr 15 20:39:12 2013 (516C4950) 
    Driver for the  Logitech GSeries Headset 
    http://www.carrona.org/drivers/driver.php?id=ladfGSCamd64.sys 
    
    ladfGSRamd64.sys Mon Apr 15  20:39:15 2013 (516C4953) 
    Driver for the Logitech GSeries Headset 
    http://www.carrona.org/drivers/driver.php?id=ladfGSRamd64.sys 
    
    Rt630x64.sys Fri May 10  11:59:08 2013 (518CC4EC) 
    Realtek PCI/PCIe Adapters 
    http://www.carrona.org/drivers/driver.php?id=Rt630x64.sys 
    
    LGSHidFilt.Sys Thu May 30  17:16:33 2013 (51A76D51) 
    Logitech Gaming KMDF HID driver[br]KB or mouse  
    http://www.carrona.org/drivers/driver.php?id=LGSHidFilt.Sys 
    
    agp440.sys Thu Aug 22 13:39:35  2013 (5215F877) 
    Intel AGP Bus Filter 
    http://www.carrona.org/drivers/driver.php?id=agp440.sys 
    
    nv_agp.sys Thu Aug 22 13:39:38 2013  (5215F87A) 
    NVIDIA nForce AGP Bus Filter 
    http://www.carrona.org/drivers/driver.php?id=nv_agp.sys 
    
    usbfilter.sys Mon Feb 17 07:23:43  2014 (5301AAEF) 
    AMD USB Filter Driver (likely part of the chipset drivers)  
    http://www.carrona.org/drivers/driver.php?id=usbfilter.sys 
    
    AMDACPKSL.SYS Sun Jun 22  04:31:43 2014 (53A6400F) 
    included in the AMD/ATI Catalyst WDM drivers  package 
    http://www.carrona.org/drivers/driver.php?id=AMDACPKSL.SYS 
    
    AtihdWB6.sys Sun Jun 22 04:32:00  2014 (53A64020) 
    AMD High Definition Audio Function Driver 
    http://www.carrona.org/drivers/driver.php?id=AtihdWB6.sys 
    
    atikmpag.sys Fri Nov 21 03:08:54  2014 (546E9EB6) 
    ATI Video driver (remove the Catalyst Control Center and  only install the Display Driver) 
    http://www.carrona.org/drivers/driver.php?id=atikmpag.sys 
    
    amdacpksd.sys Fri Nov 21 03:18:16  2014 (546EA0E8) 
    AMD ACP Kernel Service Driver (KSD) - I suspect it's a part  of the AMD chipset drivers as my system doesn't have it (and I have an Intel  chipset with an ATI video card). Just in case 
    http://www.carrona.org/drivers/driver.php?id=amdacpksd.sys 
    
    atikmdag.sys Fri Nov 21 03:30:27  2014 (546EA3C3) 
    ATI Video driver (remove the Catalyst Control Center and  only install the Display Driver) 
    http://www.carrona.org/drivers/driver.php?id=atikmdag.sys 
    
    
    
    Debug session time: Sat  Dec 27 08:42:36.716 2014 (UTC + 1:00) 
    Loading Dump File  [C:\Users\Mihael\SysnativeBSODApps\122714-11281-01.dmp] 
    Built by:  9600.17476.amd64fre.winblue_r5.141029-1500 
    System Uptime: 0 days 2:20:36.429  
    *** WARNING: Unable to verify timestamp for cdd.dll 
    *** ERROR: Module  load completed but symbols could not be loaded for cdd.dll 
    Probably caused  by : cdd.dll ( cdd+127b8 ) 
    BugCheck 7A, {ffffc001a00fd8c0, ffffffffc000003f,  12c5a1860, fffff960008727b8} 
    BugCheck Info: KERNEL_DATA_INPAGE_ERROR  (7a) 
    Bugcheck code 0000007A 
    Arguments: 
    Arg1: ffffc001a00fd8c0,  lock type that was held (value 1,2,3, or PTE address) 
    Arg2:  ffffffffc000003f, error status (normally i/o status code) 
    Arg3:  000000012c5a1860, current process (virtual address for lock type 3, or PTE)  
    Arg4: fffff960008727b8, virtual address that could not be in-paged (or PTE  contents if arg1 is a PTE address) 
    BUGCHECK_STR: 0x7a_c000003f  
    PROCESS_NAME: csrss.exe 
    FAILURE_BUCKET_ID: 0x7a_c000003f_cdd+127b8  
    BiosVersion = 2501 
    BiosReleaseDate = 04/07/2014 
    SystemManufacturer =  To be filled by O.E.M. 
    SystemProductName = To be filled by O.E.M.  
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``  
    Debug session time: Fri Dec 26 07:12:48.344 2014 (UTC + 1:00) 
    Loading  Dump File [C:\Users\Mihael\SysnativeBSODApps\122614-11312-01.dmp] 
    Built by:  9600.17476.amd64fre.winblue_r5.141029-1500 
    System Uptime: 0 days 2:47:44.054  
    Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+23063 )  
    BugCheck 7A, {ffffc00171c0d290, ffffffffc000003f, 180952880,  fffff80095502000} 
    BugCheck Info: KERNEL_DATA_INPAGE_ERROR  (7a) 
    Bugcheck code 0000007A 
    Arguments: 
    Arg1: ffffc00171c0d290,  lock type that was held (value 1,2,3, or PTE address) 
    Arg2:  ffffffffc000003f, error status (normally i/o status code) 
    Arg3:  0000000180952880, current process (virtual address for lock type 3, or PTE)  
    Arg4: fffff80095502000, virtual address that could not be in-paged (or PTE  contents if arg1 is a PTE address) 
    BUGCHECK_STR: 0x7a_c000003f  
    PROCESS_NAME: svchost.exe 
    FAILURE_BUCKET_ID:  0x7a_c000003f_nt!_??_::FNODOBFM::_string_ 
    BiosVersion = 2201  
    BiosReleaseDate = 11/22/2013 
    SystemManufacturer = To be filled by O.E.M.  
    SystemProductName = To be filled by O.E.M.  
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``  
    Debug session time: Thu Dec 25 07:34:03.517 2014 (UTC + 1:00) 
    Loading  Dump File [C:\Users\Mihael\SysnativeBSODApps\122514-12125-01.dmp] 
    Built by:  9600.17041.amd64fre.winblue_gdr.140305-1710 
    System Uptime: 0 days  1:45:42.237 
    *** WARNING: Unable to verify timestamp for amdsbs.sys 
    ***  ERROR: Module load completed but symbols could not be loaded for amdsbs.sys  
    Probably caused by : amdsbs.sys 
    BugCheck 9F, {3, ffffe000b5f0d060,  fffff802b169b8b0, ffffe000b69fc010} 
    BugCheck Info: DRIVER_POWER_STATE_FAILURE  (9f) 
    Bugcheck code 0000009F 
    Arguments: 
    Arg1: 0000000000000003, A  device object has been blocking an Irp for too long a time 
    Arg2:  ffffe000b5f0d060, Physical Device Object of the stack 
    Arg3:  fffff802b169b8b0, nt!TRIAGE_9F_POWER on Win7 and higher, otherwise the  Functional Device Object of the stack 
    Arg4: ffffe000b69fc010, The blocked  IRP 
    BUGCHECK_STR: 0x9F 
    DEFAULT_BUCKET_ID: WIN8_DRIVER_FAULT  
    PROCESS_NAME: System 
    FAILURE_BUCKET_ID:  0x9F_3_POWER_DOWN_disk_IMAGE_amdsbs.sys 
    BiosVersion = 2201  
    BiosReleaseDate = 11/22/2013 
    SystemManufacturer = To be filled by O.E.M.  
    SystemProductName = To be filled by O.E.M.  
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``  
    
    
    
    
    --- E O J --- 2014 Dec 26 22:38:51 PM _88-dbug Copyright  2012 Sysnative Forums 
    --- E O J --- 2014 Dec 26 22:38:51 PM _88-dbug  Copyright 2012 Sysnative Forums 
    --- E O J --- 2014 Dec 26 22:38:51 PM  _88-dbug Copyright 2012 Sysnative Forums
      My System SpecsSystem Spec

  3. #3


    Posts : 7
    Windows 8.1


    I removed most of the Asus software, including the Charger Driver you specified. All of my Logitech software runs through the latest Hub they released (8.57). I only possess a Logitech mouse and headset, the keyboard is Razor. Should driver verifier be the next step?
      My System SpecsSystem Spec

  4. #4


    Posts : 2,480
    Windows 10 Pro x64


    Yes, please do enable it.
      My System SpecsSystem Spec

  5. #5


    Posts : 7
    Windows 8.1


    I ran Driver Verifier with your SF Diagnostic tool and crashed upon accessing my desktop. With the error "Driver_VERIFIER_IONMANAGER_VIOLATION". I had to crash a couple times more while trying to get safe mode enabled. I hit the Grab All with SF Diagnostic and the files are attached below.Attachment 55740
      My System SpecsSystem Spec

  6. #6


    Posts : 2,480
    Windows 10 Pro x64


    Logitech Gamepanel Virtual HID Device Driver is misbehaving big time, please remove all logitech software from your PC and see how your PC behaves then, post back afterwards.
    Code:
    LGVirHid.sys Tue Nov 24 02:36:48 2009  (4B0B38B0) 
    Logitech Gamepanel Virtual HID Device Driver 
    http://www.carrona.org/drivers/driver.php?id=LGVirHid.sys 
    
    LGBusEnum.sys  Tue Nov 24 02:36:48 2009 (4B0B38B0) 
    Logitech Keyboard 
    http://www.carrona.org/drivers/driver.php?id=LGBusEnum.sys 
    
    AsUpIO.sys  Tue Aug 3 04:47:59 2010 (4C57835F) 
    ASUS hardware monitoring  software related 
    http://www.carrona.org/drivers/driver.php?id=AsUpIO.sys 
    
    AsIO.sys Wed Aug 22 11:54:47 2012  (5034AC67) 
    Asus PCProbe Utility 
    http://www.carrona.org/drivers/driver.php?id=AsIO.sys 
    
    amdsbs.sys Tue Dec 11 22:21:44 2012  (50C7A3E8) 
    AMD AHCI Compatible Controller driver 
    http://www.carrona.org/drivers/driver.php?id=amdsbs.sys 
    
    ladfGSCamd64.sys Mon Apr 15  20:39:12 2013 (516C4950) 
    Driver for the Logitech GSeries Headset 
    http://www.carrona.org/drivers/driver.php?id=ladfGSCamd64.sys 
    
    ladfGSRamd64.sys Mon Apr 15  20:39:15 2013 (516C4953) 
    Driver for the Logitech GSeries Headset 
    http://www.carrona.org/drivers/driver.php?id=ladfGSRamd64.sys 
    
    Rt630x64.sys Fri May 10  11:59:08 2013 (518CC4EC) 
    Realtek PCI/PCIe Adapters 
    http://www.carrona.org/drivers/driver.php?id=Rt630x64.sys 
    
    LGSHidFilt.Sys Thu May 30  17:16:33 2013 (51A76D51) 
    Logitech Gaming KMDF HID driver[br]KB or mouse  
    http://www.carrona.org/drivers/driver.php?id=LGSHidFilt.Sys 
    
    usbfilter.sys Mon Feb 17  07:23:43 2014 (5301AAEF) 
    AMD USB Filter Driver (likely part of the chipset  drivers) 
    http://www.carrona.org/drivers/driver.php?id=usbfilter.sys 
    
    AMDACPKSL.SYS Sun Jun 22  04:31:43 2014 (53A6400F) 
    included in the AMD/ATI Catalyst WDM drivers  package 
    http://www.carrona.org/drivers/driver.php?id=AMDACPKSL.SYS 
    
    AtihdWB6.sys Sun Jun 22 04:32:00  2014 (53A64020) 
    AMD High Definition Audio Function Driver 
    http://www.carrona.org/drivers/driver.php?id=AtihdWB6.sys 
    
    atikmpag.sys Fri Nov 21 03:08:54  2014 (546E9EB6) 
    ATI Video driver (remove the Catalyst Control Center and  only install the Display Driver) 
    http://www.carrona.org/drivers/driver.php?id=atikmpag.sys 
    
    amdacpksd.sys Fri Nov 21 03:18:16  2014 (546EA0E8) 
    AMD ACP Kernel Service Driver (KSD) - I suspect it's a part  of the AMD chipset drivers as my system doesn't have it (and I have an Intel  chipset with an ATI video card). Just in case 
    http://www.carrona.org/drivers/driver.php?id=amdacpksd.sys 
    
    atikmdag.sys Fri Nov 21 03:30:27  2014 (546EA3C3) 
    ATI Video driver (remove the Catalyst Control Center and  only install the Display Driver) 
    http://www.carrona.org/drivers/driver.php?id=atikmdag.sys 
    
    
    
    Debug session time: Sat  Dec 27 11:34:09.012 2014 (UTC + 1:00) 
    Loading Dump File  [C:\Users\Mihael\SysnativeBSODApps\122714-10406-01.dmp] 
    Built by:  9600.17476.amd64fre.winblue_r5.141029-1500 
    System Uptime: 0 days 0:00:57.807  
    *** WARNING: Unable to verify timestamp for LGVirHid.sys 
    *** ERROR:  Module load completed but symbols could not be loaded for LGVirHid.sys  
    Probably caused by : LGVirHid.sys ( LGVirHid+624 ) 
    BugCheck C9, {220,  fffff8022a2aab90, ffffcf8116be2d80, ffffe00029f2ada0} 
    BugCheck Info: DRIVER_VERIFIER_IOMANAGER_VIOLATION  (c9) 
    Bugcheck code 000000c9 
    Arguments: 
    Arg1: 0000000000000220,  IRP_MJ_SYSTEM_CONTROL has been completed by someone other than the ProviderId.  
    This IRP should either have been completed earlier or should have been  passed 
    down. 
    Arg2: fffff8022a2aab90, The address in the driver's code  where the error was detected. 
    Arg3: ffffcf8116be2d80, IRP address. 
    Arg4:  ffffe00029f2ada0, ProviderId. 
    BUGCHECK_STR: 0xc9_220 
    PROCESS_NAME:  System 
    FAILURE_BUCKET_ID: 0xc9_220_VRF_LGVirHid+624 
    BiosVersion = 2501  
    BiosReleaseDate = 04/07/2014 
    SystemManufacturer = To be filled by O.E.M.  
    SystemProductName = To be filled by O.E.M.  
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``  
    Debug session time: Sat Dec 27 11:32:19.518 2014 (UTC + 1:00) 
    Loading  Dump File [C:\Users\Mihael\SysnativeBSODApps\122714-30750-01.dmp] 
    Built by:  9600.17476.amd64fre.winblue_r5.141029-1500 
    System Uptime: 0 days 0:01:27.312  
    *** WARNING: Unable to verify timestamp for LGVirHid.sys 
    *** ERROR:  Module load completed but symbols could not be loaded for LGVirHid.sys  
    Probably caused by : LGVirHid.sys ( LGVirHid+624 ) 
    BugCheck C9, {220,  fffff8023a0a2b90, ffffcf80ff334d80, ffffe001e6227080} 
    BugCheck Info: DRIVER_VERIFIER_IOMANAGER_VIOLATION  (c9) 
    Bugcheck code 000000c9 
    Arguments: 
    Arg1: 0000000000000220,  IRP_MJ_SYSTEM_CONTROL has been completed by someone other than the ProviderId.  
    This IRP should either have been completed earlier or should have been  passed 
    down. 
    Arg2: fffff8023a0a2b90, The address in the driver's code  where the error was detected. 
    Arg3: ffffcf80ff334d80, IRP address. 
    Arg4:  ffffe001e6227080, ProviderId. 
    BUGCHECK_STR: 0xc9_220 
    PROCESS_NAME:  System 
    FAILURE_BUCKET_ID: 0xc9_220_VRF_LGVirHid+624 
    BiosVersion = 2501  
    BiosReleaseDate = 04/07/2014 
    SystemManufacturer = To be filled by O.E.M.  
    SystemProductName = To be filled by O.E.M.  
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``  
    Debug session time: Sat Dec 27 11:27:42.727 2014 (UTC + 1:00) 
    Loading  Dump File [C:\Users\Mihael\SysnativeBSODApps\122714-29296-01.dmp] 
    Built by:  9600.17476.amd64fre.winblue_r5.141029-1500 
    System Uptime: 0 days 0:01:03.523  
    *** WARNING: Unable to verify timestamp for LGVirHid.sys 
    *** ERROR:  Module load completed but symbols could not be loaded for LGVirHid.sys  
    Probably caused by : LGVirHid.sys ( LGVirHid+624 ) 
    BugCheck C9, {220,  fffff803dcea4b90, ffffcf80c1a8ed80, ffffe00119daba10} 
    BugCheck Info: DRIVER_VERIFIER_IOMANAGER_VIOLATION  (c9) 
    Bugcheck code 000000c9 
    Arguments: 
    Arg1: 0000000000000220,  IRP_MJ_SYSTEM_CONTROL has been completed by someone other than the ProviderId.  
    This IRP should either have been completed earlier or should have been  passed 
    down. 
    Arg2: fffff803dcea4b90, The address in the driver's code  where the error was detected. 
    Arg3: ffffcf80c1a8ed80, IRP address. 
    Arg4:  ffffe00119daba10, ProviderId. 
    BUGCHECK_STR: 0xc9_220 
    PROCESS_NAME:  System 
    FAILURE_BUCKET_ID: 0xc9_220_VRF_LGVirHid+624 
    BiosVersion = 2501  
    BiosReleaseDate = 04/07/2014 
    SystemManufacturer = To be filled by O.E.M.  
    SystemProductName = To be filled by O.E.M.  
    ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``  
    
    
    
    
    --- E O J --- 2014 Dec 26 23:57:15 PM _88-dbug Copyright  2012 Sysnative Forums 
    --- E O J --- 2014 Dec 26 23:57:15 PM _88-dbug  Copyright 2012 Sysnative Forums 
    --- E O J --- 2014 Dec 26 23:57:15 PM  _88-dbug Copyright 2012 Sysnative Forums
      My System SpecsSystem Spec

  7. #7


    Posts : 7
    Windows 8.1


    I made sure to wipe out all the Asus components including some sneaky processes that were going on in the background. With the Logitech software, its a physical base station so whenever you connect it, i assume it comes with some rudimentary software to operate it without the downloaded drivers. I ran driver verifier without it plugged in and no BSOD so far. This unfortunately leaves me without software for my mouse and without my headset. But a solution may be found here lol. No BSOD but i did grab all and it links here:Attachment 55742
      My System SpecsSystem Spec

  8. #8


    Posts : 7
    Windows 8.1


    This is with just re installing Logitech software ONLY as I BSODAttachment 55747
      My System SpecsSystem Spec

  9. #9


    Posts : 2,480
    Windows 10 Pro x64


    Sorry, I didn't get you quite well, apparently Logitech drivers were the cause? The BSODs stopped when you've uninstalled the drivers? Explain the second message too. I'm can't seem to understand it. Thank you.
      My System SpecsSystem Spec

  10. #10


    Posts : 7
    Windows 8.1


    I uninstalled ALL logitech drivers off the system before running driver verifier and I did not crash. I reinstalled them after turning off driver verifier and I crashed upon windows login. I assume they are the culprit.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Ongoing BSOD issue with RAID Setup
Related Threads
Solved Raid 1 setup in windows 8.1. in General Support
Hi! I am having trouble setting up a raid 1 (mirror) on a new computer using two identical hard drives. I have tried several things that I have found online. My system has an Asus motherboard A55BM-plus with an amd fm2 processor. Bios is set to a raid configuration and the bios sees both hard...
Hey gang, Until very recently i was running Windows 8 with a 240 GB Sandisk SSD as a primary and a 2 TB Western Digital Green HDD as a storage. I decided to set up a RAID 1 setup so i purchased a second 2 TB HDD and installed it. My intent was to run windows 8 off the 240 SSD as a primary and...
Solved Windows 8.1 RAID issue? in Drivers & Hardware
I've noticed that since upgrading to Windows 8.1, it doesn't seem to want to detect my RAID array. Upon system boot, it's not detected, but a few minutes after boot up, it detects my array as a removable device (even though they are connected to the motherboard's SATA ports). Also, the...
New to Windows 8 Setup Issue in Installation & Setup
Hello Eight Forums community, I have a bit of an annoying issue here; my young cousin has bought himself a win8 laptop (Home I presume as it is locked down from running lusrmgr.msc). Unfortunately in his haste he ran through the out of box experience with his mother and they used her email for...
Hi, I have created a setup package for Windows 8 app using Visual Studio 2012. On the app package success page when I click the "Launch Windows App Certification Kit", I am getting the below error: "The {0} cannot continue testing since the specied Windows Store app was not found. Please verify...
I have a new pc, with a raid setup, one small ssd drive for fast booting, and a 2 tb drive when I try to install win 8 via the "upgrade" method, it seems to install, but at the end, i get the failed to install message. its a dell xps one 27, and only 3 weeks old; I see a bunch of upgraded files...
As stated in the title, my windows 8 setup is not working. I'm trying to dual-boot the release preview ISO with my current win 7 (64 bit), but I'm having... difficulties. The problem seems to be with the partitioning. Here's what my Disk Management looks like before partitioning.7237 (The loading...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook