Windows 8 and 8.1 Forums

Hang/Freeze update CPV

  1. #1

    Hang/Freeze update CPV


    W8 may run well for several days, but occasionally hangs for 30' to minutes. Mouse is usable and some window switching is possible, but during the freeze it's essentially dead. Occurs randomly while in browser, other programs, file manager, etc. Sometimes, but not always, a window reports "not responding." If items are clicked during the unresponsive period, they will all execute when the freeze ends.

    After normal operation resumes there's no event viewer ERROR, but there is a warning at the time of the incident for storahci system: "Reset to device, \Device\RaidPort0, was issued." There is no RAID array on this box. In device manager no RAID driver is shown anywhere.

    System runs in AHCI mode and W8 drive is a SATA. Under "IDE ATA/ATAPI controllers" there were two entries for Standard SATA AHCI controller. Both indicated that the drivers were current.

    I downloaded a Marvel 91xx SATA 6g controller, right-clicked one of the above entries and UPDATED. The Marvel driver appeared under the "storage controllers" category in device manager, and one of the two SATI AHCI controller entries vanished. Clicking to upgrade the other SATA AHCI entry stated that no drivers could be found.

    W8 continues to hang. Hardware/software is identical to that used by W7 on an alternate SSD drive that never hangs. Before W8 CPV, W7 was running on the same SATA drive without problems. Virtually all freeze remedies seen in forums have been tried. Similar problems are widely reported. Perhaps the next W8 incarnation will incorporate a fix.

      My System SpecsSystem Spec

  2. #2


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Hi,

    The issue is not inherent to Windows 8. If you have an issue running it, waiting for a new version is not going to change anything in that regard.

    Install the latest proprietary driver from the manufacturer's website for the storage. Use the device manager if necessary. (Double click on the appropriate .inf to install it.)

    If you still have issues, run the tool in the top thread of the Crash subforum and make the zip as it shows, then attach the zip here.
      My System SpecsSystem Spec

  3. #3


    This is an Intel 2600K on an Asus P8P67le board. The latest (that I could find) Marvel storage 91xx driver is installed, under STORAGE CONTROLLERS in Device Manager.

    There is also a SATA/AHCI driver listed under IDE ATA/ATAPI controllers. It's an Intel driver, circa 2006, that reports itself as the "best for your computer." The zip files predate the installation of the 91xx driver, and reflect the O/S when there were two SATA/AHCI entries listed under IDE ATA/ATAPI controllers, as noted in my thread starter here.
      My System SpecsSystem Spec

  4. #4


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    You don't have the Realtek driver installed, so you can do so from the following link (on right side - HD Audio Codec driver):

    Code:
    Name    High Definition Audio Device
    Manufacturer    Microsoft
    Status    OK
    PNP Device ID    HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_1043841B&REV_1003\4&141F45D&0&0001
    Driver    c:\windows\system32\drivers\hdaudio.sys (6.2.8250.0, 330.00 KB (337,920 bytes), 2/17/2012 8:33 PM)
    Realtek

    ----------

    Should also install Intellipoint software from Microsoft's site:

    Code:
    Hardware Type    Microsoft USB Wireless Mouse (IntelliPoint)
    Number of Buttons    0
    Status    OK
    PNP Device ID    HID\VID_045E&PID_008C&COL01\7&3B410E5A&0&0000
    Power Management Supported    No
    Double Click Threshold    Not Available
    Handedness    Not Available
    Driver    c:\windows\system32\drivers\mouhid.sys (6.2.8250.0, 25.50 KB (26,112 bytes), 2/17/2012 8:35 PM)
    ---------

    Install the latest AHCI drivers for your hardware from both Intel.com and Marvell:

    Code:
    Name    Standard Dual Channel PCI IDE Controller
    Manufacturer    (Standard IDE ATA/ATAPI controllers)
    Status    OK
    PNP Device ID    PCI\VEN_1B4B&DEV_91A4&SUBSYS_91A41B4B&REV_12\4&3480BE95&0&01E6
    I/O Port    0x0000B040-0x0000B047
    I/O Port    0x0000B030-0x0000B033
    I/O Port    0x0000B020-0x0000B027
    I/O Port    0x0000B010-0x0000B013
    I/O Port    0x0000B000-0x0000B00F
    Memory Address    0xFB214000-0xFB21400F
    IRQ Channel    IRQ 19
    Driver    c:\windows\system32\drivers\pciide.sys (6.2.8250.0, 13.80 KB (14,136 bytes), 2/17/2012 9:20 PM)
        
    Name    Standard SATA AHCI Controller
    Manufacturer    Standard SATA AHCI Controller
    Status    OK
    PNP Device ID    PCI\VEN_1B4B&DEV_9120&SUBSYS_83BA1043&REV_12\4&3480BE95&0&00E6
    I/O Port    0x0000B090-0x0000B097
    I/O Port    0x0000B080-0x0000B083
    I/O Port    0x0000B070-0x0000B077
    I/O Port    0x0000B060-0x0000B063
    I/O Port    0x0000B050-0x0000B05F
    Memory Address    0xFB215000-0xFB2157FF
    IRQ Channel    IRQ 18
    Driver    c:\windows\system32\drivers\storahci.sys (6.2.8250.0, 70.30 KB (71,992 bytes), 2/17/2012 8:37 PM)
        
    Name    ATA Channel 0
    Manufacturer    (Standard IDE ATA/ATAPI controllers)
    Status    OK
    PNP Device ID    PCIIDE\IDECHANNEL\5&D32FE01&0&0
    Driver    c:\windows\system32\drivers\atapi.sys (6.2.8250.0, 26.80 KB (27,448 bytes), 2/17/2012 9:20 PM)
        
    Name    ATA Channel 1
    Manufacturer    (Standard IDE ATA/ATAPI controllers)
    Status    OK
    PNP Device ID    PCIIDE\IDECHANNEL\5&D32FE01&0&1
    Driver    c:\windows\system32\drivers\atapi.sys (6.2.8250.0, 26.80 KB (27,448 bytes), 2/17/2012 9:20 PM)
        
    Name    Standard SATA AHCI Controller
    Manufacturer    Standard SATA AHCI Controller
    Status    OK
    PNP Device ID    PCI\VEN_8086&DEV_1C02&SUBSYS_844D1043&REV_05\3&11583659&0&FA
    I/O Port    0x0000F070-0x0000F077
    I/O Port    0x0000F060-0x0000F063
    I/O Port    0x0000F050-0x0000F057
    I/O Port    0x0000F040-0x0000F043
    I/O Port    0x0000F020-0x0000F03F
    Memory Address    0xFB505000-0xFB5057FF
    IRQ Channel    IRQ 20
    Driver    c:\windows\system32\drivers\storahci.sys (6.2.8250.0, 70.30 KB (71,992 bytes), 2/17/2012 8:37 PM)
      My System SpecsSystem Spec

  5. #5


    The RealTek HD audio driver was already listed in Device Manager but I installed the latest (2.68) from your linked site.

    Intellipoint is on board. That was confirmed by attempting to install 1.0.206.0 which reported that it was already installed.

    I am unable to locate a more recent Intel SATA/AHCI driver. This one doesn't appear to be applicable to this system...
    http://downloadcenter.intel.com/Deta...er%22&lang=eng
    Have a link?

    The newest 91xx Marvel driver (that I could locate) -1.2.0.1019 - is already on the system, as mentioned earlier.

    Thanks
      My System SpecsSystem Spec

  6. #6


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Quote Originally Posted by borgus View Post
    The RealTek HD audio driver was already listed in Device Manager but I installed the latest (2.68) from your linked site.

    Intellipoint is on board. That was confirmed by attempting to install 1.0.206.0 which reported that it was already installed.

    I am unable to locate a more recent Intel SATA/AHCI driver. This one doesn't appear to be applicable to this system...
    http://downloadcenter.intel.com/Deta...er%22&lang=eng
    Have a link?

    The newest 91xx Marvel driver (that I could locate) -1.2.0.1019 - is already on the system, as mentioned earlier.

    Thanks
    This sample of my spec machine is what it looks like when the manufacturer's driver is installed:

    Code:
    Name    VIA Bus Master IDE Controller - 0571
    Manufacturer    VIA SATA/PATA IDE controllers
    Status    OK
    PNP Device ID    PCI\VEN_1106&DEV_0571&SUBSYS_72111462&REV_06\3&13C0B0C5&0&79
    I/O Port    0x0000DC00-0x0000DC0F
    Driver    c:\windows\system32\drivers\videx32.sys (7.0.7000.294, 13.65 KB (13,976 bytes), 3/9/2012 8:10 AM)
    Notice the name change and the driver name being different too, than "Standard".


    ------

    This is the Intel one to install. I would use the device manager, point to the inf, if necessary -

    http://downloadcenter.intel.com/Deta...ci%22&lang=eng

    If it isn't it, then check your motherboard manual for which chipset you have and search it for AHCI on Intel.
      My System SpecsSystem Spec

  7. #7


    Thanks for the link.
    Under IDE ATA/ATAPI controllers there is now an "Intel(R) Desktop/Workstation/Server Express Chipset SATA/AHCI controller...

    and, as I was completing this post, the PC froze once again for a full minute. ^_^ Appreciated your diligence.
      My System SpecsSystem Spec

  8. #8


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Now to install the Marvel one. Rarely, the msinfo32 does not show the motherboard model and yours is one of those cases.

    So, I assume you know which motherboard you have and if not, use CPU-Z to see. Then visit the manufacturer's site to obtain the latest Windows 7 x64 Marvel AHCI driver. Again, install using the device manager and point to the .inf, if necessary.

    You're welcome.
      My System SpecsSystem Spec

  9. #9


    As noted earlier, the latest (that I could find) Marvel 91xx SATA 6g controller driver is already on the system, as shown in Device Manager under the Storage controllers branch. Is that not the driver you are referencing?

    The board is an ASUS P8P67le. I find no such drivers on the ASUStek site. When Googling for Asus SATA/AHCI controller (or driver) the results list commercial sites with Marvel driver downloads so deeply buried in advertising (typical) that one is unable to locate the desired d/l, if it even exists. Here's but one example: http://www.driverslib.com/Motherboard/Asus/P8P67-LE/24026.html
    If you can figure it out you're the better man! What they really want to vend is an "update scanner."

    The # of the Marvel driver there is lower than the one now installed, so I assume that it is older.
      My System SpecsSystem Spec

  10. #10


    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86


    Quote Originally Posted by borgus View Post
    As noted earlier, the latest (that I could find) Marvel 91xx SATA 6g controller driver is already on the system, as shown in Device Manager under the Storage controllers branch. Is that not the driver you are referencing?

    The board is an ASUS P8P67le. I find no such drivers on the ASUStek site. When Googling for Asus SATA/AHCI controller (or driver) the results list commercial sites with Marvel driver downloads so deeply buried in advertising (typical) that one is unable to locate the desired d/l, if it even exists. Here's but one example: http://www.driverslib.com/Motherboard/Asus/P8P67-LE/24026.html
    If you can figure it out you're the better man! What they really want to vend is an "update scanner."

    The # of the Marvel driver there is lower than the one now installed, so I assume that it is older.
    Not sure what the difficulty was with following my previous post or why you're posting this link, but the Marvell driver is right on the motherboard manufacturer's page as I've said, in the SATA section of downloads:

    ASUS - Motherboards- ASUS P8P67 LE
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
Hang/Freeze update CPV
Related Threads
Windows 7/8.1 hang/lag in General Support
Toshiba Satellite A505 S6980. Windows 7 was starting to have issues. It would hesitate/hang when I went to type something, open a browser window, right-clicking, selecting an email in Thunderbird, etc. Task manager showed the disk going from 5% to 100% all the time, up and down, within the...
I've been struggling with my PC for a few weeks now, and everything I've done to fix it seems to make it worse. First things were just hanging, sometimes with a notice of "Not Responding", but often with no error message at all. (Noticed first on Secunia PSI, Outlook 2010, and Firefox) Windows...
Win 8 Hang in General Support
Hi guys, I installed Utorrent on my win8 laptop. After that found that it keep on hang n very slow. Takes so long for me to uninstall the program. The problem is my laptop still hangs even though I uninstall it. Tried to reboot my laptop few times but it still hang. Any advice ? Thanks
Random Freeze/Hang/Lag in BSOD Crashes and Debugging
Hi, I upgraded my laptop from Win 7 Home Premium x64 to Win 8 Pro x64. I am an university student so had to do it as my course required me too. I never had any errors or any bugs while using Win 7, so I assume that mean my hardware is not defective. But Win 8 in beginning crashed a lot to...
First time poster, so I appreciate any help that can be offered, as I have an annoying problem - I installed Windows 8 on Jan 28 and finally got my computer back to *just* the way I like it about a week later. Since then, I have had random freezes/reboots (no blue screens of death) every couple of...
Windows 8 Enterprise N x86 Windows update freeze in Windows Updates & Activation
Hi guys. I have a problem with Windows 8 Enterprise N x86. When i go to Control Panel\System and Security and click on Windows update that window just freeze. I cant shut it down so i have to restart explorer. System restore didn't helped. Is there any solution for that cause i cant update...
Hang ---> corruption in BSOD Crashes and Debugging
While playing audio, using either WMP or MPC, the system may hang, with a reboot the only option. This can occur after just minutes, or hours. It's then evident that the NTFS is corrupt on both the SATA drive (Win 8) and an SSD drive (W7) - all partitions. CHKDSK /f fires up. Otherwise the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook