Windows 8 and 8.1 Forums


Two different BSOD's, unpredictable timing

  1. #1

    Two different BSOD's, unpredictable timing


    Hey guys,

    First time poster here, I've always managed to fix everything myself with a little Googling, but this one's got me beaten.

    I've got two different BSODs, one of which is the "PAGE_FAULT_IN_NONPAGED_AREA", and the other always reboots so quickly that I don't have time to even read the error code.

    I've attached the logs below, help would be much appreciated

    Thanks!

    EDIT - Added another set of logs from the "dm log collector.exe" tool

      My System SpecsSystem Spec

  2. #2


    India
    Posts : 2,097
    Windows 8.1 Industry Pro B-)


    Hi Gapper100 & Welcome to the forums ^_^,

    I have analysed your dump files and below has been provided an analysis of the same for informative purposes :-
    First of all, let's check out the Page_Fault_In_Nonpaged_Area which means that a driver referenced invalid system memory. Let's first check the stack -
    Code:
    1: kd> k
    Child-SP          RetAddr           Call Site
    ffffd000`21e06188 fffff800`ce984a7f nt!KeBugCheckEx
    ffffd000`21e06190 fffff800`ce854869 nt! ?? ::FNODOBFM::`string'+0x1c8cf
    ffffd000`21e06230 fffff800`ce961f2f nt!MmAccessFault+0x7a9
    ffffd000`21e06370 fffff800`ce964525 nt!KiPageFault+0x12f
    ffffd000`21e06508 fffff800`ce889831 nt!memcpy+0xa5
    ffffd000`21e06510 fffff800`ce88b06c nt!IopCompleteRequest+0x551
    ffffd000`21e06620 fffff800`268736c9 nt!IopfCompleteRequest+0x7fc
    ffffd000`21e06730 00000000`00000156 copperhd+0x16c9
    ffffd000`21e06738 00000000`00000000 0x156
    Hmm, so what is "copperhd.sys"? It is your Razer DiamondBack's Driver. Now, Razer devices are very famous to cause BSOD's especially the drivers from 2009. Let's check the driver date of this one -
    Code:
    1: kd> lmvm copperhd
    start             end                 module name
    fffff800`26872000 fffff800`26875800   copperhd T (no symbols)           
        Loaded symbol image file: copperhd.sys
        Image path: copperhd.sys
        Image name: copperhd.sys
        Timestamp:        Tue Nov 10 13:20:17 2009 (4AF91B39)
        CheckSum:         0000ECB0
        ImageSize:        00003800
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    And there we have it.
    Now, let us have a look at the other dump file which is the KMODE_EXCEPTION_NOT_HANDLED which means that a Kernel Mode Exception was generated which could not be handled or caught by the Exception Handler. Let us take a look at the stack of this dump file -
    Code:
    2: kd> k
    Child-SP          RetAddr           Call Site
    ffffd001`3c372728 fffff800`98c5aefb nt!KeBugCheckEx
    ffffd001`3c372730 fffff800`98be4846 nt!KiFatalFilter+0x1f
    ffffd001`3c372770 fffff800`98bc2d56 nt! ?? ::FNODOBFM::`string'+0x696
    ffffd001`3c3727b0 fffff800`98bdb1ed nt!_C_specific_handler+0x86
    ffffd001`3c372820 fffff800`98b683a5 nt!RtlpExecuteHandlerForException+0xd
    ffffd001`3c372850 fffff800`98b6725f nt!RtlDispatchException+0x1a5
    ffffd001`3c372f20 fffff800`98bdf8c2 nt!KiDispatchException+0x61f
    ffffd001`3c373610 fffff800`98bde014 nt!KiExceptionDispatch+0xc2
    ffffd001`3c3737f0 fffff801`0c6a2c1a nt!KiPageFault+0x214
    ffffd001`3c373988 fffff801`0c67005a e1i63x64+0x4fc1a
    ffffd001`3c373990 ffffe001`6f48d000 e1i63x64+0x1d05a
    ffffd001`3c373998 00000000`00002000 0xffffe001`6f48d000
    ffffd001`3c3739a0 00000000`00000000 0x2000
    So, in this case there is the presence of your Intel Gigabit Adapter which caused a Page Fault.
    Code:
    2: kd> lmvm e1i63x64
    start             end                 module name
    fffff801`0c653000 fffff801`0c6c7000   e1i63x64 T (no symbols)           
        Loaded symbol image file: e1i63x64.sys
        Image path: e1i63x64.sys
        Image name: e1i63x64.sys
        Timestamp:        Wed Mar 20 13:07:29 2013 (51496739)
        CheckSum:         0007FF34
        ImageSize:        00074000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    So, according to the above analysis :-

    • Please either remove your Razer DiamondBack (Physically Detach it from the system) or find an updated version of the driver which is compatible with the Windows 8.1. You can visit **THIS** link for more information.
    • Please find an updated version for your Intel Gigabit Adapter. You can visit **THIS** link for more information.



    Let me know how it goes ^_^
      My System SpecsSystem Spec

  3. #3


    Hey blueelvis,

    Thank you so much for your reply! I've addressed both issues as follows. I've removed my Razer Copperhead and replaced it with a Roccat Kova+ I still had lying around, deinstalled al the Razer drivers and installed the Roccat ones. So as far as the mouse is concerned, that should be fixed.

    As for the ethernet drivers, I downloaded and installed the 64-bit version of this file, so I think that should be okay as well.

    I suppose all I can do now is wait and see if it happens again. If so, I'll post here, but until then; thank you very much!
      My System SpecsSystem Spec

  4. #4


    India
    Posts : 2,097
    Windows 8.1 Industry Pro B-)


    Quote Originally Posted by gapper100 View Post
    Hey blueelvis,

    Thank you so much for your reply! I've addressed both issues as follows. I've removed my Razer Copperhead and replaced it with a Roccat Kova+ I still had lying around, deinstalled al the Razer drivers and installed the Roccat ones. So as far as the mouse is concerned, that should be fixed.

    As for the ethernet drivers, I downloaded and installed the 64-bit version of this file, so I think that should be okay as well.

    I suppose all I can do now is wait and see if it happens again. If so, I'll post here, but until then; thank you very much!
    Sure thing. Let me know how it goes ^_^
      My System SpecsSystem Spec

  5. #5


    Quote Originally Posted by blueelvis View Post
    Quote Originally Posted by gapper100 View Post
    Hey blueelvis,

    Thank you so much for your reply! I've addressed both issues as follows. I've removed my Razer Copperhead and replaced it with a Roccat Kova+ I still had lying around, deinstalled al the Razer drivers and installed the Roccat ones. So as far as the mouse is concerned, that should be fixed.

    As for the ethernet drivers, I downloaded and installed the 64-bit version of this file, so I think that should be okay as well.

    I suppose all I can do now is wait and see if it happens again. If so, I'll post here, but until then; thank you very much!
    Sure thing. Let me know how it goes ^_^
    Unfortunately, I had another BSOD this morning... I was not even using the PC, it was just sitting there, locked (Win-key + L) when it suddenly crashed, rebooted, and gave me the black screen saying "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device" (you know the screen).

    Attachment 52399

    Absolutely no idea what's going on. Attached another set of logs to this post, would be amazing if you could take another look.

    Thanks again

    EDIT - I see AMD released a 14.9.1 beta driver update, because some users reported crashes and/or BSOD's with 14.9. This might solve it, so I'm going to try installing those, will keep you posted.
    Last edited by gapper100; 13 Oct 2014 at 04:57.
      My System SpecsSystem Spec

  6. #6


    India
    Posts : 2,097
    Windows 8.1 Industry Pro B-)


    Hi Gapper100 ^_^,

    Unfortunately, the dump files contained by the ZIP File is not the latest. It points to your earlier issue. Can you manually check if there are new Dump files in the folder - "C:\Windows\Minidumps\" or is there a big memory Dump at the path "C:\Windows\Memory.DMP" which has the latest time stamp?

    Are you sure that the BSOD Happened?

    Let me know how it goes ^_^
      My System SpecsSystem Spec

  7. #7


    Quote Originally Posted by blueelvis View Post
    Hi Gapper100 ^_^,

    Unfortunately, the dump files contained by the ZIP File is not the latest. It points to your earlier issue. Can you manually check if there are new Dump files in the folder - "C:\Windows\Minidumps\" or is there a big memory Dump at the path "C:\Windows\Memory.DMP" which has the latest time stamp?

    Are you sure that the BSOD Happened?

    Let me know how it goes ^_^
    Hey blueelvis,

    It appears you're right: Neither the "C:\Windows\Minidump\" folder, nor the "C:\Windows\MEMORY.DMP" contains a log that is newer than 29-09-2014. I'm sure it crashed, twice even, but it must have been something other than a BSOD then.

    However, since I flashed those updated drivers I mentioned above (AMD Catalyst 14.9.1 beta drivers), no crashes have occurred whatsoever. So I think that must have been it.

    Thanks again for looking into this! Let's hope everything is settled now
      My System SpecsSystem Spec

  8. #8


    India
    Posts : 2,097
    Windows 8.1 Industry Pro B-)


    Sure thing, let me know how it goes ^_^

    In case of any further problems, do not hesitate to post back ^_^
      My System SpecsSystem Spec

Two different BSOD's, unpredictable timing
Related Threads
I'm having problems with the windows installer taking a long time installing something. I tried installing a couple programs and the installer box would come on screen, nothing would be happening for the longest time. Then, another box would come up saying something like retry or cancel. I would...
I have been getting a ton of bsods I have re installed video drivers, updated and reinstalled windows 8. Did countless hardware test(Video ram, check memory, Cpu test) all passed temperatures stay around 25-35 c. Recently uninstalled all video drivers and re installed. The bsods sometimes go away...
Solved BSOD - seems random and unpredictable in BSOD Crashes and Debugging
Greetings, I'm getting that deja-vu feeling. Its been a couple years since I've been through the BSOD experience and now its happening in my new computer build and Windows 8.1 Pro. Previously the SevenForums did a bang up job of helping me sort it out so I'm really happy there is an...
Hi all, In the last week my laptop has spat the dummy and most programs will not connect to the internet. It's a ~3 year old HP that came with W7 that I upgraded to W8 about 6 weeks ago. Internet was working fine until last week. Chrome and Firefox will not connect - all connections time out...
I have a clients Laptop (Asus X550C) running Windows 8 and the first error I had was 0xc0000034, having a look around I tried some fixes but none worked, eventually I was left with the following error: 0xc0000001. As of now I am stuck here, I have a backup of the main files the client needs but do...
Solved File History timing of backup in Performance & Maintenance
I was happy to discover that Windows 8 came with a program to automatically back up our files to our external HD, but it frustrates me that I cannot specify a time for that to happen. Daily is more than frequent enough for us, but we don't keep our computer on 24/7. If we did, does file history...
Solved Unpredictable shut down behavior in BSOD Crashes and Debugging
Guys, I installed Win 8 Preview on my two PCs and laptop months ago. Recently, all of them started having shutting down problem. when shutting down there were notice that windows isn't properly shut down, need to restart, then restarted. Sometimes it just restarted when shut down without any...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook