Windows 8 and 8.1 Forums


Continues Errors at startup "Metadata staging failed"

  1. #151


    Posts : 23
    8.1


    Thanks for the update, mine disappeared for a few days, however when I received the email notification for this thread I looked and there are 27 when I rebooted this morning.
    They are the only ones in the last 7 days, there are also an equal amount of "A connection to the Windows Metadata and Internet Services (WMIS) could not be established" in warnings.
    It works it just takes too long and is creating these logs as far as I can see.
    Thanks again.

      My System SpecsSystem Spec

  2. #152


    Posts : 81
    Windows 8 Home Premium 64 bit


    [QUOTE=wrogg;504569]Thanks for the update, mine disappeared for a few days, however when I received the email notification for this thread I looked and there are 27 when I rebooted this morning.
    They are the only ones in the last 7 days, there are also an equal amount of "A connection to the Windows Metadata and Internet Services (WMIS) could not be established" in warnings.
    It works it just takes too long and is creating these logs as far as I can see.


    Thanks for that, it is appreciated. I agree this appears to be time related but I am not a wizard with these things and I think it is fair to say I have dug a deep hole and cannot dig any deeper, I have exhausted my knowledge base.

    However, following this in the event log this task runs on what is stated as 'regular intervals' my perception of this:

    If you refresh your hardware page it will run on demand
    If you install a new device, it will run
    If you do nothing it will run every 7 days.

    merely my perception but if you 'do nothing' it does tend to make you think it has vanished until you get to the 7th day then the error re-appears.

    With reference to your warnings - the numbers will correspond, hopefully to the number of devices the metadata is trying to refresh. Initially I had the warnings too, since I checked for Windows updates manually and somehow appeared to get a fast connection to WMIS -the warnings have gone away, temporary or permanent remains to be seen. The Errors remain.
    Kind Regards
    For now, I am observing and leaving Microsoft to continue the digging.
      My System SpecsSystem Spec

  3. #153


    Posts : 23
    8.1


    That would make sense. I did update my Nvidia driver last night, but yes it is the seventh day!
      My System SpecsSystem Spec

  4. #154


    N.Y.
    Posts : 2,214
    Windows 10 Pro 64bit


    Quote Originally Posted by amtino View Post
    Hi just to keep you up to date with the loop:

    I received a further call from the Level 3 Support Engineer as promised.

    We have established thus far that event id 31 ' metadata staging failed' is generated by the Task Scheduler running the task to update Hardware and Devices, this uses the forwarding url which we believe is malfunctioning.

    I am no longer stating that this url fails: It doesn't - When you see event id131 'metadata staging failed' e.g. 9.31 am if you trace back this event and read all the events in the Application Log you will see that following the red cross for the error 131 you will get the success mark within a few milliseconds stating the event did indeed complete - processed x number of tasks and updated etc etc.

    What we have not established is why the url is taking so long to forward thus allowing the operating system to think this task has failed just a few seconds prior to it completing.

    We do know that removing the link in the registry and going directly to device metadata prevents this error occurring and obviously gives a faster more direct update via the Microsoft Server.

    I have also noticed a slight time lag with other things on the system, pop-up blocks in IE etc seem to be a little behind times and often appear on the second time of opening or the second click of the Mouse rather than the first. eg after resetting IE you see the pop-up the first time you sign into a site for example your email ' do you want IE to remember your passwords? Don't Ask me again etc. This no longer appears on the first launch.

    I have passed all this to the engineer, he has tested this on his own system and traced the events, he agrees it 'may' be a time issue on the server. Note updating and resyncing to Windows Time has a negative result.

    What happens next - all these recordings and observations have been passed to ' the back end team' to investigate the hold up in this url to establish why things are not happening at the correct speed.

    I have been asked to give them time and assured I will receive a further call on Friday or Saturday. I will keep you all updated.

    In the meantime, if anyone observes anything they think may be relevant or of assistance please post this, as every little helps.

    In the meantime I was very interested to note on the roll out of Windows 10 Options icon yesterday, there are notes in the article that state some forwarding url links are not working ..... Windows 10 to follow in the footsteps of Windows 8 maybe???

    Update for Windows 7 and 8.1 silently installs Windows 10 downloader - Myce.com
    Nice to hear they responded back, good work Amtino again. Where in the Application log are you seeing this, trying to find it ? For me i used to get almost 8 or so Metadata failed a day, lately in the past days i am only getting 2 a day now.

    So much to keep up with lately as had issues with an update causing sfc not being able to fix corrupt files, KB3022245. Has to do with enabling Diagnostic tracking service be in Services.msc. At first showed as a optional i never installed it, but then it slipped by me as becoming important or recommended as i take those updates, i uninstalled it, but it came back.

    Besides this then there is the other recommended update brought in the Windows 10 icon for reserving. Hopefully even if article feels this will be issues with servers on Win 10 probably would seem right since it's on Windows 8.1 for some already as issue effects both, but why only some complaining unless most are unaware of event viewer errors happening.
      My System SpecsSystem Spec

  5. #155


    Posts : 81
    Windows 8 Home Premium 64 bit


    Hi

    Some users may never even open 'Event Viewer' Some may only check once a month - therefore they may or may not be aware of the issue at present. Unfortunately for me I have this terrible habit of checking the Event Log immediately after Booting up and also before Shutting Down -

    with reference to the number of errors we see at any given time and how often depends when the metadata task runs:

    If you refresh your hardware page it will run on demand Click on Hardware Sound>Devices and Printers> Click a Blank space and click refresh - running this task on demand 'should' produce a number of errors equivalent to the number of devices you have installed or are refreshing at that time.


    If you install a new device, it will run automatically, this would only produce one or two errors depending on how long the task takes to complete - which at present we know is just 'not fast enough' So for one new device I see 2 errors at present

    If you do nothing it will run every 7 days - this is my perception of the task stating ' the task will run at regular intervals' - again you would see a larger number of errors as the task will try to update all devices during this scheduled task. It is running weekly on my system.


    To view the full log and see exactly what is occurring:


    Event Viewer >Open Applications & Services>Microsoft Folder>Windows Folder>Device Set-up Manager Folder:> Admin Log

    You should see the errors closely followed by the success: we are talking seconds but a long enough delay to product the error to say the task failed:

    eg From my log:

    Error Time 3.07.10 - Device Metadata Staging failed for container 00000 - FFFFF etc etc


    Information Log directly above: - Device Desktop Pc container 00000 - FFFFF etc etc has been serviced: Processed 1 Task, wrote 34 properties, active worktime 868 milliseconds


    Information Log directly above - Time 3.09.01 DSM Service shutting down - Service uptime was 440 seconds active workrtime was 3650 Milliseconds


    If you view the Operational Logs you will see the confirmation that the task completed successfully.



    Hope this helps - your continued interest and support is appreciated. Thank You
      My System SpecsSystem Spec

  6. #156


    N.Y.
    Posts : 2,214
    Windows 10 Pro 64bit


    Quote Originally Posted by amtino View Post
    Hi

    Some users may never even open 'Event Viewer' Some may only check once a month - therefore they may or may not be aware of the issue at present. Unfortunately for me I have this terrible habit of checking the Event Log immediately after Booting up and also before Shutting Down -

    with reference to the number of errors we see at any given time and how often depends when the metadata task runs:

    If you refresh your hardware page it will run on demand Click on Hardware Sound>Devices and Printers> Click a Blank space and click refresh - running this task on demand 'should' produce a number of errors equivalent to the number of devices you have installed or are refreshing at that time.


    If you install a new device, it will run automatically, this would only produce one or two errors depending on how long the task takes to complete - which at present we know is just 'not fast enough' So for one new device I see 2 errors at present

    If you do nothing it will run every 7 days - this is my perception of the task stating ' the task will run at regular intervals' - again you would see a larger number of errors as the task will try to update all devices during this scheduled task. It is running weekly on my system.


    To view the full log and see exactly what is occurring:


    Event Viewer >Open Applications & Services>Microsoft Folder>Windows Folder>Device Set-up Manager Folder:> Admin Log

    You should see the errors closely followed by the success: we are talking seconds but a long enough delay to product the error to say the task failed:

    eg From my log:

    Error Time 3.07.10 - Device Metadata Staging failed for container 00000 - FFFFF etc etc


    Information Log directly above: - Device Desktop Pc container 00000 - FFFFF etc etc has been serviced: Processed 1 Task, wrote 34 properties, active worktime 868 milliseconds


    Information Log directly above - Time 3.09.01 DSM Service shutting down - Service uptime was 440 seconds active workrtime was 3650 Milliseconds


    If you view the Operational Logs you will see the confirmation that the task completed successfully.



    Hope this helps - your continued interest and support is appreciated. Thank You
    Well i have had same devices on my PC since this event started, no changes. I see what you mean in operational logs, but same to me shows in Device Set-up Manager folder under Admin as it does in Custom Views folder under Administrator events. As said less Metadata failed in past days as from before was more errors.

    Your welcome, i always have interest an try to be supportive when comes to PC help, all in all you are learning a lot more then you needed to, but making you more knowledgeable in long run, keep up the good work !
      My System SpecsSystem Spec

  7. #157


    Posts : 81
    Windows 8 Home Premium 64 bit

    Registry key default values


    I am still looking at this naturally and just out of interest I have spotted some different values in the registry here on some of my machines:

    If any of you get a moment can you look at the following and tell me value Binar Value you see - ie. what is the default value 0 or 1?

    Thanks so much
    HKEY LOCAL MACHINE
    SOFTWARE
    MICROSOFT
    WINDOWS
    CURRENT VERSION
    DEVICE METADATA

    Next to last item in tree: Prevent Device Metadata from Network - Binary Value does it read 0 or 1? If have conflicting issues here and someone with an unamended registry can perhaps tell me the default value please?

    Cheers
      My System SpecsSystem Spec

  8. #158


    Posts : 1,121
    Windows 8.1 x64


    Mine Shows 0

    This is what it shows for the DeviceMetadataServiceURL

    go.microsoft.com/fwlink/?LinkID=252669&clcid=0x409
      My System SpecsSystem Spec

  9. #159


    Posts : 81
    Windows 8 Home Premium 64 bit


    Quote Originally Posted by Saltgrass View Post
    Mine Shows 0

    This is what it shows for the DeviceMetadataServiceURL

    go.microsoft.com/fwlink/?LinkID=252669&clcid=0x409
    Thanks for your response, do you see event ID 131 'metadata staging failed ' in your event log?
      My System SpecsSystem Spec

  10. #160


    N.Y.
    Posts : 2,214
    Windows 10 Pro 64bit


    Mine also shows 0 and DeviceMetaDataServiceURL http://go.microsoft.com/fwlink/?Link...69&clcid=0x409
      My System SpecsSystem Spec

Page 16 of 27 FirstFirst ... 6141516171826 ... LastLast
Continues Errors at startup "Metadata staging failed"
Related Threads
The title says it partially, but that's not the whole story: I decided to use OneDrive, and so I sent a folder from my external Toshiba drive to OneDrive. It took forever and three days to finish, and seemingly isn't finished yet. :( I now get, File Failed to Upload -- There was an error...
So I restored my system because I had no other choice from it not booting before and it was working for a day, then when I restarted it said 'installing XX / 93 updates' so I let that run, and when It finally finished, it restarted said 'configuring windows updates XX% complete...' and then it...
Specs: Acer AO756-2808 Netbook Intel Celeron CPU 877 @ 1.40Ghz Intel HD Graphics 2000 Windows 8.1 Pro 64Bit 8G Dual Ram 120SSD Updated Intel Chipset 9.4.0.1026, Intel HD Graphics 2000 9.17.10.3347, and Intel MGMTEngine 9.5.14.1724
Hello, Actually this is more than errors in the Services Console Panel. I have several errors with my fresh install of Windows 8 Pro which I have never experienced before. What also boggles me with all this is that my user account is set as Administrator as usual, but still Windows behaves as it...
When i start my computer i get that error in the bottom left,i used hijackthis and this is the report: Logfile of Trend Micro HijackThis v2.0.4 Scan saved at 10:23:07, on 27/07/2013 Platform: Unknown Windows (WinNT 6.02.1008) MSIE: Internet Explorer v10.0 (10.00.9200.16537) Boot mode: Normal...
Hi there, I am facing a problem with the backup program of Windows 8. My computer (Asus with 250SSD) disk is new and I just installed my programs. Now I want to create a System Image using Windows. The image should be around 50go. Everything works fine until I get a message error saying my...
Hey all Tearing my hair out with my 32bit W7 to W8 pro upgrade here.. :(. Setup gets to 24% and then bombs out with "Windows 8 installation has failed". The logs say.. 2012-10-27 21:01:41, Error Error while getting snapshot properties of fixed drive 2: 0x80042308...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook