Windows 8 and 8.1 Forums

BSOD When Attaching External USB 3 Hard Drive

  1. #1

    Posts : 4
    Server 2012 R2

    BSOD When Attaching External USB 3 Hard Drive

    I'm running Windows Server 2012 R2 on a Dell Poweredge R310. I just bought a G-RAID 8TB external USB 3 hard drive. I plugged the hard drive in and when I switched it on the computer crashed.

    I didn't notice right away since the computer is headless. But when I got back to my desk I noticed the computer was rebooting. When it fished POST it gave me some warning about IRQL_NOT_LESS_EQUAL and rebooted again.

    I removed the USB drive and now the computer is running fine.

    Can someone tell what the problem is from this minidump?


      My System SpecsSystem Spec

  2. #2

    Posts : 4
    Server 2012 R2

    By the way, the USB port I used is a USB 2.0 port.
      My System SpecsSystem Spec

  3. #3

    Posts : 5,139
    Win8.1Pro - Finally!!!

    The uploaded reports are incomplete, please re-run the data collection app and let it run for at least 15 minutes (or until the app itself says that it's done): Blue Screen of Death (BSOD) Posting Instructions Please use Option 1 as it provides Event Viewer logs.

    Please make sure that you have ALL available Windows Updates.

    The memory dump blames uaspstor.sys - a driver for your USB. Here's a link that describes this new Windows driver: USB in Windows - FAQ (Windows Drivers)

    FWIW - rarely are Windows drivers at fault. If they were, the system file checker and other protection mechanisms would have to be broken down. The most likely culprit here is an unidentified 3rd party driver.
    Just FYI - here's how I do BSOD analysis':
    - first I rule out 3rd party drivers (over 90% of BSOD's are due to this)
    - then I rule out hardware (less than 10% of BSOD's are due to this)
    - then I look at Windows problems (less than 1% of BSOD's are due to this - as long as Windows Updates are fully up to date).

    The easiest way to troubleshoot this would be to run Driver Verifier according to these instructions: Driver Verifier Settings If this is a production server, I'd understand if you can't run it easily.

    You can start with updating these drivers. They are date stamped from before Win8.1 was released, so they are the most likely suspects at this point:

    The following is for informational purposes only.
    **************************Tue Aug  5 16:33:12.732 2014 (UTC - 4:00)**************************
    Loading Dump File [C:\Users\John\SysnativeBSODApps\080514-13875-01.dmp]
    Windows 8 Kernel Version 9600 MP (4 procs) Free x64
    Built by: 9600.17085.amd64fre.winblue_gdr.140330-1035
    System Uptime:0 days 0:00:05.412
    *** WARNING: Unable to verify timestamp for uaspstor.sys
    *** ERROR: Module load completed but symbols could not be loaded for uaspstor.sys
    Probably caused by :uaspstor.sys ( uaspstor+a13b )
    BugCheck D1, {ffffe0019566cf34, 2, 0, fffff8016ca3013b}
    Arg1: ffffe0019566cf34, memory referenced
    Arg2: 0000000000000002, IRQL
    Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
    Arg4: fffff8016ca3013b, address which referenced memory
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID: AV_uaspstor+a13b
      BIOS Version                  1.12.0
      BIOS Release Date             09/06/2013
      Manufacturer                  Dell Inc.
      Product Name                  PowerEdge R310
    3rd Party Drivers:
    The following is for information purposes only.
    Any drivers in red should be updated or removed from your system. And should have been discussed in the body of my post.
    **************************Tue Aug  5 16:33:12.732 2014 (UTC - 4:00)**************************
    bxvbda.sys                  Mon Feb  4 14:47:18 2013 (51101046)
    bxnd60a.sys                 Tue Jun 11 19:33:25 2013 (51B7B3C5)
    dump_megasas.sys            Tue Jul 23 17:08:29 2013 (51EEF0CD)
    megasas.sys                 Tue Jul 23 17:08:29 2013 (51EEF0CD)
    dcdbas64.sys                Tue Aug 13 07:12:21 2013 (520A1495)
    intelppm.sys                Thu Aug 22 04:46:35 2013 (5215CFEB)
    dump_megasas.sys - this driver hasn't been added to the DRT as of this run. Please search Google/Bing for the driver if additional information is needed.
      My System SpecsSystem Spec

  4. #4

    Posts : 4
    Server 2012 R2

    Hi usasma,

    Thanks for looking into this.

    Here are the complete reports.

    Windows Update doesn't tell me that new drivers are available. Maybe the ones you listed are from before the release of Windows 8.1 because this is a Server 2012 R2 OS?
      My System SpecsSystem Spec

  5. #5

    Posts : 5,139
    Win8.1Pro - Finally!!!

    Nothing very revealing in the reports, but there are many, many Windows Update failures in the WER section of MSINFO32.
    I'd suggest a visit to the Windows Update and Activation forum to see if they can help: Windows Updates & Activation - Windows 8 Forums

    Beyond that, I'd suggest troubleshooting the USB ports to make sure that the rest are working properly. Trying the offending device in each USB port would be the best - but again, if this is a production server it may disrupt your operations.
      My System SpecsSystem Spec

  6. #6

    Posts : 4
    Server 2012 R2


    I tried the USB hard drive in both front USB ports and server crashes either way. I tried one of the back USB ports and everything seems fine though. As far as I know, both front and back USB ports are USB 2.0.
      My System SpecsSystem Spec

  7. #7

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    Quote Originally Posted by movezig View Post

    I tried the USB hard drive in both front USB ports and server crashes either way. I tried one of the back USB ports and everything seems fine though. As far as I know, both front and back USB ports are USB 2.0.
    Chances you might have a defective/shorted/loose cable that connected from the MB to the front USB ports.
      My System SpecsSystem Spec

BSOD When Attaching External USB 3 Hard Drive
Related Threads
Windows 8.1 Pro 64-bit. I have a second DVD recorder that's an IDE connection. The PC I just built doesn't have any IDE connectors and I don't want to mess with adding anything. I'd like to connect the DVD to use when needed (yes, I have SATA DVD burners in the box, but this one is a...
Hard drive crash enquiry My hard drive recently crashed on my desktop running XP and due to the discontinuation of support for XP, I decided to upgrade with a new motherboard, memory, hard drive etc., now running Win 8.1, which has been working fine so far. My problem is that there is...
new external hard drive in Drivers & Hardware
Hello I have a pc which uses 2.0 usb. I want a new external hard drive, with no adapters. Can my pc work with a one with 3.0 if that's all I can find? I think it will work at 2.0 speeds but am asking to be sure. I know the upgrade would be better but I don't want to buy a new pc just for the...
Solved External hard drive in Drivers & Hardware
I'm installing a new toshiba 1 TB external hard drive & it is formatted NTSF.I'v all ways heard you must format high capacity drives to fat 32.Which is correct & why Thanks
I'm at the point of no return with Hyper V.:mad: I have finally gotten access to the Internet.:rolleyes: For the next step, can someone point out where I can find Step-by-Step instructions to gain access to a Host Hard Drive from the VM. I have the MS Windows 8 Inside Out and it is of no help. For...
I have a 2TB Western Digital My Book Essentials, it's filled with tons of old photos, movies, docs, games, and I'm scared to think of what else. The SATA to USB connector broke on it, so I took the drive apart and put it inside my computer. I opened up device manager because it wasn't showing up...
Hi All, I have been having an issue with Windows 8 RTM (N Version). I get BSOD everytime I try to copy files to an external hard drive (1 TB Seagate Freeagent). I was trying to copy 500 GB of data, but it keeps failing with a BSOD. I have also tried copying files in smaller sizes (20 GB each),...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook